Bug 27860 - /usr/bin/ab2 mispackaged
: /usr/bin/ab2 mispackaged
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/apache2-base)
: unstable
: all Linux
: P3 major
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2012-10-16 20:54 by
Modified: 2012-10-20 19:02 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2012-10-16 20:54:06
[altlinux@eeelive scheduler]$ sudo apt-get install /usr/bin/ab2
[sudo] password for altlinux:
Reading Package Lists... Done
Building Dependency Tree... Done
Selecting apache2-base for '/usr/bin/ab2'
The following extra packages will be installed:
  apache2-base apache2-common apache2-httpd-worker condstopstart-common
condstopstart-web libapr1 libaprutil1
The following NEW packages will be installed:
  apache2-base apache2-common apache2-httpd-worker condstopstart-common
condstopstart-web libapr1 libaprutil1
0 upgraded, 7 newly installed, 0 removed and 39 not upgraded.
Need to get 920kB of archives.
After unpacking 2732kB of additional disk space will be used.
Do you want to continue? [Y/n] 

Интересно, кому-нибудь приходило в голову, что делать бенчмарк произвольного
http сервера и запускать на своей машине apache2 - это две немножко разные
задачи?
------- Comment #1 From 2012-10-16 22:10:02 -------
Присоединяюсь к просьбе запаковать ab2 отдельно.
------- Comment #2 From 2012-10-17 15:59:36 -------
  OK. Какие части apache2 нужно для корректной работы /usr/bin/ab2?
------- Comment #3 From 2012-10-17 16:36:47 -------
(В ответ на комментарий №2)
>   OK. Какие части apache2 нужно для корректной работы /usr/bin/ab2?

Никаких, libapr само подтянется.

Ещё бы /usr/bin/htpasswd2 вынести. Оно для нгинкса тоже сгодится.
------- Comment #4 From 2012-10-17 17:53:38 -------
  Тогда создаю пакеты apache2-{ab,htpasswd} и пакет apache2 (не apache2-base)
будет их требовать.
------- Comment #5 From 2012-10-17 18:55:08 -------
Хорошо. Спасибо.
------- Comment #6 From 2012-10-17 19:20:56 -------
apache2-2.2.22-alt9 -> sisyphus:

* Wed Oct 17 2012 Aleksey Avdeev <solo@altlinux> 2.2.22-alt9
- Move %_bindir/ab2 to %name-ab subpackage (Closes: #27860)
- Move %_bindir/htpasswd2 to %name-htpasswd subpackage
------- Comment #7 From 2012-10-20 19:02:35 -------
(В ответ на комментарий №4)
>   Тогда создаю пакеты apache2-{ab,htpasswd} и пакет apache2 (не apache2-base)
> будет их требовать.

  Это для Сизифа.

  В бранчах (p6/t6/5.1/p5/5.0), дабы не поломать обратную совместимость, пакеты
apache2-{ab,htpasswd} будет требовать apache2-base.