Bug 29033 - Не монтируются шифрованные разделы LUKS и не стартует Xorg
: Не монтируются шифрованные разделы LUKS и не стартует Xorg
Status: CLOSED WORKSFORME
: ALT Linux Centaurus
(All bugs in ALT Linux Centaurus/Установка)
: 7.0.1
: all Linux
: P3 normal
Assigned To:
:
:
:
: 29066
:
  Show dependency tree
 
Reported: 2013-05-30 18:14 by
Modified: 2013-11-05 13:30 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2013-05-30 18:14:44
Не монтируются шифрованные разделы и не запускается графический режим.

При установке на 2 раздела -- / и шифрованный /home(пароль 123) при загрузке не
запускается Xorg и идет ругань про "все-подряд не могу, т.к. read-only".
------- Comment #1 From 2013-05-30 18:26:45 -------
Можно ещё ссылку на конкретный образ, при установке которого такое
воспроизводится?  LUKS вообще-то при этой переработке проверялся и
дорабатывался.
------- Comment #2 From 2013-05-30 18:33:02 -------
altlinux-7.0.0_beta-20130520-kdesktop-x86_64-ru-install-dvd5.iso
altlinux-p7-kde4-20130428-i586.iso
и x86_64 образ kdesktop, собранный с task#97874
------- Comment #3 From 2013-05-30 18:41:38 -------
(В ответ на комментарий №1)
> LUKS вообще-то при этой переработке проверялся и дорабатывался.
На altlinux-p7-kde4-20130428-i586.iso даже пароль не спросил. Отключал сплеш по
Esc.
------- Comment #4 From 2013-05-30 18:43:09 -------
Я всё пробовал в VirtualBox.
------- Comment #5 From 2013-05-30 19:13:46 -------
(In reply to comment #3)
> На altlinux-p7-kde4-20130428-i586.iso даже пароль не спросил.
> Отключал сплеш по Esc.
Да, со сплэшем там были грабли.  Точнее сейчас не вспомню сходу...
------- Comment #6 From 2013-05-30 22:30:36 -------
(В ответ на комментарий №5)
> Да, со сплэшем там были грабли.
На бете KDesktop диалог пароля появляется поверх splash.
------- Comment #7 From 2013-05-30 22:37:17 -------
(В ответ на комментарий №6)
> На бете KDesktop диалог пароля появляется поверх splash.
Правда, там не нарисовано ничего, из чего можно догадаться, что за пароль оно
вообще хочет.
------- Comment #8 From 2013-05-31 10:44:44 -------
(В ответ на комментарий №7)
> (В ответ на комментарий №6)
> > На бете KDesktop диалог пароля появляется поверх splash.
> Правда, там не нарисовано ничего, из чего можно догадаться, что за пароль оно
> вообще хочет.
В Simply Linux рисуется замок и пустое поле ввода. Там не воспроизводится.
------- Comment #9 From 2013-05-31 12:10:54 -------
(В ответ на комментарий №8)
> рисуется замок
Я ж говорю, не рисуется, на чем этот замок висит.
------- Comment #10 From 2013-05-31 12:34:20 -------
(В ответ на комментарий №8)
> (В ответ на комментарий №7)
> > (В ответ на комментарий №6)
> > > На бете KDesktop диалог пароля появляется поверх splash.
> > Правда, там не нарисовано ничего, из чего можно догадаться, что за пароль оно
> > вообще хочет.
> В Simply Linux рисуется замок и пустое поле ввода. Там не воспроизводится.

Дальше нормально грузится?
------- Comment #11 From 2013-05-31 12:48:39 -------
(В ответ на комментарий №10)
> > В Simply Linux рисуется замок и пустое поле ввода. Там не воспроизводится.
> 
> Дальше нормально грузится?
Если указан правильный пароль на LUKS - да.
------- Comment #12 From 2013-05-31 16:10:42 -------
(В ответ на комментарий №11)
> Если указан правильный пароль на LUKS - да.
Пароль -- "123"?
Какой именно "Simply Linux"? Последняя бета 7-го?
------- Comment #13 From 2013-05-31 17:06:28 -------
(В ответ на комментарий №12)
> (В ответ на комментарий №11)
> > Если указан правильный пароль на LUKS - да.
> Пароль -- "123"?
Нет, конечно. Там каждый раз я что-то новое придумываю. На этот раз было «h».

> Какой именно "Simply Linux"? Последняя бета 7-го?
Да, от 29.05.2013
------- Comment #14 From 2013-05-31 19:28:53 -------
(В ответ на комментарий №8)
> В Simply Linux 
[...]
> не воспроизводится.
Подтверждаю.
------- Comment #15 From 2013-06-10 17:57:54 -------
Только что поймал то же, но с нешифрованными разделами сегодняшнем образе из
сегодняшнего p7. 3 обычных раздела: /, /home и swap .

Какая информация нужна?
------- Comment #16 From 2013-06-10 18:47:45 -------
(В ответ на комментарий №15)
> Только что поймал то же, но с нешифрованными разделами
Это #29066
------- Comment #17 From 2013-06-10 20:44:09 -------
Давай пока так и пометим -- если окажутся дубли, эту закроем.
------- Comment #18 From 2013-06-10 21:24:56 -------
Как-минимум, последствия очень схожи.
------- Comment #19 From 2013-11-05 11:51:24 -------
Альт Линукс 7.0.1 Кентавр.
Дистрибутив
ftp://ftp.altlinux.org/pub/distributions/ALTLinux/p7/images/centaurus/altlinux-7.0.1-centaurus-i586-ru-install-dvd5.iso
Не монтирует шифрованные разделы, не запускается.
Отсутствуют библиотеки mount.crypt (а равно как и линки на  mount.crypt_LUKS и
mount.crypto_LUKS) - при установке не установились.
Пароль не спрашивает, система не грузится вовсе.
------- Comment #20 From 2013-11-05 13:30:08 -------
(В ответ на комментарий №19)
> Альт Линукс 7.0.1 Кентавр.
> Дистрибутив
> ftp://ftp.altlinux.org/pub/distributions/ALTLinux/p7/images/centaurus/altlinux-7.0.1-centaurus-i586-ru-install-dvd5.iso
> Не монтирует шифрованные разделы, не запускается.
> Отсутствуют библиотеки mount.crypt (а равно как и линки на  mount.crypt_LUKS и
> mount.crypto_LUKS) - при установке не установились.
> Пароль не спрашивает, система не грузится вовсе.
Посмотрел под капот: нужный пакет pam_mount ставится в профиле desktop-mate (то
есть в группе "Среда MATE"). Однако, при установке и в профиле "Офисный сервер"
в centaurus-7.0.1 (x86_64) раздел создаётся и затем нормально функционирует
(даже без pam_mount) через /dev/mapper/luks-<UID number>.

В общем, проверил на всех профилях (минимальный, офисный сервер, MATE/Systemd)
— нигде не воспроизводится. При этом каждый раз я удалял и заново создавал
шифрованный раздел.