Bug 29066 - Не монтирует /tmp
: Не монтирует /tmp
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/systemd)
: unstable
: all Linux
: P3 normal
Assigned To:
:
:
:
:
: 27685 29033
  Show dependency tree
 
Reported: 2013-06-10 18:45 by
Modified: 2013-06-17 16:09 (History)


Attachments
/etc/fstab (433 bytes, text/plain)
2013-06-10 18:46, Sergey V Turchin
no flags Details
fdisk -l (562 bytes, text/plain)
2013-06-10 18:47, Sergey V Turchin
no flags Details


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2013-06-10 18:45:33
С прилагаемым fstab система не работает.
Если закомментировать /tmp, загружается нормально.

При sysvinit в KDesktop-6 всё было ок.
------- Comment #1 From 2013-06-10 18:46:30 -------
Created an attachment (id=5852) [details]
/etc/fstab
------- Comment #2 From 2013-06-10 18:47:09 -------
Created an attachment (id=5853) [details]
fdisk -l
------- Comment #3 From 2013-06-10 18:55:50 -------
tmp.mount отключен
------- Comment #4 From 2013-06-13 15:57:11 -------
Необходимо удалить tmp.mount из пакета. Тогда все работает.
Маскирование tmp.mount не помогает.

P.S.
Так же снизит потребление памяти на всех LiveCD, где не используется костыль по
его отключению (сейчас это все, кроме KDesktop).
------- Comment #5 From 2013-06-13 16:10:45 -------
А так же этот баг приведет к незагружаемости KDesktop-6, обновленный до p7 и
переведенный на systemd.
------- Comment #6 From 2013-06-13 16:27:03 -------
Если никто не против, я исправлю 204-alt4 и скопирую  в p7 со всеми изменениями
после 204-alt1.
------- Comment #7 From 2013-06-13 16:36:02 -------
(В ответ на комментарий №6)
> Если никто не против, я исправлю 204-alt4 и скопирую  в p7 со всеми изменениями
> после 204-alt1.

Прошу высказываться.
Особенно shaba@ , ldv@, boyarsh@, sem@
Это надо тестировать не только на kdesktop.
------- Comment #8 From 2013-06-13 16:46:13 -------
Задание копирования в p7, естественно, сделаю test-only и сюда ссылку дам.
------- Comment #9 From 2013-06-13 16:50:08 -------
Что не работает и почему?
------- Comment #10 From 2013-06-13 16:54:55 -------
(В ответ на комментарий №9)
> Что не работает
Система почти не грузится с руганью "ничего не могу, т.к. все read-only".

> и почему?
Каким-то образом tmp.mount меняет поведение, несмотря на его отключение при
помощи
systemctl mask tmp.mount
------- Comment #11 From 2013-06-13 16:56:44 -------
В остальных дистрибутивах поведение измениться не должно, т.к. в их fstab есть
tmpfs        /tmp            tmpfs    nosuid                0 0
, который у меня коментируется.
------- Comment #12 From 2013-06-13 17:09:55 -------
Достаточно будет убрать зависимость от tmp.mount у local-fs.target
------- Comment #13 From 2013-06-13 17:10:27 -------
Не могу понять, чего и каким образом ты хочешь добиться.

Неужели ты хочешь, чтобы /tmp по умолчанию в дистрибутивах был НЕ на tmpfs?
------- Comment #14 From 2013-06-13 17:22:12 -------
(В ответ на комментарий №13)
> Неужели ты хочешь, чтобы
> /tmp по умолчанию в дистрибутивах
Только в KDesktop. Остальных не затрагивает.
Максимум, им когда-нибудь станет нужно будет не прописывать в fstab, а ставить
зависимость для local-fs.target на tmp.mount , но к этой баге отношения не
имеет.

> был НЕ на tmpfs?
Именно так я давно делаю для экономии RAM.
Несколько лет назад обсуждалось в devel-distro.
------- Comment #15 From 2013-06-13 17:36:38 -------
(В ответ на комментарий №14)
> Несколько лет назад обсуждалось в devel-distro.
http://lists.altlinux.org/pipermail/devel-distro/2010-September/000744.html
------- Comment #16 From 2013-06-13 18:00:02 -------
Для тестирования на p7 -- http://git.altlinux.org/tasks/98706/
------- Comment #17 From 2013-06-13 18:21:13 -------
systemd-204-alt5 -> sisyphus:

* Thu Jun 13 2013 Sergey V Turchin <zerg@altlinux> 204-alt5
- turn off tmp.mount by default (ALT#29066)
------- Comment #18 From 2013-06-14 15:00:30 -------
(В ответ на комментарий №16)
> Для тестирования на p7 -- http://git.altlinux.org/tasks/98706/

Обновил вчерашний кентавр из этого задания -- проблем не наблюдаю.
------- Comment #19 From 2013-06-14 15:06:00 -------
(В ответ на комментарий №18)
> Обновил вчерашний кентавр из этого задания -- проблем не наблюдаю.

А у меня не смонтировался luks-раздел после обновления. Подробнее не
разбирался.
------- Comment #20 From 2013-06-14 15:13:28 -------
(В ответ на комментарий №19)
> Обновил вчерашний кентавр из этого задания -- проблем не наблюдаю.
Я дома на p7 тоже пока ничего не заметил.
------- Comment #21 From 2013-06-14 15:14:31 -------
(В ответ на комментарий №19)
> А у меня не смонтировался luks-раздел после обновления.
Может, это #29033 ?
------- Comment #22 From 2013-06-14 18:38:23 -------
(В ответ на комментарий №19)
> А у меня не смонтировался luks-раздел после обновления.
У меня тоже на свежем образе зацикливается и пароль не просит даже.
Тогда в 204-alt1 сделаю свое изменение и отправлю.
------- Comment #23 From 2013-06-14 18:43:35 -------
(В ответ на комментарий №22)
> Тогда в 204-alt1 сделаю свое изменение и отправлю.
Ой, 201-alt1
------- Comment #24 From 2013-06-14 19:01:31 -------
http://git.altlinux.org/tasks/98777/
------- Comment #25 From 2013-06-17 16:09:00 -------
2 Shaba:
Маскирование tmp.mount (при его наличии) в любом случае приводит к такому
поведению, но теперь у меня есть возможность не маскировать.