Bug 29099 - compiz пропадает декорация окон
: compiz пропадает декорация окон
Status: NEW
: Simply Linux
(All bugs in Simply Linux/bugs)
: Не указана
: all Linux
: P3 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2013-06-22 23:22 by
Modified: 2013-07-22 18:48 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2013-06-22 23:22:35
Simply Linux 7.0.0 RC1
При включеном compiz пропадает декорация окон. Сама по себе.
Стойкий, повторяющийся эффект.
Эффект можно получить так:
1. вызываю терминал. нормально выглядит.
2. в терминале говорю su -l и ввожу пароль, давлю Enter - заголовок окна
исчезает.

acc вызывается сразу без заголовка.

Но, достаточно нажать Alt+TAB и заголовки появляются на месте. Даже если
запущена одна программа и переключаться некуда.

В Simply Linux branch p6 (на том же железе)такого не наблюдалось.

Дополнительно.
Видео = VGA compatible controller: Intel Corporation Atom Processor
D4xx/D5xx/N4xx/N5xx Integrated Graphics Controller
Драйвер = i915
------- Comment #1 From 2013-06-22 23:36:14 -------
Есть подозрение, что связано с #29093, т.е. способом включения infinality,
введенном ровно в SL7 rc1.
------- Comment #2 From 2013-06-24 17:37:55 -------
(В ответ на комментарий №1)
> Есть подозрение, что связано с #29093, т.е. способом включения infinality,
> введенном ровно в SL7 rc1.

Нет, проблема воспроизводится только с видео от Intel. Заголовок на самом деле
не пропадает, он просто не отрисовывается.
------- Comment #3 From 2013-06-27 19:36:36 -------
(In reply to comment #2)
> 
> Нет, проблема воспроизводится только с видео от Intel. Заголовок на самом деле
> не пропадает, он просто не отрисовывается.

Да, на двух интелах наблюдаю. На nvidia все нормально.
Установил только-что RC2. Ничего не поменялось...
------- Comment #4 From 2013-06-27 19:42:57 -------
(В ответ на комментарий №3)
> (In reply to comment #2)
> > 
> > Нет, проблема воспроизводится только с видео от Intel. Заголовок на самом деле
> > не пропадает, он просто не отрисовывается.
> 
> Да, на двух интелах наблюдаю. На nvidia все нормально.
> Установил только-что RC2. Ничего не поменялось...

Попробуйте xorg-drv-intel из Sisyphus и ядро un-def из p7.
------- Comment #5 From 2013-07-01 19:40:26 -------
(В ответ на комментарий №4)
> 
> Попробуйте xorg-drv-intel из Sisyphus и ядро un-def из p7.

не помогло...

$ uname -r
3.9.8-un-def-alt1

$ rpm -q xorg-drv-intel
xorg-drv-intel-2.21.10-alt1
------- Comment #6 From 2013-07-02 02:46:06 -------
(В ответ на комментарий №5)
> не помогло...
> 
> $ uname -r
> 3.9.8-un-def-alt1
> 
> $ rpm -q xorg-drv-intel
> xorg-drv-intel-2.21.10-alt1

Да, на xorg-drv-intel-2.21.11-alt1 тоже ничего не изменилось. Проблема где-то в
SNA. Переключение на UXA помогает.

root@bragi ~ # cat /etc/X11/xorg.conf.d/10-monitor.conf
Section "Device"
    Identifier "Card0"
    Driver "intel"
#    Option "AccelMethod" "sna"
    Option "AccelMethod" "uxa"
    Option "TearFree" "true"
EndSection
------- Comment #7 From 2013-07-16 02:56:19 -------
Прошу записать в Release Notes как известную проблему.
------- Comment #8 From 2013-07-16 11:10:02 -------
(В ответ на комментарий №7)
> Прошу записать в Release Notes как известную проблему.
Записано.
------- Comment #9 From 2013-07-21 18:35:36 -------
*** Bug 29207 has been marked as a duplicate of this bug. ***
------- Comment #10 From 2013-07-21 18:45:15 -------
(В ответ на комментарий №9)
> *** Ошибка 29207 признана повтором этой ошибки. ***

2AnthonySoprano: у Вас ошибка проявилась и на Radeon, это неприятная новость.
Какой драйвер используете?
------- Comment #11 From 2013-07-22 18:48:05 -------
(В ответ на комментарий №10)
> 
> 2AnthonySoprano: у Вас ошибка проявилась и на Radeon, это неприятная новость.
> Какой драйвер используете?

К сожалению, не могу сейчас проверить. Скажу в скором времени, как только
появится возможность.