Bug 29713 - Несовместимые с Red Hat provides
: Несовместимые с Red Hat provides
Status: NEW
: Sisyphus
(All bugs in Sisyphus/perl-base)
: unstable
: all Linux
: P3 normal
Assigned To:
:
: http://forum.altlinux.org/index.php?t...
:
:
:
  Show dependency tree
 
Reported: 2014-01-12 15:24 by
Modified: 2014-01-14 11:02 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2014-01-12 15:24:53
При установке пакета vipnet-sdk
vipnet-sdk: Требует: perl(English) но пакет не может быть установлен

В Fedora:
rpm -qp perl-5.18.2-291.fc21.i686.rpm --provides | grep English
perl(English) = 1.06

у нас (на p6):
perl(English.pm) = 1.040

Как мы можем обеспечить совместимость? Пакет, к слову, обязателен для
электронных госуслуг в России.
------- Comment #1 From 2014-01-12 15:32:00 -------
2boyarsh: важно для СПТ
------- Comment #2 From 2014-01-12 15:34:08 -------
А почему нет сборки этого пакета vipnet-sdk для ALT Linux?
------- Comment #3 From 2014-01-13 11:16:34 -------
(В ответ на комментарий №2)
> А почему нет сборки этого пакета vipnet-sdk для ALT Linux?
Потому что в основных дистрибутивах работает без напильника?
------- Comment #4 From 2014-01-14 02:22:55 -------
(В ответ на комментарий №0)
> Как мы можем обеспечить совместимость?
Например, compat-прокладкой.

(В ответ на комментарий №2)
> А почему нет сборки этого пакета vipnet-sdk для ALT Linux?
Вероятно, вопрос к поставщику, а не Андрею.  И он скорее риторический.
------- Comment #5 From 2014-01-14 04:11:12 -------
(В ответ на комментарий №4)
> (В ответ на комментарий №0)
> > Как мы можем обеспечить совместимость?
> Например, compat-прокладкой.
> 
?
А разве у нас нет модуля English?
2crux:?
------- Comment #6 From 2014-01-14 04:25:52 -------
(In reply to comment #5)
> (В ответ на комментарий №4)
> > (В ответ на комментарий №0)
> > > Как мы можем обеспечить совместимость?
> > Например, compat-прокладкой.
> > 
> ?
> А разве у нас нет модуля English?

$ rpmquery -f /usr/share/perl5/English.pm
perl-base-5.18.2-alt1

У нас просто несовместимый с RedHat формат перловых зависимостей.

Предлагаю перевесить баг куда-нибудь подальше от пакета perl-base.
------- Comment #7 From 2014-01-14 11:02:03 -------
(В ответ на комментарий №6)
> Предлагаю перевесить баг куда-нибудь подальше от пакета perl-base.
То есть оставляем как есть, лишний provides вручную не добавляем и используем
прокладку compat-*?