Bug 30127 - Избавиться от пакета (was: missing pkgconfig file)
: Избавиться от пакета (was: missing pkgconfig file)
Status: NEW
: Sisyphus
(All bugs in Sisyphus/libopenjpeg-devel)
: unstable
: all Linux
: P3 enhancement
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2014-06-19 19:45 by
Modified: 2018-01-13 00:38 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2014-06-19 19:45:25
Хорошо бы паковать *.pc (вылезло на федорином openslide для nip2).
------- Comment #1 From 2017-06-23 15:22:37 -------
(In reply to comment #0)
> Хорошо бы паковать *.pc (вылезло на федорином openslide для nip2).

Хорошо бы избавиться от этого устаревшего пакета.
------- Comment #2 From 2017-06-26 15:40:59 -------
(В ответ на комментарий №1)
> Хорошо бы избавиться от этого устаревшего пакета.
libopenjpeg?
------- Comment #3 From 2017-06-27 13:12:24 -------
(In reply to comment #2)
> (В ответ на комментарий №1)
> > Хорошо бы избавиться от этого устаревшего пакета.
> libopenjpeg?

да
------- Comment #4 From 2018-01-13 00:37:52 -------
(В ответ на комментарий №2)
> (В ответ на комментарий №1)
> > Хорошо бы избавиться от этого устаревшего пакета.
> libopenjpeg?
Да, в пользу отличного нового libopenjpeg2.0,
который уже используется в ряде пакетов:
  libpoppler71-0.60.1-alt1.S1
  libfreeimage-3.17.0-alt3
  gst-plugins-bad1.0-1.12.4-alt1
  libgs-9.20-alt2
  darktable-2.4.0-alt1
  libImageMagick-6.9.9.28-alt1

Но старый держится вот этими:
  libpoppler67-0.56.0-alt2.S1
  libpoppler59-0.42.0-alt3
  libopenslide-3.4.1-alt1
  mplayer-1.3.0-alt1
  mencoder-1.3.0-alt1
  gpac-0.6.1-alt1
  calligra-core-0:3.0.1-alt2.S1


По самой же баге:
Нужно просто поменять зависимость в пакете openslide на
BuildRequires: libopenjpeg2.0-devel