Bug 30407 - Просьба обновить версию до 8.6.х
: Просьба обновить версию до 8.6.х
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/tcl)
: unstable
: all Linux
: P3 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2014-10-20 13:14 by
Modified: 2017-04-27 02:31 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2014-10-20 13:14:20
TCL 8.6.2 released at Aug 27, 2014
------- Comment #1 From 2014-10-20 13:21:08 -------
На Sisyphus.
------- Comment #2 From 2015-04-25 15:36:32 -------
Дракон с версии 1.23 требует tcl 8.6 -- http://drakon-editor.sourceforge.net/ :

Switch to Tcl/Tk 8.6. It's a major change in system requirements. DRAKON Editor
now needs Tcl/Tk 8.6 to run. Tcl/Tk 8.5 is not supported any more.

Интересно, можно ли просто отправить в Сизиф сборку tcl 8.6? Должно ли что-то
сломаться?

А как это проверить по возможности автоматически? У меня в системе не так много
пакетов зависит от tcl:

apt> remove tcl
Unrequested changes are needed to execute this operation.
The following packages will be REMOVED:
  git git-gui gitk hplip-gui python-module-imaging python-modules-tkinter tcl
tk uniconvertor usb-modeswitch usb-modeswitch-data


Или можно просто отправить в Сизиф, и ждать, пока люди сообщат, что у них
что-то отвалилось?

По крайней мере, кажется, разумным обновлять вместе tcl и tk. А нужно ли
какие-то ещё пакеты включить в такую транзакцию, непонятно.
------- Comment #3 From 2015-04-25 19:02:06 -------
предлагаю посмотреть на вывод apt-cache whatdepends libtcl,
затем libtk -- там далеко не пара пакетов.
(hint: их soname включает версию).
затем предлагаю посмотреть на формат автогенерированных
tcl-зависимостей, напр. rpmquery -pR tkabber-1.0-alt1.noarch.rpm
(hint: там нет версии).
Таким образом, получить tcl8.6 в репозитарии можно
только заменив им tcl8.5 и после тотальной пересборки
всех слинкованных с libtcl/libtk пакетов.
это было довольно трудоёмко во времена перехода с tcl8.4 на tcl8.5, повторять
же это ещё раз сейчас я определённо не намерен.
------- Comment #4 From 2015-04-26 15:45:05 -------
(В ответ на комментарий №3)
> Таким образом, получить tcl8.6 в репозитарии можно
> только заменив им tcl8.5 и после тотальной пересборки
> всех слинкованных с libtcl/libtk пакетов.
> это было довольно трудоёмко во времена перехода с tcl8.4 на tcl8.5, повторять
> же это ещё раз сейчас я определённо не намерен.
А если поможем? почти (ц)
------- Comment #5 From 2015-04-26 20:00:36 -------
если кто-то готов взять на себя всё это хозяйство -- буду рад.
------- Comment #6 From 2015-04-27 17:48:08 -------
(В ответ на комментарий №3)
> предлагаю посмотреть на вывод apt-cache whatdepends libtcl,

(Смешно вышло: сделал это в apt-shell и ничего не увидел. А standalone команда
даёт большой вывод -- https://bugzilla.altlinux.org/show_bug.cgi?id=30976 .)
------- Comment #7 From 2015-04-27 17:51:43 -------
(В ответ на комментарий №3)

> затем предлагаю посмотреть на формат автогенерированных
> tcl-зависимостей, напр. rpmquery -pR tkabber-1.0-alt1.noarch.rpm
> (hint: там нет версии).
> Таким образом, получить tcl8.6 в репозитарии можно
> только заменив им tcl8.5 и после тотальной пересборки
> всех слинкованных с libtcl/libtk пакетов.

Меня в этой процедуре ещё беспокоит проверка работоспосбности tcl-скриптов с
новой версией. Ведь при сборке пакета никакой компиляции и выдачи compile-time
ошибок для tcl-скриптов не происходит, да?

Нет ли такого режима проверки скриптов?
------- Comment #8 From 2015-04-27 18:27:36 -------
на уровне скриптов совместимость до сих пор соблюдалась.
проблемы будут с приложениями, линкующимися с libtcl/libtk