Bug 30976 - "apt-cache whatdepends" and "whatdepends" in apt-shell give different results
: "apt-cache whatdepends" and "whatdepends" in apt-shell give different results
Status: CLOSED DUPLICATE of bug 32429
: Sisyphus
(All bugs in Sisyphus/apt)
: unstable
: all Linux
: P3 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2015-04-27 17:46 by
Modified: 2017-01-10 18:04 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2015-04-27 17:46:40
apt-0.5.15lorg2-alt50

From one side, the short output in apt-shell:

[root@z ~]# apt-shell 
Чтение списков пакетов... Завершено
Построение дерева зависимостей... Завершено
Добро пожаловать в APT shell. Используйте команду "help" для дополнительной
информации.
apt> whatdepends libtcl
libtcl-8.5.9-alt2
  i586-libtcl.32bit-8.5.9-alt2
    Требует: libtcl = 8.5.9-alt2
  tcl-8.5.9-alt2
    Требует: libtcl = 8.5.9-alt2
apt> 

From the other, the long output of "apt-cache whatdepends libtcl":

[root@z ~]# apt-cache whatdepends libtcl
libtcl-8.5.9-alt2
  i586-libtcl.32bit-8.5.9-alt2
    Требует: libtcl = 8.5.9-alt2
  tcl-8.5.9-alt2
    Требует: libtcl = 8.5.9-alt2
  xcrysden-1.5.21-alt4
    Требует: <libtcl8.5.so()(64bit)>
      libtcl-8.5.9-alt2
  xchat-2.8.6-alt3.1
    Требует: <libtcl8.5.so()(64bit)>
      libtcl-8.5.9-alt2
  wordnet-tk-3.0-alt7
    Требует: <libtcl8.5.so()(64bit)>
      libtcl-8.5.9-alt2
  wok-tool-6.5.2-alt2
    Требует: <libtcl8.5.so()(64bit)>
      libtcl-8.5.9-alt2
  libwok-tool-6.5.2-alt2
    Требует: <libtcl8.5.so()(64bit)>
      libtcl-8.5.9-alt2
  weechat-plugin-tcl-0.3.5-alt3
    Требует: <libtcl8.5.so()(64bit)>
      libtcl-8.5.9-alt2
  vtk-examples-5.10.1-alt3
    Требует: <libtcl8.5.so()(64bit)>
      libtcl-8.5.9-alt2
  vtk-5.10.1-alt3
    Требует: <libtcl8.5.so()(64bit)>
      libtcl-8.5.9-alt2
  libvtk-tcl-5.10.1-alt3
    Требует: <libtcl8.5.so()(64bit)>
      libtcl-8.5.9-alt2
  libvtk-python-5.10.1-alt3
    Требует: <libtcl8.5.so()(64bit)>
      libtcl-8.5.9-alt2
  vkeybd-1:0.1.18c-alt1.qa1
    Требует: <libtcl8.5.so()(64bit)>
      libtcl-8.5.9-alt2
  vim-enhanced-4:7.3.353-alt2
    Требует: <libtcl8.5.so()(64bit)>
      libtcl-8.5.9-alt2
  vim-X11-neXtaw-4:7.3.353-alt2
    Требует: <libtcl8.5.so()(64bit)>
      libtcl-8.5.9-alt2
  vim-X11-gtk2-4:7.3.353-alt2
    Требует: <libtcl8.5.so()(64bit)>
      libtcl-8.5.9-alt2
  vim-X11-gnome2-4:7.3.353-alt2
    Требует: <libtcl8.5.so()(64bit)>
      libtcl-8.5.9-alt2
  xdeview-0.5.20-alt6.M70T.1
    Требует: <libtcl8.5.so()(64bit)>
      libtcl-8.5.9-alt2
  tuxracer-0.61-alt13.qa1
    Требует: <libtcl8.5.so()(64bit)>
      libtcl-8.5.9-alt2
  torque-gui-4.2.1-alt1
    Требует: <libtcl8.5.so()(64bit)>
      libtcl-8.5.9-alt2
  torque-client-4.2.1-alt1
    Требует: <libtcl8.5.so()(64bit)>
      libtcl-8.5.9-alt2
  tk-8.5.9-alt3
    Требует: <libtcl8.5.so()(64bit)>
      libtcl-8.5.9-alt2
  tcl-dp-4.0b2-alt2
    Требует: <libtcl8.5.so()(64bit)>
      libtcl-8.5.9-alt2
  sqlite-tcl-2.8.17-alt2.2
    Требует: <libtcl8.5.so()(64bit)>
      libtcl-8.5.9-alt2
  smalltalk-3.2.4-alt1.git.263.ga839464.2
    Требует: <libtcl8.5.so()(64bit)>
      libtcl-8.5.9-alt2
  libsetools-tcl-3.3.8-alt3.M70P.1
    Требует: <libtcl8.5.so()(64bit)>
      libtcl-8.5.9-alt2
  scotty-2:3.0.0-alt5.qa1
    Требует: <libtcl8.5.so()(64bit)>
      libtcl-8.5.9-alt2
  scilab-5.5.1-alt0.M70P.1
    Требует: <libtcl8.5.so()(64bit)>
      libtcl-8.5.9-alt2
  sK1-0.9.1-alt2.1.1.1
    Требует: <libtcl8.5.so()(64bit)>
      libtcl-8.5.9-alt2
  ruby-tk-1.9.3-alt44.M70P.1
    Требует: <libtcl8.5.so()(64bit)>
      libtcl-8.5.9-alt2
  python3-modules-tkinter-3.3.1-alt4
    Требует: <libtcl8.5.so()(64bit)>
      libtcl-8.5.9-alt2
  python3-module-matplotlib-tk-1.3.0-alt4.git20121010
    Требует: <libtcl8.5.so()(64bit)>
      libtcl-8.5.9-alt2
  python-module-matplotlib-tk-1.3.0-alt4.git20121010
    Требует: <libtcl8.5.so()(64bit)>
      libtcl-8.5.9-alt2
  python-module-imaging-1.1.7-alt7
    Требует: <libtcl8.5.so()(64bit)>
      libtcl-8.5.9-alt2
  python-modules-tkinter-2.7.6-alt2.M70P.1
    Требует: <libtcl8.5.so()(64bit)>
      libtcl-8.5.9-alt2
  ppracer-0.3.1-alt4
    Требует: <libtcl8.5.so()(64bit)>
      libtcl-8.5.9-alt2
  postgresql9.4-tcl-9.4.1-alt0.M70P.1
    Требует: <libtcl8.5.so()(64bit)>
      libtcl-8.5.9-alt2
  postgresql9.3-tcl-9.3.6-alt0.M70P.1
    Требует: <libtcl8.5.so()(64bit)>
      libtcl-8.5.9-alt2
  postgresql9.2-1C82-tcl-9.2.10-alt0.M70P.822.1
    Требует: <libtcl8.5.so()(64bit)>
      libtcl-8.5.9-alt2
  postgresql9.2-1C-tcl-9.2.10-alt0.M70P.1
    Требует: <libtcl8.5.so()(64bit)>
      libtcl-8.5.9-alt2
  postgresql9.1-tcl-9.1.15-alt0.M70P.1
    Требует: <libtcl8.5.so()(64bit)>
      libtcl-8.5.9-alt2
  postgresql9.0-tcl-9.0.19-alt0.M70P.1
    Требует: <libtcl8.5.so()(64bit)>
      libtcl-8.5.9-alt2
  plplot-tk-5.9.9-alt5.svn20121223
    Требует: <libtcl8.5.so()(64bit)>
      libtcl-8.5.9-alt2
  libplplot-tk-5.9.9-alt5.svn20121223
    Требует: <libtcl8.5.so()(64bit)>
      libtcl-8.5.9-alt2
  libopenipmi-2.0.19-alt2
    Требует: <libtcl8.5.so()(64bit)>
      libtcl-8.5.9-alt2
  libopencascade-6.5.4-alt1
    Требует: <libtcl8.5.so()(64bit)>
      libtcl-8.5.9-alt2
  ogdi-tcl-3.2.0-alt1.beta2.1
    Требует: <libtcl8.5.so()(64bit)>
      libtcl-8.5.9-alt2
  labltk-runtime-3.12.1-alt1
    Требует: <libtcl8.5.so()(64bit)>
      libtcl-8.5.9-alt2
  libngsolve-5.1-alt1.svn20130203
    Требует: <libtcl8.5.so()(64bit)>
      libtcl-8.5.9-alt2
  libnetgen-5.1-alt1.svn20130203
    Требует: <libtcl8.5.so()(64bit)>
      libtcl-8.5.9-alt2
  liboop-binding-tcl-1.0-alt3.qa2
    Требует: <libtcl8.5.so()(64bit)>
      libtcl-8.5.9-alt2
  libini-1.1.10-alt1
    Требует: <libtcl8.5.so()(64bit)>
      libtcl-8.5.9-alt2
  libdb4.7_tcl-4.7.25-alt8
    Требует: <libtcl8.5.so()(64bit)>
      libtcl-8.5.9-alt2
  ical-2.3.3-alt3.qa1
    Требует: <libtcl8.5.so()(64bit)>
      libtcl-8.5.9-alt2
  hping3-0.0.20051105-alt5.qa1
    Требует: <libtcl8.5.so()(64bit)>
      libtcl-8.5.9-alt2
  gtkwave-3.3.45-alt1
    Требует: <libtcl8.5.so()(64bit)>
      libtcl-8.5.9-alt2
  grass-6.4.3-alt0.M70P.1
    Требует: <libtcl8.5.so()(64bit)>
      libtcl-8.5.9-alt2
  findlib-toolbox-1.2.7-alt1
    Требует: <libtcl8.5.so()(64bit)>
      libtcl-8.5.9-alt2
  extreme-tuxracer-1:0.5-alt0.svn254.1
    Требует: <libtcl8.5.so()(64bit)>
      libtcl-8.5.9-alt2
  expect-1:5.45-alt4
    Требует: <libtcl8.5.so()(64bit)>
      libtcl-8.5.9-alt2
  environment-modules-3.2.10-alt1_4
    Требует: <libtcl8.5.so()(64bit)>
      libtcl-8.5.9-alt2
  emacspeak-servers-35.0-alt2
    Требует: <libtcl8.5.so()(64bit)>
      libtcl-8.5.9-alt2
  elmerfem-7.0-alt2.svn6034
    Требует: <libtcl8.5.so()(64bit)>
      libtcl-8.5.9-alt2
  eggdrop-1.6.19-alt2.qa1
    Требует: <libtcl8.5.so()(64bit)>
      libtcl-8.5.9-alt2
  dstool_tk-0.2003-alt7
    Требует: <libtcl8.5.so()(64bit)>
      libtcl-8.5.9-alt2
  dstool-2.0-alt5
    Требует: <libtcl8.5.so()(64bit)>
      libtcl-8.5.9-alt2
  din-5.2.1-alt1.1
    Требует: <libtcl8.5.so()(64bit)>
      libtcl-8.5.9-alt2
  cgns-seq-3.2-alt1.svn20121213
    Требует: <libtcl8.5.so()(64bit)>
      libtcl-8.5.9-alt2
  cgns-mpi-3.2-alt1.svn20121213
    Требует: <libtcl8.5.so()(64bit)>
      libtcl-8.5.9-alt2
  libXdmf-20100923-alt21
    Требует: <libtcl8.5.so()(64bit)>
      libtcl-8.5.9-alt2
  TiMidity++-2.14.0-alt3
    Требует: <libtcl8.5.so()(64bit)>
      libtcl-8.5.9-alt2
  R-tcltk-2.15.1-alt3
    Требует: <libtcl8.5.so()(64bit)>
      libtcl-8.5.9-alt2
[root@z ~]#
------- Comment #1 From 2017-01-10 18:04:56 -------
Discovered once again.

*** This bug has been marked as a duplicate of bug 32429 ***