Bug 32429 - apt-shell whatdepends are incomplete
: apt-shell whatdepends are incomplete
Status: NEW
: Sisyphus
(All bugs in Sisyphus/apt)
: unstable
: all Linux
: P3 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2016-08-25 16:17 by
Modified: 2017-01-10 18:04 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2016-08-25 16:17:45
evolution is missing in the output of "whatdepends" under apt-shell, but it is
present in the output of "apt-cache whatdepends":

[imz@basalt ~]$ apt-cache whatdepends libpst
libpst-0.6.67-alt3
  libpst-docs-0.6.67-alt3
    Depends: libpst = 0.6.67-alt3
  libpst-tools-0.6.67-alt3
    Depends: libpst = 0.6.67-alt3
  libpst-devel-0.6.67-alt3
    Depends: libpst = 0.6.67-alt3
  evolution-3.20.5-alt1
    Depends: <libpst.so.4()(64bit)>
      libpst-0.6.67-alt3
[imz@basalt ~]$ apt-shell 
Reading Package Lists... Done
Building Dependency Tree... Done
Welcome to the APT shell. Type "help" for more information.
apt> whatdepends libpst
libpst-0.6.67-alt3
  libpst-docs-0.6.67-alt3
    Depends: libpst = 0.6.67-alt3
  libpst-tools-0.6.67-alt3
    Depends: libpst = 0.6.67-alt3
  libpst-devel-0.6.67-alt3
    Depends: libpst = 0.6.67-alt3
apt> 
[imz@basalt ~]$ rpm -qf "$(which apt-shell)" "$(which apt-cache)"
apt-0.5.15lorg2-alt53
apt-0.5.15lorg2-alt53
[imz@basalt ~]$
------- Comment #1 From 2017-01-10 18:04:11 -------
This still affects apt-0.5.15lorg2-alt56.

(Discovered on the example of whatdepends gdk-pixbuf)
------- Comment #2 From 2017-01-10 18:04:56 -------
*** Bug 30976 has been marked as a duplicate of this bug. ***