Bug 32891 - apt вылетает при сборке программы obs-studio для i586
: apt вылетает при сборке программы obs-studio для i586
Status: CLOSED DUPLICATE of bug 32887
: Sisyphus
(All bugs in Sisyphus/apt)
: unstable
: all Linux
: P3 major
Assigned To:
:
:
: regression
:
:
  Show dependency tree
 
Reported: 2016-12-13 21:06 by
Modified: 2016-12-13 22:14 (History)


Attachments
Весь лог сборки obs-studio (110.85 KB, text/plain)
2016-12-13 21:06, Konstantin Yablochkin
no flags Details


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2016-12-13 21:06:28
Created an attachment (id=6898) [details]
Весь лог сборки obs-studio

Собрал ffmpeg под i586 (успешно прошло).
Собираю obs-studio, который его использует - вылетает apt.
Лог во вложении. Расшифровка команд, которые я запускаю:

================================== 1 =========================================
[toor@gbgb bin]$ cat gear-hsh-i586-mk
#!/bin/bash
mkdir ~/hasher && i586 gear-hsh --verbose -- --verbose --target=i586
--apt-config=/etc/apt/apt.i586.conf
[toor@gbgb bin]$ 
================================== /1 =========================================

================================== 2 =========================================
[toor@gbgb apt]$ cat apt.i586.conf
/*
 * This is the main configuration file for the APT suite of tools,
 * see apt.conf(5) for details.
 */

// See apt-cdrom(8) for details.
Acquire::CDROM::Copy "true";
Acquire::CDROM::mount "/media/ALTLinux";

RPM 
{
    Allow-Duplicated {
        // Old-style kernels.
       
"^(NVIDIA_)?(kernel|alsa)[0-9]*(-adv|-linus)?($|-up|-smp|-secure|-custom|-enterprise|-BOOT|-tape|-aureal)";
        // New-style kernels.
        "^kernel-(image|modules)-.*";
    };
    Hold {
        // Old-style kernels.
        "^(kernel|alsa)[0-9]+-source";
    };
};


Dir "/"
{
  Etc "etc/apt/" {
    sourcelist "sources.i586.list";
    main "apt.i586.conf";
  }
}


[toor@gbgb apt]$ 
================================== /2 =========================================

================================== 3 =========================================
[toor@gbgb apt]$ cat sources.i586.list
# Local package resource list for APT goes here.
# To inspect package defined part, see /etc/apt/sources.list.d/*.list

#rpm [alt] http://ftp.altlinux.org/pub/distributions ALTLinux/Sisyphus/x86_64
classic
#rpm [alt] http://ftp.altlinux.org/pub/distributions ALTLinux/Sisyphus/noarch
classic
#rpm [alt] http://ftp.altlinux.org/pub/distributions
ALTLinux/Sisyphus/x86_64-i586 classic



rpm [alt] file:/mnt/sda7/sisyphus/Sisyphus i586 classic
#rpm [alt] file:/mnt/sda7/sisyphus/Sisyphus x86_64 classic
rpm [alt] file:/mnt/sda7/sisyphus/Sisyphus noarch classic
#rpm [alt] file:/mnt/sda7/sisyphus/repo/ noarch hasher
#rpm file:///mnt/sda7/sisyphus/repo x86_64 hasher

rpm file:/mnt/sda7/sisyphus/repo i586 hasher
#rpm file:/mnt/sda7/sisyphus/repo x86_64 hasher
rpm file:/mnt/sda7/sisyphus/repo noarch hasher

[toor@gbgb apt]$ 
================================== /3 =========================================
------- Comment #1 From 2016-12-13 21:54:18 -------
При nativr сборке то же самое

apt-get: rpm/rpmhandler.cc:112: virtual std::__cxx11::string
RPMFileHandler::FileName(): Assertion `rc != 0' failed.
0 upgraded, 562 newly installed, 0 removed and 0 not upgraded.
hsh-install: apt-get terminated by signal 6
hsh-install: Failed to calculate package file list.
hsh-install: Failed to generate package file list.
------- Comment #2 From 2016-12-13 21:55:35 -------
Это сборка под x86_64
------- Comment #3 From 2016-12-13 22:14:11 -------
rpm-4.13.0-alt4 -> sisyphus:

* Tue Dec 13 2016 Gleb F-Malinovskiy <glebfm@altlinux> 4.13.0-alt4
...
- Fixed support of APT external tags (ALT#32887).

*** This bug has been marked as a duplicate of bug 32887 ***