Bug 32887 - Сломан genbasedir
: Сломан genbasedir
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/librpm7)
: unstable
: all Linux
: P3 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2016-12-12 22:50 by
Modified: 2016-12-18 20:05 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2016-12-12 22:50:03
В apt сломались локальные источники.
Создавал командой
genbasedir --bloat --topdir=/home/diman/Build/Sisyphus/repo x86_64 hasher

sources.list:
rpm file:/home/diman/Build/Sisyphus/repo x86_64 hasher
rpm [alt] http://ftp.altlinux.org/pub/distributions/ALTLinux Sisyphus/x86_64
classic
rpm [alt] http://ftp.altlinux.org/pub/distributions/ALTLinux
Sisyphus/x86_64-i586 classic
rpm [alt] http://ftp.altlinux.org/pub/distributions/ALTLinux Sisyphus/noarch
classic


[diman@dimanko ~]$ sudo apt-get install icewm-githubmod
[sudo] password for diman:
Freeing read locks for locker 0x9: 16583/140423596164928
Reading Package Lists... Done
Building Dependency Tree... Done
The following packages will be upgraded
  icewm-githubmod
1 upgraded, 0 newly installed, 0 removed and 4 not upgraded.
apt-get: rpm/rpmhandler.cc:112: virtual std::__cxx11::string
RPMFileHandler::FileName(): Assertion `rc != 0' failed.
Аварийный останов
------- Comment #1 From 2016-12-13 20:46:41 -------
rpm-4.13.0-alt4 -> sisyphus:

* Tue Dec 13 2016 Gleb F-Malinovskiy <glebfm@altlinux> 4.13.0-alt4
- rpmspec: restored support of BuildRequires(pre) (ALT#32870),
  and Serial (ALT#32888) tags.
- rpmspec: fixed support of long lines in specfile.
- rpm: restored --with{,out} and --{en,dis}able aliases for rpmbuild.
- Added conflict to apt < 0.5.15lorg2-alt54 (ALT#32873).
- Fixed retrieving of remote files.
- Dropped R: curl (it is optional).
- Fixed encoding of translataed manpages.
- Changed rpmlog to write to stderr.
- Fixed support of APT external tags (ALT#32887).
- Define RPM_INSTALL_{NAME,ARG1,ARG2} env variables only for per-package
  scripts (ALT#32890).
------- Comment #2 From 2016-12-13 22:14:11 -------
*** Bug 32891 has been marked as a duplicate of this bug. ***
------- Comment #3 From 2016-12-18 20:05:44 -------
*** Bug 32907 has been marked as a duplicate of this bug. ***