Bug 32907 - apt-get: rpm/rpmhandler.cc:112: virtual std::__cxx11::string RPMFileHandler::FileName(): Assertion `rc != 0' failed
: apt-get: rpm/rpmhandler.cc:112: virtual std::__cxx11::string RPMFileHandler::...
Status: CLOSED DUPLICATE of bug 32887
: Sisyphus
(All bugs in Sisyphus/apt)
: unstable
: all Linux
: P3 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2016-12-18 00:48 by
Modified: 2016-12-18 20:05 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2016-12-18 00:48:01
apt-get dist-upgrade
Reading Package Lists... Done
Building Dependency Tree... Done
Calculating Upgrade... Done
The following packages will be upgraded
...
The following packages have been kept back
  dpkg istack-commons perl-Dpkg
181 upgraded, 9 newly installed, 0 removed and 3 not upgraded.
apt-get: rpm/rpmhandler.cc:112: virtual std::__cxx11::string
RPMFileHandler::FileName(): Assertion `rc != 0' failed.

 $ rpm -q apt rpm
apt-0.5.15lorg2-alt55.x86_64
rpm-4.13.0-alt5.x86_64
------- Comment #1 From 2016-12-18 10:38:39 -------
rm -f /var/cache/apt/*.bin не помогает ?
------- Comment #2 From 2016-12-18 20:05:44 -------
К сожалению, при использовании genbasedir с librpm7 < 4.13.0-alt4 индексы
оказываются сломанными таким образом.

*** This bug has been marked as a duplicate of bug 32887 ***