Bug 33106 - Update to 3.16.11
: Update to 3.16.11
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/hplip)
: unstable
: all Linux
: P3 normal
Assigned To:
:
: https://sourceforge.net/p/hplip/news/...
:
:
:
  Show dependency tree
 
Reported: 2017-02-12 00:39 by
Modified: 2017-02-23 23:48 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2017-02-12 00:39:55
У меня есть принтер HP LJ Pro M106w, так вот, он заявлен как поддерживаемый
только начиная с версии 3.16.11.

На текущей версии в Сизифе (3.16.7) принтер не определяется никак (ищу его как
сетевой принтер), после ручной пересборки пакета с 3.16.11 все стало
определяться как надо.

В процессе работы всплыли некоторые странности работы hplip в целом:

Словил #29356 - оказалось, hp-toolbox хочет видеть сетевой принтер с включенным
snmp, иначе он говорит что произошла ошибка и отказывается соединяться. Как
только включил snmp с public community и отключил принудительный https в
настройках принтера, все пришло в норму.

Также словил #31824, у себя вылечил установкой control su/sudo public на время
настройки плагина, так все заработало.
------- Comment #1 From 2017-02-22 20:17:29 -------
hplip-1:3.16.11-alt2 -> sisyphus:

* Wed Feb 22 2017 Igor Vlasenko <viy@altlinux> 1:3.16.11-alt2
- Sisyphus release (closes: #33106)
- PPD* subpackages are now optional as they are deprecated
- cups/filter/foomatic-rip dependency disabled by default
- foomatic-db moved out from requires

* Thu Feb 09 2017 Igor Vlasenko <viy@altlinux> 1:3.16.11-alt1
- new version

* Wed Feb 08 2017 Igor Vlasenko <viy@altlinux> 1:3.16.10-alt2
- 3.16.10 build