Bug 3374 - textcase.sty: \MakeTextUpper(Lower)case and not needed space
: textcase.sty: \MakeTextUpper(Lower)case and not needed space
Status: CLOSED DUPLICATE of bug 3373
: Sisyphus
(All bugs in Sisyphus/tetex)
: unstable
: all Linux
: P2 minor
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2003-12-15 14:20 by
Modified: 2006-08-26 21:09 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2003-12-15 14:20:52
В файле textcase.sty следует вставить знак комментария (%) после строки       
\def\NoCaseChange##1{\noexpand\NoCaseChange{\noexpand##1}}, т.е. должно быть 
так:
\def\NoCaseChange##1{\noexpand\NoCaseChange{\noexpand##1}}%

Иначе при спользовании этого пакета макросы \MakeTextUppercase и \MakeLowercase 
вставляют пробел впереди текста, который обрабатывают, т.е. строка

bla-bla-bla-\MakeUppercase{bla-bla-bla-}bla-bla-bla

даст в результате

bla-bla-bla- BLA-BLA-BLA-bla-bla-bla

вместо 

bla-bla-bla-BLA-BLA-BLA-bla-bla-bla
------- Comment #1 From 2003-12-16 18:40:56 -------

*** This bug has been marked as a duplicate of 3373 ***
------- Comment #2 From 2006-08-26 21:09:57 -------
дубль