Bug 33856 - Линковка бинда с libxml для съёма статистики
: Линковка бинда с libxml для съёма статистики
Status: CLOSED DUPLICATE of bug 31401
: Sisyphus
(All bugs in Sisyphus/bind)
: unstable
: all Linux
: P3 normal
Assigned To:
:
: http://madb.mageia.org/rpm/show/appli...
:
:
:
  Show dependency tree
 
Reported: 2017-09-07 06:21 by
Modified: 2018-07-17 16:39 (History)


Attachments
Спек с поддержкой xml и исправлением сборки python-bind (29.12 KB, text/x-rpm-spec)
2017-09-19 07:32, Вадим Илларионов
no flags Details


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2017-09-07 06:21:25
Версия для р8 собиралась с таким патчем:

@@ -62,6 +62,7 @@
 %def_disable static
 %def_enable ipv6
 %def_with openssl
+%def_with libxml2

 Provides: bind-chroot(%_chrootdir)
 Obsoletes: bind-chroot, bind-debug, bind-slave, caching-nameserver
@@ -70,6 +71,7 @@
 PreReq: bind-control >= 1.2
 PreReq: chrooted syslogd-daemon
 PreReq: libbind = %EVR
+PreReq: libxml2

 # due to %_chrootdir/dev/log
 BuildPreReq: coreutils
@@ -80,6 +82,7 @@
 # for better --enable-linux-caps experience
 BuildPreReq: libcap-devel

+%{?_with_libxml2:BuildPreReq: libxml2-devel}                                   
 %{?_with_openssl:BuildPreReq: libssl-devel}                                    

 %package utils                                                                 
@@ -215,6 +218,7 @@                                                             
        --enable-fetchlimit \                                                   
        --enable-fixed-rrset \                                                  
        --disable-seccomp \                                                     
+        %{subst_with libxml2} \                                                
         %{subst_with openssl} \                                                
         %{subst_enable ipv6} \                                                 
         %{subst_enable static} \                                               

Попробовал добавить эту поддержку к сизифовому спеку - сборка ломается с такой
руганью:

предупреждение: Installed (but unpackaged) file(s) found:
    /usr/lib/python2.7/site-packages/isc-1.0-py2.7.egg-info
    /usr/lib/python2.7/site-packages/isc/__init__.py
    /usr/lib/python2.7/site-packages/isc/__init__.pyc
    /usr/lib/python2.7/site-packages/isc/__init__.pyo
    /usr/lib/python2.7/site-packages/isc/checkds.py
    /usr/lib/python2.7/site-packages/isc/checkds.pyc
    /usr/lib/python2.7/site-packages/isc/checkds.pyo
    /usr/lib/python2.7/site-packages/isc/coverage.py
    /usr/lib/python2.7/site-packages/isc/coverage.pyc
    /usr/lib/python2.7/site-packages/isc/coverage.pyo
    /usr/lib/python2.7/site-packages/isc/dnskey.py
    /usr/lib/python2.7/site-packages/isc/dnskey.pyc
    /usr/lib/python2.7/site-packages/isc/dnskey.pyo
    /usr/lib/python2.7/site-packages/isc/eventlist.py
    /usr/lib/python2.7/site-packages/isc/eventlist.pyc
    /usr/lib/python2.7/site-packages/isc/eventlist.pyo
    /usr/lib/python2.7/site-packages/isc/keydict.py
    /usr/lib/python2.7/site-packages/isc/keydict.pyc
    /usr/lib/python2.7/site-packages/isc/keydict.pyo
    /usr/lib/python2.7/site-packages/isc/keyevent.py
    /usr/lib/python2.7/site-packages/isc/keyevent.pyc
    /usr/lib/python2.7/site-packages/isc/keyevent.pyo
    /usr/lib/python2.7/site-packages/isc/keyzone.py
    /usr/lib/python2.7/site-packages/isc/keyzone.pyc
    /usr/lib/python2.7/site-packages/isc/keyzone.pyo
    /usr/lib/python2.7/site-packages/isc/utils.py
    /usr/lib/python2.7/site-packages/isc/utils.pyc
    /usr/lib/python2.7/site-packages/isc/utils.pyo
ошибка: File list check failed, terminating build

Ошибки сборки пакетов:
    Installed (but unpackaged) file(s) found:
    File list check failed, terminating build

Возможно, проблема именно с питоном, но всё же поддержку xml бинду вообще имеет
смысл добавить.
------- Comment #1 From 2017-09-11 04:57:20 -------
(В ответ на комментарий №0)
> Версия для р8 собиралась с таким патчем:

Забыл указать, что патч - для спек-файла.
------- Comment #2 From 2017-09-18 18:22:55 -------
(In reply to comment #1)
SPEC-файл не содержит путей для сборки пакета из файлов Python.
Я позаимствовал их из аналогичного спека Mageia 6

...
%package -n    python-bind
Summary:    A module allowing rndc commands to be sent from Python programs
BuildArch: noarch
Requires: python
Group:        Development/Python
...
%description -n    python-bind
This package provides a module which allows commands to be sent to rndc
directly from Python programs.
...
...
%files -n python-bind
%{python_sitelibdir_noarch}/*py*
%{python_sitelibdir_noarch}/isc/*py*
...
------- Comment #3 From 2017-09-19 07:32:24 -------
Created an attachment (id=7214) [details]
Спек с поддержкой xml и исправлением сборки python-bind
------- Comment #4 From 2017-09-19 08:03:26 -------
(В ответ на комментарий №2)
Спасибо, добрый человек!

Выше добавил результирующий спек-файл, но чуть поторопился: демон удалось
запустить только после доустановки пакета openssl-engines и копирования в
/var/lib/bind/ каталога /usr/lib64/openssl/engines/.
Чтобы не приходилось так делать, в секцию %configure следует добавить ключик:
 --with-gost=no \
------- Comment #5 From 2017-09-19 08:08:08 -------
Осталось дождаться, когда мейнтейнер внесёт его в репозитории. :)
------- Comment #6 From 2018-07-17 16:39:04 -------
Уже было. Говорят, libxml дыряв.

*** This bug has been marked as a duplicate of bug 31401 ***