Bug 34020 - Конфликтует с libgstrawparse.so из gst-plugins-bad1.0
: Конфликтует с libgstrawparse.so из gst-plugins-bad1.0
Status: NEW
: Branch p8
(All bugs in Branch p8/gst-plugins-base1.0)
: не указана
: all Linux
: P3 normal
Assigned To:
:
:
:
: 33941
:
  Show dependency tree
 
Reported: 2017-10-17 10:24 by
Modified: 2018-05-24 16:37 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2017-10-17 10:24:19
В последнее время заметил такое сообщение при обновлении пакетов(apt-get
update) на машине

-----------------------------------------------------------------

Preparing...                
#############################################################################################
[100%]
file /usr/lib64/gstreamer-1.0/libgstrawparse.so from install of
gst-plugins-base1.0-1.12.3-alt0.M80P.1 conflicts with file from package
gst-plugins-bad1.0-1.10.5-alt0.M80P.1
E: Ошибка во время исполнения транзакции

-----------------------------------------------------------------

Такое и на "рабочей станции" и на "симпли"  8-версии. Хотя раньше пакеты
обновлялись без проблем. 

На альтовом форуме подсказали следующее: 
>> Типичная ошибка в spec-файле при сборке - недопроставленный "Conflicts".
------- Comment #1 From 2017-10-29 16:36:51 -------
file /usr/lib64/gstreamer-1.0/libgstrawparse.so from install of
gst-plugins-base1.0-1.12.3-alt0.M80P.1 conflicts with file from package
gst-plugins-bad1.0-1.8.2-alt2
------- Comment #2 From 2017-11-03 19:42:25 -------
# epm policy gst-plugins-bad1.0
предупреждение: пакет gst-plugins-bad1.0 не установлен
 # apt-cache policy gst-plugins-bad1.0
gst-plugins-bad1.0:
  Установлен: (нет)
  Кандидат: 1.12.3-alt0.M80P.1
  Таблица версий:
     1.12.3-alt0.M80P.1 0
        500 file: ALTLinux/p8/branch/x86_64/classic pkglist

apt-get install gst-plugins-bad1.0
Следующие пакеты имеют неудовлетворенные зависимости:
  gst-plugins-bad1.0: Требует: libx265.so.59()(64bit) (>=
set:plZozBek7OwnqtTPRH4h18BIDyv7Ilo9tAc1)

 # rpm -q --provides libx265
libx265.so.79()(64bit)

 # apt-cache policy libx265
libx265:
  Установлен: 1.9-alt1
  Кандидат: 1.9-alt1
  Таблица версий:
 *** 1.9-alt1 0
        100 RPM Database
     1.7-alt1 0
        500 file: ALTLinux/p8/branch/x86_64/classic pkglist
------- Comment #3 From 2017-11-03 19:44:08 -------
(В ответ на комментарий №2)
...
Беру обратно, это кто-то подсунул пакет из Сизифа:
>  # apt-cache policy libx265
> libx265:
>   Установлен: 1.9-alt1
>   Кандидат: 1.9-alt1
>   Таблица версий:
>  *** 1.9-alt1 0
>         100 RPM Database
>      1.7-alt1 0
>         500 file: ALTLinux/p8/branch/x86_64/classic pkglist
------- Comment #4 From 2018-05-24 16:37:04 -------
А почему на gst-plugins-bad1.0, когда надо на gst-plugins-base1.0 ?