Bug 34118 - Неверный регистр поля
: Неверный регистр поля
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/bacula9-director-postgresql)
: unstable
: all Linux
: P3 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2017-11-02 16:13 by
Modified: 2017-11-04 19:52 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2017-11-02 16:13:56
1. В скрипте создания таблиц /usr/share/bacula/scripts/make_postgresql_tables
указано:

408 CREATE TABLE version
409 (
410     versionid         integer               not null
411 );

При инсталяции с такой таблицей bacula-dir не мог корректно прочитать версию и
соответственно запуститься.

Привели таблицу к следующему виду:

408 CREATE TABLE Version
409 (
410     VersionId         integer               not null
411 );

После запуск директора произошел корректно.

2. При установке baculum9-tools baculum9-apache2 baculum9-common
baculum9-postgresql. Вместе с зависимостями поставился baculum9-sqlite3. После
установки, бакула директор пытался подключиться к базе sqlite. Решилось: rpm -e
--nodeps baculum9-sqlite3
------- Comment #1 From 2017-11-02 16:38:57 -------
Над первой проблемой работаю. Вторая проблема - скорее проблема резолвера
зависимостей apt-get либо же использования apt-get: установка
baculum9-postgresql baculum9-tools baculum9-apache2 baculum9-common (т.е.
указание пакета с postgresql в начале списка) не тянет за собой sqlite3-части.
------- Comment #2 From 2017-11-02 17:39:51 -------
bacula9-9.0.3-alt3.S1 -> sisyphus:

Thu Nov 02 2017 Aleksei Nikiforov <darktemplar@altlinux> 9.0.3-alt3.S1
- Fixed sql scripts to use VersionId with correct case (closes: #34118).
------- Comment #3 From 2017-11-04 19:52:20 -------
(В ответ на комментарий №2)
> bacula9-9.0.3-alt3.S1 -> sisyphus:
> 
> Thu Nov 02 2017 Aleksei Nikiforov <darktemplar@altlinux> 9.0.3-alt3.S1
> - Fixed sql scripts to use VersionId with correct case (closes: #34118).
Спасибо. Прошу собрать в p8.