Bug 34239 - Похоже, не работает Provides: grub2 (удаляется alterator-grub)
: Похоже, не работает Provides: grub2 (удаляется alterator-grub)
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/apt)
: unstable
: all Linux
: P3 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2017-11-27 10:06 by
Modified: 2018-04-25 11:42 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2017-11-27 10:06:33
# apt-get install grub-pc
Чтение списков пакетов... Завершено
Построение дерева зависимостей... Завершено
Следующие дополнительные пакеты будут установлены:
  grub-common
Следующие пакеты будут УДАЛЕНЫ:
  alterator-grub grub2-common grub2-efi grub2-pc
Следующие НОВЫЕ пакеты будут установлены:
  grub-common grub-pc
------- Comment #1 From 2017-11-27 10:41:45 -------
https://forum.altlinux.org/index.php?topic=40496.0
------- Comment #2 From 2017-11-27 10:45:56 -------
Из 

https://forum.altlinux.org/index.php?topic=40496.msg320069#msg320069

PS не понятно, почему выносит alterator-grub, хотя  grub-common провайдит
grub2-common
------- Comment #3 From 2017-11-27 10:52:12 -------
alterator-grub хочет grub2-pc, а не grub2-common:

Requires: grub2-pc > 2.00-alt20

Но у grub-pc Provides: grub2-pc тоже есть.
------- Comment #4 From 2017-11-27 10:57:43 -------
Боюсь что это ошибка в нашем apt'е, связанная с версиями у виртуальных пакетов.

Пользователей p8 это никак не должно затрагивать (у них при dist-upgrade grub
не меняется), а остальным можно посоветовать при обновлении делать так:
apt-get install grub-pc alterator-grub
должно сработать.

Что происходит в такой конфигурации ?
------- Comment #5 From 2017-11-28 09:18:06 -------
(In reply to comment #4)

> Что происходит в такой конфигурации ?

Да, так работает:

# apt-get install grub-pc alterator-grub
Чтение списков пакетов... Завершено
Построение дерева зависимостей... Завершено
Последняя версия alterator-grub уже установлена.
Следующие дополнительные пакеты будут установлены:
  grub-common grub-efi
Следующие пакеты будут УДАЛЕНЫ:
  grub2-common grub2-efi grub2-pc
Следующие НОВЫЕ пакеты будут установлены:
  grub-common grub-efi grub-pc
0 будет обновлено, 3 новых установлено, 3 пакетов будет удалено и 1 не будет
обновлено.
------- Comment #6 From 2017-11-28 09:21:28 -------
Перевешиваю на apt, проблема в нём.
------- Comment #7 From 2017-11-28 09:25:49 -------
Я уже Bug 34246 завёл, а этот думал на Grub оставить с WONTFIX.
------- Comment #8 From 2017-11-28 09:26:42 -------
Вообще, по моему на apt'е уже висит что-то подобное.
Проблема давняя.
------- Comment #9 From 2018-04-25 11:42:42 -------
исправлено в alterator-grub