Bug 3517 - libdb4.0: eliminate unneeded library
: libdb4.0: eliminate unneeded library
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/libdb4.0)
: unstable
: all Linux
: P2 enhancement
Assigned To:
:
:
:
: 3464 3527
: 3459
  Show dependency tree
 
Reported: 2004-01-19 15:24 by
Modified: 2006-12-17 16:22 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2004-01-19 15:24:49
This library should be eliminated, all clients should be ported to libdb4.1
------- Comment #1 From 2004-01-20 17:29:01 -------
perl-BerkeleyDB strongly depends on libdb4.0.  With libdb4.1, some tests fail,
which simply means it doesnot work. With libdb4.0, all tests pass.

I see there's a problem.  All perl modules should use the same version of libdb4
as they can be loaded simultaneously.  I would like to test perl-BerkeleyDB with
libdb4.2 before libdb4.0 eliminated.
------- Comment #2 From 2004-02-02 04:51:34 -------
$ aptbox/apt-cache whatdepends libdb-4.0.so 
<libdb-4.0.so> 
  sendmail-8.12.10-alt4 
    Требует: <libdb-4.0.so> 
      libdb4.0-4.0.14-alt11 
  python23-2.3.3-alt5 
    Требует: <libdb-4.0.so> 
      libdb4.0-4.0.14-alt11 
  poedit-1.2.2-alt2.1 
    Требует: <libdb-4.0.so> 
      libdb4.0-4.0.14-alt11 
  perl-Cyrus-2.2.3-alt1 
    Требует: <libdb-4.0.so> 
      libdb4.0-4.0.14-alt11 
  perl-BerkeleyDB-0.25-alt1 
    Требует: <libdb-4.0.so> 
      libdb4.0-4.0.14-alt11 
  osec-0.6.0-alt2 
    Требует: <libdb-4.0.so> 
      libdb4.0-4.0.14-alt11 
  maildrop-utils-1.6.2-alt1 
    Требует: <libdb-4.0.so> 
      libdb4.0-4.0.14-alt11 
  maildrop-userdb-1.6.2-alt1 
    Требует: <libdb-4.0.so> 
      libdb4.0-4.0.14-alt11 
  maildrop-common-1.6.2-alt1 
    Требует: <libdb-4.0.so> 
      libdb4.0-4.0.14-alt11 
  libsasl2-2.1.17-alt1 
    Требует: <libdb-4.0.so> 
      libdb4.0-4.0.14-alt11 
  librpm-4.0.4-alt32 
    Требует: <libdb-4.0.so> 
      libdb4.0-4.0.14-alt11 
  libinn-2.4.1-alt1 
    Требует: <libdb-4.0.so> 
      libdb4.0-4.0.14-alt11 
  inn-2.4.1-alt1 
    Требует: <libdb-4.0.so> 
      libdb4.0-4.0.14-alt11 
  gift-openft-0.2.1.2-alt1 
    Требует: <libdb-4.0.so> 
      libdb4.0-4.0.14-alt11 
  drac-1.11-alt3 
    Требует: <libdb-4.0.so> 
      libdb4.0-4.0.14-alt11 
  db4.0-utils-4.0.14-alt11 
    Требует: <libdb-4.0.so> 
      libdb4.0-4.0.14-alt11 
  cyrus-sasl2-2.1.17-alt1 
    Требует: <libdb-4.0.so> 
      libdb4.0-4.0.14-alt11 
  cyrus-imapd-utils-2.2.3-alt1 
    Требует: <libdb-4.0.so> 
      libdb4.0-4.0.14-alt11 
  cyrus-imapd-murder-2.2.3-alt1 
    Требует: <libdb-4.0.so> 
      libdb4.0-4.0.14-alt11 
  cyrus-imapd-2.2.3-alt1 
    Требует: <libdb-4.0.so> 
      libdb4.0-4.0.14-alt11 
  courier-imap-utils-2.1.2-alt1 
    Требует: <libdb-4.0.so> 
      libdb4.0-4.0.14-alt11 
  courier-imap-2.1.2-alt1 
    Требует: <libdb-4.0.so> 
      libdb4.0-4.0.14-alt11 
  courier-authdaemon-pgsql-2.1.2-alt1 
    Требует: <libdb-4.0.so> 
      libdb4.0-4.0.14-alt11 
  courier-authdaemon-mysql-2.1.2-alt1 
    Требует: <libdb-4.0.so> 
      libdb4.0-4.0.14-alt11 
  courier-authdaemon-ldap-2.1.2-alt1 
    Требует: <libdb-4.0.so> 
      libdb4.0-4.0.14-alt11 
  courier-authdaemon-2.1.2-alt1 
    Требует: <libdb-4.0.so> 
      libdb4.0-4.0.14-alt11 
  GConf-1.0.9-alt6 
    Требует: <libdb-4.0.so> 
      libdb4.0-4.0.14-alt11 
------- Comment #3 From 2004-02-23 03:42:47 -------
$ whatdepends libdb-4.0.so |fgrep -v libdb 
courier-imap-2.1.2-alt1.src.rpm 
drac-1.11-alt3.src.rpm 
inn-2.4.1-alt2.src.rpm 
maildrop-1.6.2-alt1.src.rpm 
osec-0.6.0-alt2.src.rpm 
poedit-1.2.2-alt2.1.src.rpm 
python23-2.3.3-alt5.src.rpm 
rpm-4.0.4-alt33.src.rpm 
sendmail-8.12.10-alt4.src.rpm 
------- Comment #4 From 2004-02-27 19:31:26 -------
osec-0.6.0-alt2.src.rpm 
poedit-1.2.2-alt2.1.src.rpm 
rpm-4.0.4-alt34.src.rpm 
 
------- Comment #5 From 2004-03-04 02:52:18 -------
Eliminated.