Bug 4049 - nscd не запускается
: nscd не запускается
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/nscd)
: unstable
: all Linux
: P2 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2004-04-28 13:57 by
Modified: 2007-01-20 02:23 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2004-04-28 13:57:14
1) Нет прав на запуск 
$ ll /usr/sbin/nscd
-rw-r--r--  1 root root 43900 Apr 28 13:45 /usr/sbin/nscd

2) После установки прав на запуск
# service nscd restart
Service nscd is not running.[PASSED]
Starting nscd service: [ DONE ]
# service nscd restart
Service nscd is not running.[PASSED]
Starting nscd service: [ DONE ]

3) не запускается вручную
# nscd -d
11995: /var/run/nscd/socket: No such file or directory

4) После создания каталога /var/run/nscd/
# service nscd restart
Service nscd is not running.[PASSED]
Starting nscd service: [ DONE ]
# service nscd restart
Service nscd is not running.[PASSED]
Starting nscd service: /usr/sbin/nscd: already running
[FAILED]

$ cat /etc/altlinux-release 
ALT Linux Sisyphus (20040427)

$ rpm -q nscd
nscd-2.3.3.200404190147-alt1
------- Comment #1 From 2004-04-28 21:57:31 -------
1) fixed in nscd-2.3.3.200404240000-alt1
2) unable to reproduce, please reopen and provide more info.
------- Comment #2 From 2004-04-30 14:47:55 -------
После обновления ничего с п.2 не изменилось.

Чтобы заработало, пришлось:
1) mkdir /var/run/nscd
2) chown root.nscd /var/run/nscd
3) chmod g+s /var/run/nscd
4) изменить /etc/init.d/nscd, строка 
PIDFILE=/var/run/nscd.pid 
на
PIDFILE=/var/run/nscd/nscd.pid

Может 2,3 и не нужно, думаю хуже не будет.
------- Comment #3 From 2004-04-30 15:00:50 -------
*** Bug 4062 has been marked as a duplicate of this bug. ***
------- Comment #4 From 2004-04-30 15:15:11 -------
Похоже что я пропустил это изменение в nscd.
------- Comment #5 From 2004-04-30 15:49:33 -------
Попробуйте сделать
chmod 711 /var/run/nscd
chown 0:0 /var/run/nscd
service nscd restart
- должно работать не хуже, чем с теми правами, которые сделали вы.
------- Comment #6 From 2004-04-30 16:09:48 -------
Да, с этими правами тоже все работает
------- Comment #7 From 2004-04-30 18:18:37 -------
Thanks, fixed in nscd-2.3.3.200404240000-alt3.