Bug 4210 - что-то сломано в /etc/dhcpc/dhcpcd.exe
: что-то сломано в /etc/dhcpc/dhcpcd.exe
Status: CLOSED DUPLICATE of bug 4158
: Sisyphus
(All bugs in Sisyphus/dhcpcd)
: unstable
: all Linux
: P2 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2004-05-22 13:55 by
Modified: 2005-07-13 15:46 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2004-05-22 13:55:13
Это из /var/log/messages:
May 22 12:33:35 home ifup: /etc/dhcpc/dhcpcd.exe: line 27: .: filename argument
required                       
May 22 12:33:35 home ifup: .: usage: . filename
После добавления в /etc/dhcpc/dhcpcd.exe отладочной строки
logger "dhcpd.exe: 1==$1 2==$2 3==$3"
в логе получаем следующее:
May 22 12:40:58 home root: dhcpd.exe: 1== 2==down 3==
(Никакого DHCP-сервера там нет, конфигурация интерфейса следующая:
DEVICE=eth0                                                                    
                               
BOOTPROTO=dhcp,zcip                                                            
                               
IPADDR=10.200.200.1                                                            
                               
NETMASK=255.255.255.0                                                          
                               
ONBOOT=yes

Не передаются необходимые параметры скрипту.
# rpm -q dhcpcd
dhcpcd-1.3.22pl4-alt1
------- Comment #1 From 2004-05-22 13:57:43 -------

*** This bug has been marked as a duplicate of 4158 ***