Bug 4359 - synaptic падает при запуске
: synaptic падает при запуске
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/synaptic)
: unstable
: all Linux
: P2 blocker
Assigned To:
:
:
:
:
: 3459
  Show dependency tree
 
Reported: 2004-06-15 00:57 by
Modified: 2006-12-17 16:22 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2004-06-15 00:57:37
synaptic (включая 0.48.2) падает при запуске, если имеются нарушенные 
зависимости. 
Пример: 
apt-get install planner 
rpm -e --nodeps libplanner 
synaptic
------- Comment #1 From 2004-06-16 21:00:53 -------
Не воспроизводится.
При запуске показывает сообщение о том, что имеются нарушенные зависимости и
предалгает выбрать фильтр "Broken" для того, чтоб посмотреть пакеты с
нарушенными зависимостями.
------- Comment #2 From 2004-06-16 22:35:22 -------
Оказывается, нужно побольше сломанных зависимостей. 
Например, так: 
# apt-get remove libxml2-devel 
# rpm -ivh --nodeps libgnome-devel-2.6.1.1-alt1.i586.rpm 
$ synaptic 
------- Comment #3 From 2004-06-25 20:34:01 -------
Нда, есть такой глюк...

ЗЫ в 0.51 это обрабатывается нормально :)
------- Comment #4 From 2004-07-02 10:56:40 -------
see 4564
------- Comment #5 From 2004-07-02 11:31:14 -------
*** Bug 4564 has been marked as a duplicate of this bug. ***
------- Comment #6 From 2004-07-11 23:42:05 -------
Fixed in 0.48.2-alt3