Bug 5046 - /etc/profile.d/lang.csh doesn't interprets "export" command in ~/.i18n
Summary: /etc/profile.d/lang.csh doesn't interprets "export" command in ~/.i18n
Status: CLOSED DUPLICATE of bug 2618
Alias: None
Product: Sisyphus
Classification: Development
Component: setup (show other bugs)
Version: unstable
Hardware: all Linux
: P2 normal
Assignee: Alexey Gladkov
QA Contact: qa-sisyphus
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-08-22 00:14 MSD by evseev
Modified: 2007-04-21 16:19 MSD (History)
3 users (show)

See Also:


Attachments
lang.csh.diff (697 bytes, patch)
2004-11-15 16:15 MSK, Dmitry V. Levin
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description evseev 2004-08-22 00:14:51 MSD
.i18n file provided by etcskel package is actually shell script. /etc/profile.
d/lang.csh converts all lines having "NAME=VALUE" format to "setenv NAME VALUE". 
But additionally i18n may contain "export" command that is now not suppressed 
nor converted by lang.csh and causes error when our primary shell is tcsh.

This bug exists also in M22 classic initscripts package.

Steps to Reproduce:
1. Change your shell to tcsh
2. Check that ~/.i18n contain export command (this is so for russian locale)
3. Login

Actual Results:  
"export: Command not found" error on tcsh login.


Expected Results:  
no error message.
Comment 1 Dmitry V. Levin 2004-11-15 16:15:48 MSK
Created attachment 642 [details]
lang.csh.diff

Please try this patch.
Comment 2 Dmitry V. Levin 2004-11-15 23:44:04 MSK

*** This bug has been marked as a duplicate of 2618 ***