Bug 5259 - Add pentium4 arch support
: Add pentium4 arch support
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/rpm)
: unstable
: all Linux
: P2 enhancement
Assigned To:
:
:
:
:
: 5274
  Show dependency tree
 
Reported: 2004-09-28 16:39 by
Modified: 2008-01-13 20:38 (History)


Attachments
pentium4 arch support (5.53 KB, patch)
2004-09-28 16:40, Sir Raorn
no flags Details | Diff
pentium4 arch support (update) (5.58 KB, patch)
2004-10-02 14:49, Sir Raorn
no flags Details | Diff
Add Athlon XP arch support (4.95 KB, patch)
2004-10-03 15:04, Немос
no flags Details | Diff


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2004-09-28 16:39:41
Add pentium4 arch support in rpm
------- Comment #1 From 2004-09-28 16:40:50 -------
Created an attachment (id=598) [details]
pentium4 arch support
------- Comment #2 From 2004-10-02 14:49:04 -------
Created an attachment (id=601) [details]
pentium4 arch support (update)

- Fixed typo in sed subst's
- Recognize Intel(R) Xeon(TM)
------- Comment #3 From 2004-10-03 15:04:05 -------
Created an attachment (id=602) [details]
Add Athlon XP arch support

патчить после патча rpm-4_0-4.0.4-alt-pentium4-arch.patch
------- Comment #4 From 2004-10-03 16:26:25 -------
(In reply to comment #3)
> Created an attachment (id=602) [details]
> Add Athlon XP arch support
Патч для installplatform - кривой. Работать не будет.
------- Comment #5 From 2004-10-03 21:17:37 -------
(In reply to comment #4)
> (In reply to comment #3)
> > Created an attachment (id=602) [details]
> > Add Athlon XP arch support
> Патч для installplatform - кривой.
В чем именно? Вроде ошибку с sed учел.
> Работать не будет.
У меня работает.
------- Comment #6 From 2004-10-03 22:17:27 -------
(In reply to comment #5)
> В чем именно? Вроде ошибку с sed учел.
Попробуйте пересобрать пакет патченым rpm - увидите.
------- Comment #7 From 2004-10-04 08:57:31 -------
(In reply to comment #6)
> (In reply to comment #5)
> > В чем именно? Вроде ошибку с sed учел.
> Попробуйте пересобрать пакет патченым rpm - увидите.
Сборка rpm и glibc подайдет?
Проблема возникла только у glibc, точнее две проблемы (думаю втору проблему вы
имели ввиду, но она не проблема rpm, а проблема libtool):
1. непонятный баг не возможности найти перловые зависимости пакета glibc-utils
возникающий при попытке пересобрать glibc под архитектуру отличную от i586,
лечится указанием не искать перловые зависимости для glibc-utils.
2. glibc как половина пакетов из сизифа использует config.sub из libtool, а он
не понимает машину athlonxp-alt-linux (патчик кидал в sisyphus@, но для порядка
закинул сейчас в багзиллу https://bugzilla.altlinux.org/show_bug.cgi?id=5274),
лечится правкой config.sub
С этим config.sub придется помучится, наврятли быстро обновят пол сизифа для
поддержки сборки под athlonxp.
------- Comment #8 From 2004-10-04 09:11:45 -------
(In reply to comment #7)
> > Попробуйте пересобрать пакет патченым rpm - увидите.
> Сборка rpm и glibc подайдет?
Я вижу две грубые ошибки в патче для installplatform.

> Проблема возникла только у glibc,
glibc с --enable archopt собирается только под i686. Это by design.
------- Comment #9 From 2004-10-04 21:51:00 -------
(In reply to comment #8)
> (In reply to comment #7)
> > > Попробуйте пересобрать пакет патченым rpm - увидите.
> > Сборка rpm и glibc подайдет?
> Я вижу две грубые ошибки в патче для installplatform.

Какие именно?

> > Проблема возникла только у glibc,
> glibc с --enable archopt собирается только под i686. Это by design.
Под athlon тоже как то собирал, но при этом правда пересобирается лишь
glibc-core, мне же захотелось пересобрать его полностью.
------- Comment #10 From 2004-10-31 23:12:14 -------
Applied p4 support patch.
------- Comment #11 From 2004-11-03 13:29:54 -------
(In reply to comment #10)
> Applied p4 support patch.
а с патчем для athlon xp что?
------- Comment #12 From 2004-11-13 10:09:16 -------
(In reply to comment #8)
> (In reply to comment #7)
> > > Попробуйте пересобрать пакет патченым rpm - увидите.
> > Сборка rpm и glibc подайдет?
> Я вижу две грубые ошибки в патче для installplatform.
Одну нашел какая вторая?
Ошибка:
вместо
i[3456]86|k6|athlon|pentium4)
нужно
i[3456]86|k6|athlon|athlonxp|pentium4)