Bug 5380 - Неверные зависимости в modules.dep для NAT(ipv4) модулей
: Неверные зависимости в modules.dep для NAT(ipv4) модулей
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/kernel-image-std26-smp)
: unstable
: all Linux
: P2 critical
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2004-10-22 22:23 by
Modified: 2006-03-24 12:22 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2004-10-22 22:23:47
При создании файла modules.dep командой depmod -a для ядра
kernel-image-std26-smp#2.6.9-alt10 неверно прописываются зависимости модулей
для
NAT(ipv4) подсистемы. Для каждого модуля, начиная с нижнего (iptable_nat.ko) к
списку зависимостей добаыляется ipfwadm.ko, который мало того, что IMO
предназначен для эмуляции старой системы ipfwadm, так еще и не грузится. Из-за
этого не загружается ни один из модулей NAT(ipv4) и, соответственно, NAT(ipv4)
не работает.

При этом для *-up ядра все прописывается правильно.

Steps to Reproduce:
1. modprobe ip_nat_ftp

Actual Results:  
modprobe: Error inserting
'/lib/modules/2.6.9-std26-smp-alt10/kernel/net/ipv4/netfilter/ipfwadm.ko': -1
Device or resource busy
iptables: Loading module ip_nat_ftp: failed
------- Comment #1 From 2004-11-01 18:45:40 -------
fixed (2.6.9-alt11)