Bug 5478 - ftp & -X erratically
: ftp & -X erratically
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/wget)
: unstable
: all Linux
: P3 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2004-11-10 17:37 by
Modified: 2006-12-17 23:16 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2004-11-10 17:37:46
wget-1.9.1-alt1.1

1)
wget -X/music/Album ftp://somehost/music - работает, Album исключен
wget -X/music/A* ftp://somehost/music - не работает, Album скачивается
wget -X/music/Albu? ftp://somehost/music - не работает, Album скачивается

2)
wget -X/music/Album ftp://somehost/music - работает, Album исключен
echo "exclude_directories = /music/Album" >~/.wgetrc && wget
ftp://somehost/music - не работает, Album скачивается
Такое ощущение, что exclude_directories в конфиге вообще не работает.

glob принудительно включен. Сервер: 220 Welcome to Pure-FTPd [privsep]
------- Comment #1 From 2005-06-29 22:32:45 -------

*** This bug has been marked as a duplicate of 5151 ***
------- Comment #2 From 2005-06-29 23:02:51 -------
шой-то меня проплющило хорошо так... спать пора.
------- Comment #3 From 2005-06-29 23:04:22 -------
*** Bug 5579 has been marked as a duplicate of this bug. ***
------- Comment #4 From 2006-02-08 10:54:29 -------
Проверь на 1.10.2?
------- Comment #5 From 2006-10-15 00:28:50 -------
1.10.2:

$ wget -r -X'/pub/projects/git/mike/alterator*'
ftp://ftp.linux.kiev.ua/pub/projects/git/mike >/dev/null 
$ ftp.linux.kiev.ua/pub/projects/git/mike 
pciutils

(там ещё два подкаталога вида alterator-* было)