Bug 6889 - [FR] [5.0] (!) add "pci=routeirq" to "Safe settings" boot params
: [FR] [5.0] (!) add "pci=routeirq" to "Safe settings" boot params
Status: CLOSED WORKSFORME
: Sisyphus
(All bugs in Sisyphus/alterator-lilo)
: unstable
: all Linux
: P2 enhancement
Assigned To:
:
: http://faq.altlinux.ru/index.php?acti...
:
:
: 17728
  Show dependency tree
 
Reported: 2005-05-18 00:42 by
Modified: 2013-03-15 21:04 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2005-05-18 00:42:02
Есть подозрение, что в флаги загрузки в "безопасном" режиме стоит добавить
"pci=routeirq" (см. Url).
------- Comment #1 From 2005-06-29 22:51:21 -------
JFYI: с последней версией ltmodem этого уже не надо.
------- Comment #2 From 2005-06-29 22:53:48 -------
А оно что, только с ltmodem вылазило?.. грабли-то подводные.
------- Comment #3 From 2005-06-29 23:05:40 -------
Ну я других случаев не слышал, хотя, вообще говоря, никто не гарантирует, что 
точно нигде не вылезет.
------- Comment #4 From 2005-06-30 15:43:32 -------
to manteiner  
------- Comment #5 From 2005-07-06 16:20:51 -------
Стас, тут Костик тоже это независимо выдвигал (только "по умолчанию", что IMHO
немного сильно).
------- Comment #6 From 2005-07-09 16:41:34 -------
Вообще-то оно у меня вылазит и с drm, и с некоторыми usb контроллерами. Так что
пока routeirq просто необходим для нормальной работы.
------- Comment #7 From 2005-08-04 11:59:29 -------
Не разу не сталкивался. IMHO не надо все засовывать в Safe.
Можно просто описать в документации.
------- Comment #8 From 2005-08-04 13:18:01 -------
То, что ты не сталкивался, ещё не говорит о том, что так не бывает. [...]

Предлагаемое не вносит (AFAIK) никаких регрессов или дополнительных опасностей
в
safe, но добавляет решение ещё нескольких проблем "одной кнопкой".

Давайте спросим vsu?
------- Comment #9 From 2005-08-04 18:04:36 -------
и что ? теперь вносить все возможные опции в cmdline ?

Достаточно надписи в документации.
------- Comment #10 From 2005-08-04 22:35:47 -------
Для корректной работы DVB-карточки SkyStar2 эта опция тоже необходима.
------- Comment #11 From 2005-08-04 22:42:13 -------
По твоей логике пункт safe mode не нужен, поскольку vga=0 noapic nolapic
acpi=off -- это тоже строчка в документации.  И memtest не нужен, поскольку это
тоже строчка в документации -- скачать дискетку и сунуть.  И rescue не нужен,
RTFM.

Да и сам инсталер, в общем, незачем -- достаточно написать документацию, делают
же так LFS и Gentoo.

Ладно, вольному воля.
------- Comment #12 From 2005-09-02 00:03:34 -------
Будет ли написано о возможных параметрах в той справке, которая идёт к 
загрузчику? То есть не в книжке и не на диске, а доступная сразу из LILO? 
------- Comment #13 From 2005-09-02 01:32:19 -------
хороший вопрос
------- Comment #14 From 2005-09-02 12:18:15 -------
> Будет ли написано о возможных параметрах в той справке, которая идёт к 
> загрузчику? То есть не в книжке и не на диске, а доступная сразу из LILO? 

Будет, если мне дать список параметров, которые нужно там описать и по 
каждому параметру -- что про него должно быть сказано (текст может быть 
любой степени литературности). 
Если эти условия выполнить, то будет даже очень быстро.
------- Comment #15 From 2008-01-25 16:50:19 -------
Неактуально.
------- Comment #16 From 2008-03-30 20:49:58 -------
Поскольку дома наткнулся на необходимость pci=routeirq для устойчивой работы
FireWire-карточки -- предлагаю переоткрыть и порешать для 4.1.
------- Comment #17 From 2009-01-26 18:35:27 -------
перевешиваю на современный пакет
------- Comment #18 From 2009-08-17 15:13:19 -------
2 ktirf: всё-таки пока актуально, пусть и в качестве FR.
------- Comment #19 From 2010-11-03 15:31:19 -------
Видимо, alterator-lilo следует считать заброшенным.
На nobody@
------- Comment #20 From 2013-03-15 21:04:20 -------
(In reply to comment #16)
> наткнулся на необходимость pci=routeirq
Отпало уже к 5.1/branch, рекомендаций таких тоже давно уж не наблюдаю.