Bug 7061 - mutt1.5: fix dependency on timelocal.pl
: mutt1.5: fix dependency on timelocal.pl
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/mutt1.5)
: unstable
: all Linux
: P2 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2005-06-11 10:23 by
Modified: 2009-06-21 22:28 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2005-06-11 10:23:28
/usr/lib/perl5/timelocal.pl:
;# This file has been superseded by the Time::Local library module.
;# It is implemented as a call to that module for backwards compatibility
;# with code written for perl4; new code should use Time::Local directly.

mutt1.5-alt-req-timelocal.patch:
--- smime_keys.pl-	2005-01-29 11:50:53 +0000
+++ smime_keys.pl	2005-06-11 06:16:35 +0000
@@ -23,7 +23,7 @@ use File::Copy;
 
 umask 077;
 
-require "timelocal.pl";
+use Time::Local qw(timegm);
 
 sub usage ();
 sub newfile ($;$$);
------- Comment #1 From 2005-07-23 13:23:10 -------
Склероз проклятый...  В следующей сборке поправлю.
------- Comment #2 From 2005-08-22 20:58:18 -------
Fixed in 1.5.10i-alt2
------- Comment #3 From 2009-06-21 19:29:44 -------
*** Bug 19454 has been marked as a duplicate of this bug. ***
------- Comment #4 From 2009-06-21 19:30:35 -------
Потерялось при переезде.
------- Comment #5 From 2009-06-21 22:28:24 -------
mutt1.5-3:1.5.20-alt1 -> sisyphus:

* Sun Jun 21 2009 Alexey I. Froloff <raorn@altlinux> 3:1.5.20-alt1

- [1.5.20] (closes: #20476)
  ! $fcc_attach is a quadoption now
  + $honor_disposition to honor Content-Disposition headers
  + $search_context specifies number of context lines for search results
    in pager/page-based menus
  ! ssl_use_sslv2 defaults to no
  + uncolor works for header + body objects, too
  + the "flagged" and "replied" flags are enabled/supported for
    POP when built with header caching
  ! browser correctly displays maildir's mtime
  + <set-flag> and <clear-flag> work in the pager, too
  + ~x pattern also matches against In-Reply-To
  + lower case patterns for string searches perform case-insensitive
    search as regex patterns do (except IMAP)
  + $ssl_verify_dates controls whether mutt checks the validity period of
    SSL certificates
  + $ssl_verify_hostname controls whether mutt will accept certificates whose
    host names do not match the host name in the folder URL.
- Removed dependency on perl(timelocal.pl) (closes: #7061)