Bug 7308 - alterator-x11 + mga/radeon: mode test leaves second X server running
: alterator-x11 + mga/radeon: mode test leaves second X server running
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/xorg-x11)
: unstable
: all Linux
: P1 blocker
Assigned To:
:
:
:
:
: 7079 7371
  Show dependency tree
 
Reported: 2005-07-06 19:45 by
Modified: 2007-10-23 15:17 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2005-07-06 19:45:42
в alterator-x11, что в 2.9.11, после подтверждения успешности конфигурации
остаётся висеть X-сервер.  соответственно пробраться дальше получается только
если догадаться переключиться на tty3/tty7 и сказать игнорировать ошибку.

это и в init 7, и в acc; замечено на Matrox G200
------- Comment #1 From 2005-07-06 19:54:30 -------
так... вот чего ещё:

- пустили acc, иксовый модуль
- сказали разрешение 800x600 (стоит 1280x1024)
- "проверить/записать"
- (tty2) pidof X => два сервера
- (tty7) висит табличка "тест не прошёл, игнорировать?"
- ответили "да, видим"
- экран мигнул, остался один крестообразный иксовый курсор
- (tty2) pidof X -- _точно те же_ два сервера
- (tty7) висит табличка...
=> где-то отпустили процесс на волю?

При этом без прибивания второго сервера повторный тест не удался, ну да это уже
неважно.
------- Comment #2 From 2005-07-06 20:34:13 -------
под vmware не поймал
------- Comment #3 From 2005-07-06 21:16:21 -------
под ati (Rage128) не воспроизводится... возможно, это только mga, тебя пускать
на машинку? ;-)
------- Comment #4 From 2005-07-06 22:59:28 -------
под nvidia тоже не воспроизводится.  надо искать ещё матрасников
------- Comment #5 From 2005-07-07 01:08:30 -------
не, это не mga-specific

Date: Wed, 6 Jul 2005 19:28:11 +0400
From: "Sergey S. Skulachenko"
To: ALT Linux Sisyphus discussion list
Subject: Re: [sisyphus] I: installer-2.9.11.iso

У меня на Radeon 7000 после вопроса "Видите ли Вы это сообщение?"
и ответа "да" возникает чёрный экран с курсором-крестиком. Выйти
из него можно с помощью Cntrl-Alt-Backspace. После этого
возвращается зелёный экран с вопросом "были ли проблемы?". После
ответа "нет" установка нормально завершается, а Х-ы запускаются с
выбранным разрешением.
------- Comment #6 From 2005-07-07 09:47:46 -------
Это бага в xorg.
------- Comment #7 From 2005-07-07 09:49:59 -------
reassign to xorg mantainer.

2shrek: проблема в том, что xinit не прибивает xorg после окончания работы
приложения.
------- Comment #8 From 2005-07-07 15:49:28 -------
похоже что не всегда и не на всех видеокартах  
------- Comment #9 From 2005-07-07 16:59:35 -------
именно: ati / nvidia / s3 -- порядок, mga / radeon -- поймали
завтра будет sis, если Женька не забудет
------- Comment #10 From 2005-07-07 17:00:02 -------
эээ.... могу на машинке с mga рутшелл обеспечить
------- Comment #11 From 2005-07-10 14:40:10 -------
(In reply to comment #4) 
> под nvidia тоже не воспроизводится. 
У меня воспроизводится, на 2.9.11, см #6964c24. 
 
------- Comment #12 From 2005-07-11 16:27:06 -------
пробуйте на alt11 
------- Comment #13 From 2005-07-15 09:53:21 -------
Эта ошибка исправлена в alterator-x11-0.3.7

Но:

ошибка в xinit осталась. Заключается в том, что при получении сигнала на
завершение своей работы xinit не прекращает работу своих потомков (X и xtest в
данном случае).

------- Comment #14 From 2005-09-08 15:13:07 -------
считаем что исправлено в новом alterator-x11
------- Comment #15 From 2005-09-08 16:22:16 -------
имеет смысл собирать стендик с mga? (что именно -- версии -- проверить?)
------- Comment #16 From 2005-09-08 16:27:02 -------
я ставил себе матрас 450, но так и не поймал ничего