Bug 7655 - некорректная работа в локали utf-8
: некорректная работа в локали utf-8
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/zsh)
: unstable
: all Linux
: P2 critical
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2005-08-12 12:47 by
Modified: 2006-12-08 12:13 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2005-08-12 12:47:47
в локали utf8 zsh не работает нормально
------- Comment #1 From 2005-08-12 12:53:33 -------
(In reply to comment #0)
> в локали utf8 zsh не работает нормально
В Debian stable работает. 
------- Comment #2 From 2005-08-12 13:53:35 -------
*** Bug 7656 has been marked as a duplicate of this bug. ***
------- Comment #3 From 2005-08-12 20:22:24 -------
На этой неделе в zsh-workers опять взялись мутозить ZLE_UNICODE_SUPPORT.
Результатом стало то, что при попытке автодополнения zsh теперь не падает
в корку.  Комментарий от David GГiimez:

I've already tried it with ZLE_UNICODE_SUPPORT enabled ;). It's not so easy
to get a segmentation fault as before. Fist thing i noticed is that when you
try to complete a line, it always tries to complete the first word.

Только что-то я нихера не понимаю, чево они там сделать хотят.  Они там за
основу взяли не utf8, а четырехбайтовый wchar_t.
------- Comment #4 From 2005-09-08 15:15:00 -------
не критично для 3.0
------- Comment #5 From 2005-09-09 08:51:18 -------
То есть zsh в ALC3.0 не будет?
------- Comment #6 From 2005-09-09 11:10:19 -------
В main -- очевидно, нет, судя по предыдущей постановке задачи и текущему
(afaik)
состоянию у нас.  В contrib -- вроде должен быть.
------- Comment #7 From 2006-12-08 12:13:07 -------
zsh-4.3.2-alt2
УМВР