Bug 7851 - не работает Aureal Semiconductor Vortex 1
: не работает Aureal Semiconductor Vortex 1
Status: CLOSED WORKSFORME
: Sisyphus
(All bugs in Sisyphus/kernel-modules-alsa-std26-up)
: unstable
: all Linux
: P2 blocker
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2005-09-03 16:49 by
Modified: 2005-12-02 23:59 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2005-09-03 16:49:32
Compact-3.0-rc6 он же ALT Linux Sisyphus (20050723)
Не работает Aureal Semiconductor Vortex 1, при том, что девайс детектится.

[root@localhost log]# pciscan -v -c004
Recommended driver     Description
------------------     -----------
snd-au8820             Aureal Semiconductor Vortex 1 [Multimedia audio controller]
                       12eb:0001:12eb:0001  drivers: 24:snd-au8820 snd-au8820 
class:004:01:00
                       slot: 0000:00:0a.0  hwid: AE94ECD46E719A25

[root@localhost log]# pciscan -v
Recommended driver     Description
------------------     -----------
amd-k7-agp             Advanced Micro Devices [AMD] AMD-751 [Irongate] System
Controller [Host bridge]
                       1022:7006  drivers: 31:amd-k7-agp  class:006:00:00
                       slot: 0000:00:00.0  hwid: 1F307149A183472B

shpchp                 Advanced Micro Devices [AMD] AMD-751 [Irongate] AGP
Bridge [PCI bridge Normal decode]
                       1022:7007  drivers: 7:shpchp  class:006:04:00
                       slot: 0000:00:01.0  hwid: 73F05EB67F70824E

unknown                Advanced Micro Devices [AMD] AMD-756 [Viper] ISA [ISA bridge]
                       1022:7408  drivers:  not found  class:006:01:00
                       slot: 0000:00:07.0  hwid: C85B1F10993ADC4E

amd74xx                Advanced Micro Devices [AMD] AMD-756 [Viper] IDE [IDE
interface storage controller]
                       1022:7409  drivers: 24:amd74xx amd74xx  class:001:01:8a
                       slot: 0000:00:07.1  hwid: 2C14D99A594DF392

i2c-amd756             Advanced Micro Devices [AMD] AMD-756 [Viper] ACPI [Bridge]
                       1022:740b  drivers: 24:i2c-amd756  class:006:80:00
                       slot: 0000:00:07.3  hwid: DCE6A5712E4C8AF1

ohci-hcd               Advanced Micro Devices [AMD] AMD-756 [Viper] USB [OHCI
USB Controller]
                       1022:740c  drivers: 2.6|ohci-hcd 2.4|usb-ohci 7:ohci-hcd
usb-ohci  class:00c:03:10
                       slot: 0000:00:07.4  hwid: 731FC0A5BB98819D

snd-au8820             Aureal Semiconductor Vortex 1 [Multimedia audio controller]
                       12eb:0001:12eb:0001  drivers: 24:snd-au8820 snd-au8820 
class:004:01:00
                       slot: 0000:00:0a.0  hwid: AE94ECD46E719A25

tdfxfb                 3Dfx Interactive, Inc. Voodoo 3 [VGA compatible controller]
                       121a:0005:121a:0030  drivers: 24:i2c-voodoo3 25:tdfxfb 
class:003:00:00
                       slot: 0000:01:05.0  hwid: 425FCBCB6459FD76

[root@localhost log]# 
Команда modprobe snd-au8820 результата не даёт. 
Steps to Reproduce:
1.Загрузка Xorg (KDE)
2.Модуль звуковушки не работает
3.
Actual Results:  
нет звука Aureal Semiconductor Vortex 1
------- Comment #1 From 2005-09-05 15:51:06 -------
Так модули то загружены ?

lsmod что показывает ?
------- Comment #2 From 2005-09-05 22:44:47 -------
[root@localhost RPMS.base]# lsmod
Module                  Size  Used by
nls_koi8_r              5376  1
isofs                  35128  1
nls_base                7296  2 nls_koi8_r,isofs
zlib_inflate           18560  1 isofs
lp                     12616  0
fan                     4740  0
battery                 9604  0
ac                      4996  0
thermal                13192  0
processor              22324  1 thermal
button                  6800  0
ide_cd                 39684  1
cdrom                  37536  1 ide_cd
i2c_amd756              6404  0
i2c_core               21008  1 i2c_amd756
shpchp                 90212  0
pci_hotplug            26804  1 shpchp
amd_k7_agp              8716  1
agpgart                34248  1 amd_k7_agp
parport_pc             38468  1
parport                33864  2 lp,parport_pc
8250_pnp                8704  0
8250                   32100  1 8250_pnp
serial_core            21120  1 8250
floppy                 57300  0
evdev                   9344  0
psmouse                35844  0
pcspkr                  3652  0
ohci_hcd               20484  0
usbcore               114012  2 ohci_hcd
snd_au8820             35008  0
gameport               14984  1 snd_au8820
snd_ac97_codec         77436  1 snd_au8820
snd_pcm_oss            51744  0
snd_seq_dummy           3972  0
snd_seq_oss            33024  0
snd_seq_midi_event      7040  1 snd_seq_oss
snd_seq                49296  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
snd_mixer_oss          18048  1 snd_pcm_oss
snd_pcm                85384  3 snd_au8820,snd_ac97_codec,snd_pcm_oss
snd_timer              23812  2 snd_seq,snd_pcm
snd_page_alloc          9860  1 snd_pcm
snd_mpu401_uart         7296  1 snd_au8820
snd_rawmidi            24480  1 snd_mpu401_uart
snd_seq_device          8716  4 snd_seq_dummy,snd_seq_oss,snd_seq,snd_rawmidi
snd                    53636  12
snd_au8820,snd_ac97_codec,snd_pcm_oss,snd_seq_dummy,snd_seq_oss,snd_seq,snd_mixer_oss,snd_pcm,snd_timer,snd_mpu401_uart,snd_rawmidi,snd_seq_device
soundcore               9184  1 snd
subfs                   7680  2
dm_mod                 55868  1
rtc                    12216  0
ext3                  127880  3
jbd                    52760  1 ext3
mbcache                 9476  1 ext3
ide_disk               17024  5
ide_generic             1408  0 [permanent]
amd74xx                12572  0 [permanent]
ide_core              120856  4 ide_cd,ide_disk,ide_generic,amd74xx
[root@localhost RPMS.base]# 
------- Comment #3 From 2005-09-06 09:22:09 -------
модули загружены. Значит это не проблема hotplug.

А регулятор громкости выставлен ?
------- Comment #4 From 2005-09-06 19:30:11 -------
aumix не запускается. KMix запускается, но без параметров.
Информационное – Сообщение aRts
Sound server informational message:
Error while initializing the sound driver:
device /dev/dsp can't be opened (No such file or directory)
The sound server will continue, using the null output device.
------- Comment #5 From 2005-09-28 21:29:28 -------
Compact-3.0-rc7
Звук не работает. lsmod не изменился. Модуль подгружен(snd_au8820).
------- Comment #6 From 2005-09-29 10:05:38 -------
reassign to alsa
------- Comment #7 From 2005-09-29 12:25:02 -------
Запускать надо не aumix, а alsamixer - в aumix доступны далеко не все
регуляторы.

Покажите вывод dmesg, cat /proc/asound/cards и amixer contents.
------- Comment #8 From 2005-09-29 22:42:41 -------
[root@localhost root]# dmesg
Linux version 2.6.12-std26-up-alt4 (builder@salto.malta.altlinux.ru) (gcc
version 3.4.4 20050526 (ALT Linux, build 3.4.4-alt1)) #1 Tue Aug 16 16:28:22 MSD
2005
BIOS-provided physical RAM map:
 BIOS-e820: 0000000000000000 - 000000000009fc00 (usable)
 BIOS-e820: 000000000009fc00 - 00000000000a0000 (reserved)
 BIOS-e820: 00000000000f0000 - 0000000000100000 (reserved)
 BIOS-e820: 0000000000100000 - 000000001fff0000 (usable)
 BIOS-e820: 000000001fff0000 - 000000001fff8000 (ACPI data)
 BIOS-e820: 000000001fff8000 - 0000000020000000 (ACPI NVS)
 BIOS-e820: 00000000ffff0000 - 0000000100000000 (reserved)
0MB HIGHMEM available.
511MB LOWMEM available.
On node 0 totalpages: 131056
  DMA zone: 4096 pages, LIFO batch:1
  Normal zone: 126960 pages, LIFO batch:31
  HighMem zone: 0 pages, LIFO batch:1
DMI 2.3 present.
ACPI: RSDP (v000 AMI                                   ) @ 0x000fabb0
ACPI: RSDT (v001 AMIINT          0x00000010 MSFT 0x00000097) @ 0x1fff0000
ACPI: FADT (v001 AMIINT          0x00000011 MSFT 0x00000097) @ 0x1fff0030
ACPI: DSDT (v001 AMD75X IRONGATE 0x00001000 MSFT 0x0100000b) @ 0x00000000
ACPI: PM-Timer IO Port: 0x5008
Allocating PCI resources starting at 20000000 (gap: 20000000:dfff0000)
Built 1 zonelists
Kernel command line: auto BOOT_IMAGE=linux-up ro root=301 splash=silent
bootsplash: silent mode.
Local APIC disabled by BIOS -- you can enable it with "lapic"
mapped APIC to ffffd000 (01402000)
Initializing CPU#0
PID hash table entries: 2048 (order: 11, 32768 bytes)
Detected 1212.916 MHz processor.
Using pmtmr for high-res timesource
Console: colour dummy device 80x25
Dentry cache hash table entries: 131072 (order: 7, 524288 bytes)
Inode-cache hash table entries: 65536 (order: 6, 262144 bytes)
Memory: 515788k/524224k available (1496k kernel code, 7884k reserved, 738k data,
184k init, 0k highmem)
Checking if this processor honours the WP bit even in supervisor mode... Ok.
Calibrating delay loop... 2400.25 BogoMIPS (lpj=1200128)
Security Framework v1.0.0 initialized
Capability LSM initialized
Mount-cache hash table entries: 512
CPU: After generic identify, caps: 0183f9ff c1c3f9ff 00000000 00000000 00000000
00000000 00000000
CPU: After vendor identify, caps: 0183f9ff c1c3f9ff 00000000 00000000 00000000
00000000 00000000
Enabling disabled K7/SSE Support.
CPU: L1 I Cache: 64K (64 bytes/line), D cache 64K (64 bytes/line)
CPU: L2 Cache: 64K (64 bytes/line)
CPU: After all inits, caps: 0383f9ff c1c3f9ff 00000000 00000020 00000000
00000000 00000000
Intel machine check architecture supported.
Intel machine check reporting enabled on CPU#0.
CPU: AMD Duron(tm) Processor  stepping 01
Enabling fast FPU save and restore... done.
Enabling unmasked SIMD FPU exception support... done.
Checking 'hlt' instruction... OK.
ACPI: Looking for DSDT in initrd... not found!
ACPI: setting ELCR to 0008 (from 0e00)
checking if image is initramfs...it isn't (no cpio magic); looks like an initrd
Freeing initrd memory: 288k freed
NET: Registered protocol family 16
PCI: PCI BIOS revision 2.10 entry at 0xfdb71, last bus=1
PCI: Using configuration type 1
mtrr: v2.0 (20020519)
ACPI: Subsystem revision 20050309
ACPI: Interpreter enabled
ACPI: Using PIC for interrupt routing
ACPI: PCI Root Bridge [PCI0] (0000:00)
PCI: Probing PCI hardware (bus 00)
Boot video device is 0000:01:05.0
ACPI: PCI Interrupt Routing Table [\_SB_.PCI0._PRT]
ACPI: Power Resource [URP1] (off)
ACPI: Power Resource [URP2] (off)
ACPI: Power Resource [FDDP] (off)
ACPI: Power Resource [LPTP] (off)
ACPI: PCI Interrupt Link [LNKA] (IRQs 3 4 5 6 7 9 10 11 12 14 15) *0, disabled.
ACPI: PCI Interrupt Link [LNKB] (IRQs 3 4 5 6 7 9 10 *11 12 14 15)
ACPI: PCI Interrupt Link [LNKC] (IRQs 3 4 5 6 7 9 *10 11 12 14 15)
ACPI: PCI Interrupt Link [LNKD] (IRQs 3 4 5 6 7 *9 10 11 12 14 15)
Linux Plug and Play Support v0.97 (c) Adam Belay
pnp: PnP ACPI init
pnp: PnP ACPI: found 10 devices
PnPBIOS: Disabled by ACPI PNP
PCI: Using ACPI for IRQ routing
PCI: If a device doesn't work, try "pci=routeirq".  If it helps, post a report
pnp: 00:00: ioport range 0xde00-0xde03 has been reserved
audit: initializing netlink socket (disabled)
audit(1128029898.492:0): initialized
Total HugeTLB memory allocated, 0
VFS: Disk quotas dquot_6.5.1
Dquot-cache hash table entries: 1024 (order 0, 4096 bytes)
Initializing Cryptographic API
vesafb: framebuffer at 0xe0000000, mapped to 0xe0880000, using 3750k, total 16384k
vesafb: mode is 800x600x16, linelength=1600, pages=16
vesafb: protected mode interface info at c000:7e6b
vesafb: scrolling: redraw
vesafb: Truecolor: size=0:5:6:5, shift=0:11:5:0
bootsplash 3.1.6-2004/03/31: looking for picture...<6> silentjpeg size 63545
bytes,<6>...found (800x600, 10934 bytes, v3).
Console: switching to colour frame buffer device 100x35
fb0: VESA VGA frame buffer device
isapnp: Scanning for PnP cards...
isapnp: No Plug & Play device found
PNP: PS/2 Controller [PNP0303:PS2K,PNP0f03:PS2M] at 0x60,0x64 irq 1,12
serio: i8042 AUX port at 0x60,0x64 irq 12
serio: i8042 KBD port at 0x60,0x64 irq 1
io scheduler noop registered
io scheduler anticipatory registered
io scheduler deadline registered
io scheduler cfq registered
RAMDISK driver initialized: 16 RAM disks of 12288K size 1024 blocksize
mice: PS/2 mouse device common for all mice
md: md driver 0.90.1 MAX_MD_DEVS=256, MD_SB_DISKS=27
NET: Registered protocol family 2
IP: routing cache hash table of 4096 buckets, 32Kbytes
TCP established hash table entries: 32768 (order: 6, 262144 bytes)
TCP bind hash table entries: 32768 (order: 5, 131072 bytes)
TCP: Hash tables configured (established 32768 bind 32768)
NET: Registered protocol family 1
ACPI wakeup devices:
PCI0  USB
ACPI: (supports S0 S1 S4 S5)
md: Autodetecting RAID arrays.
md: autorun ...
md: ... autorun DONE.
RAMDISK: Compressed image found at block 0
input: AT Translated Set 2 keyboard on isa0060/serio0
VFS: Mounted root (romfs filesystem) readonly.
Uniform Multi-Platform E-IDE driver Revision: 7.00alpha2
ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
AMD7409: IDE controller at PCI slot 0000:00:07.1
AMD7409: chipset revision 7
AMD7409: not 100% native mode: will probe irqs later
AMD7409: 0000:00:07.1 (rev 07) UDMA66 controller
    ide0: BM-DMA at 0xf000-0xf007, BIOS settings: hda:DMA, hdb:pio
    ide1: BM-DMA at 0xf008-0xf00f, BIOS settings: hdc:DMA, hdd:pio
Probing IDE interface ide0...
hda: FUJITSU MPG3204AH E, ATA DISK drive
ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
Probing IDE interface ide1...
hdc: TOSHIBA DVD-ROM SD-R1312, ATAPI CD/DVD-ROM drive
ide1 at 0x170-0x177,0x376 on irq 15
Probing IDE interface ide2...
Probing IDE interface ide3...
Probing IDE interface ide4...
Probing IDE interface ide5...
hda: max request size: 128KiB
hda: 40031712 sectors (20496 MB) w/2048KiB Cache, CHS=39714/16/63, UDMA(66)
hda: cache flushes not supported
 hda: hda1 hda2 hda4 < hda5 hda6 >
kjournald starting.  Commit interval 5 seconds
EXT3-fs: mounted filesystem with ordered data mode.
VFS: Mounted root (ext3 filesystem) readonly.
Trying to move old root to /initrd ... failed
Unmounting old root
Trying to free ramdisk memory ... okay
Freeing unused kernel memory: 184k freed
Executing init=/sbin/init
Real Time Clock Driver v1.12
Adding 2970568k swap on /dev/hda2.  Priority:-1 extents:1
EXT3 FS on hda1, internal journal
device-mapper: 4.4.0-ioctl (2005-01-12) initialised: dm-devel@redhat.com
kjournald starting.  Commit interval 5 seconds
EXT3 FS on hda6, internal journal
EXT3-fs: mounted filesystem with ordered data mode.
kjournald starting.  Commit interval 5 seconds
EXT3 FS on hda5, internal journal
EXT3-fs: mounted filesystem with ordered data mode.
subfs 0.9
ACPI: PCI Interrupt Link [LNKC] enabled at IRQ 10
PCI: setting IRQ 10 as level-triggered
ACPI: PCI Interrupt 0000:00:0a.0[A] -> Link [LNKC] -> GSI 10 (level, low) -> IRQ 10
PCI: Unable to reserve I/O region #2:8@de00 for device 0000:00:0a.0
au8820: probe of 0000:00:0a.0 failed with error -16
usbcore: registered new driver usbfs
usbcore: registered new driver hub
ohci_hcd: 2004 Nov 08 USB 1.1 'Open' Host Controller (OHCI) Driver (PCI)
ACPI: PCI Interrupt Link [LNKD] enabled at IRQ 9
PCI: setting IRQ 9 as level-triggered
ACPI: PCI Interrupt 0000:00:07.4[D] -> Link [LNKD] -> GSI 9 (level, low) -> IRQ 9
ohci_hcd 0000:00:07.4: Advanced Micro Devices [AMD] AMD-756 [Viper] USB
ohci_hcd 0000:00:07.4: new USB bus registered, assigned bus number 1
ohci_hcd 0000:00:07.4: irq 9, io mem 0xeffdf000
hub 1-0:1.0: USB hub found
hub 1-0:1.0: 4 ports detected
input.c: calling hotplug without a hotplug agent defined
input: PC Speaker
input.c: calling hotplug without a hotplug agent defined
input: GenPS/2 Genius Wheel Mouse on isa0060/serio1
Floppy drive(s): fd0 is 1.44M
FDC 0 is a post-1991 82077
Serial: 8250/16550 driver $Revision: 1.90 $ 48 ports, IRQ sharing enabled
ttyS0 at I/O 0x3f8 (irq = 4) is a 16550A
ttyS0 at I/O 0x3f8 (irq = 4) is a 16550A
parport: PnPBIOS parport detected.
parport0: PC-style at 0x378 (0x778), irq 7, dma 3
[PCSPP,TRISTATE,COMPAT,EPP,ECP,DMA]
Linux agpgart interface v0.101 (c) Dave Jones
agpgart: Detected AMD Irongate chipset
agpgart: AGP aperture is 64M @ 0xe4000000
pci_hotplug: PCI Hot Plug PCI Core version: 0.5
shpchp: HPC vendor_id 1022 device_id 7007 ss_vid 0 ss_did 0
shpchp: shpc_init: cannot reserve MMIO region
shpchp: Standard Hot Plug PCI Controller Driver version: 0.4
hdc: ATAPI 40X DVD-ROM CD-R/RW drive, 2048kB Cache, UDMA(33)
Uniform CD-ROM driver Revision: 3.20
ACPI: Power Button (FF) [PWRF]
ACPI: Sleep Button (FF) [SLPF]
ACPI: Thermal Zone [THRM] (30 C)
powernow-k8: Processor cpuid 671 not supported
mtrr: 0xe0000000,0x2000000 overlaps existing 0xe0000000,0x1000000
[drm] Initialized drm 1.0.0 20040925
PCI: Unable to reserve mem region #2:2000000@e0000000 for device 0000:01:05.0
[drm] Initialized tdfx 1.0.0 20010216 on minor 0: 3Dfx Interactive, Inc. Voodoo 3
[drm] Used old pci detect: framebuffer loaded
mtrr: 0xe0000000,0x2000000 overlaps existing 0xe0000000,0x1000000
lp0: using parport0 (interrupt-driven).
lp0: console ready
bootsplash 3.1.6-2004/03/31: looking for picture...<6> silentjpeg size 63545
bytes,<6>...found (800x600, 10934 bytes, v3).
bootsplash: status on console 1 changed to on
bootsplash 3.1.6-2004/03/31: looking for picture...<6> silentjpeg size 63545
bytes,<6>...found (800x600, 10934 bytes, v3).
bootsplash: status on console 2 changed to on
bootsplash 3.1.6-2004/03/31: looking for picture...<6> silentjpeg size 63545
bytes,<6>...found (800x600, 10934 bytes, v3).
bootsplash: status on console 3 changed to on
bootsplash 3.1.6-2004/03/31: looking for picture...<6> silentjpeg size 63545
bytes,<6>...found (800x600, 10934 bytes, v3).
bootsplash: status on console 4 changed to on
bootsplash 3.1.6-2004/03/31: looking for picture...<6> silentjpeg size 63545
bytes,<6>...found (800x600, 10934 bytes, v3).
bootsplash: status on console 5 changed to on
bootsplash 3.1.6-2004/03/31: looking for picture...<6> silentjpeg size 63545
bytes,<6>...found (800x600, 10934 bytes, v3).
bootsplash: status on console 11 changed to on
[root@localhost root]# cat /proc/asound/cards
--- no soundcards ---
[root@localhost root]# amixer contents
amixer: Control default open error: No such file or directory
------- Comment #9 From 2005-09-30 13:18:29 -------
(In reply to comment #8)
> PCI: Unable to reserve I/O region #2:8@de00 for device 0000:00:0a.0
> au8820: probe of 0000:00:0a.0 failed with error -16

Что-то не так с назначением портов ввода-вывода для PCI-устройств.  Надо
смотреть вывод команд lspci -vvx, cat /proc/ioports, cat /proc/iomem (лучше
присоедините их как файл - ссылка "Create a New Attachment", чтобы не создавать
километровую страницу).

Ситуация может измениться при смене настроек BIOS (типа "PnP OS Installed"), а
также при загрузке системы с параметрами pci=noacpi или acpi=off.


> powernow-k8: Processor cpuid 671 not supported

И неудивительно - процессор-то семейства K7, а не K8, поэтому попытка загрузки
powernow-k8, вероятно, связана с ошибкой в cpuscan (впрочем, это нужно повесить
отдельным багом на libhw-tools).
------- Comment #10 From 2005-10-11 18:06:29 -------
Что с этой проблемой? Если один из предложенных вариантов обхода помог -
напишите об этом.
------- Comment #11 From 2005-12-02 23:59:29 -------
Судя по отсутствию реакции, проблема либо как-то решилась, либо просто никого
не
интересует.