Bug 7962 - Добавить поддержку 7zip
: Добавить поддержку 7zip
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/mc)
: unstable
: all Linux
: P2 enhancement
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2005-09-14 16:57 by
Modified: 2005-09-19 22:49 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2005-09-14 16:57:05
В mc не хватает поддержки архивов 7zip, вот инструкция по добавлению (файл u7z 
может быть найден в исходниках). 

For use u7z you must add following line to extfs.ini 

=-=-=-=-=-= Cut -=-=-=-=-=- 
u7z 
=-=-=-=-=-= Cut -=-=-=-=-=- 

And add somthing like this to extension file 

=-=-=-=-=-= Cut -=-=-=-=-=- 
regex/\.(7z|7Z)$ 
    View=%view{ascii} 7za l %f 2>/dev/null 
    Open=%cd %p#u7z 
=-=-=-=-=-= Cut -=-=-=-=-=- 

This must be added before Manual pages Lines to prevent handle 7z archive 
like man page
------- Comment #1 From 2005-09-15 14:05:39 -------
А там (в /usr/share/mc/extfs) никакого u7z не наблюдается.
Нагуглилось здесь:
http://www.qilinux.it/index.php?op=modload&name=distromatic&file=index&tag=stable/1.2&pkg=p7zip
------- Comment #2 From 2005-09-15 14:12:25 -------
у нас это в пакете p7zip есть... ща вот опакетил новый mc...
ждём mc-4.6.1r-alt3
------- Comment #3 From 2005-09-15 15:32:34 -------
fixed in mc-4.6.1r-alt3
------- Comment #4 From 2005-09-18 11:45:06 -------
Забыли 
    Open=%cd %p#u7z   
 
------- Comment #5 From 2005-09-18 12:24:45 -------
Не туда посмотрел, всё нормально. 
------- Comment #6 From 2005-09-19 22:49:36 -------
*** Bug 8013 has been marked as a duplicate of this bug. ***