Bug 9666 - grep-2.5.1a-alt1 has invalid BuildRequires
: grep-2.5.1a-alt1 has invalid BuildRequires
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/grep)
: unstable
: all Linux
: P2 minor
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2006-06-04 14:56 by
Modified: 2009-05-10 09:33 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2006-06-04 14:56:38
По недомыслию собрал grep-2.5.1a-alt (был 2.5.1-alt0.4cvs) на Мастере 2.4.
Собрал с libpcre3-4.5 (у которой ещё /usr/lib/libpcre.so.3 вместо
/lib/libpcre.so.3). Соответственно, при следующей загрузке машины получил
ругань
от fgrep-а (он не мог найти libpcre.so.3). Видимо необходимо в спеке сделать
s/BuildRequires: libpcre-devel/BuildRequires: libpcre-devel >= 6.4-alt2/;
------- Comment #1 From 2006-06-04 16:53:21 -------
*** Bug 9667 has been marked as a duplicate of this bug. ***
------- Comment #2 From 2006-06-04 16:54:36 -------
BuildRequires тут не при чём.
------- Comment #3 From 2006-06-04 20:02:37 -------
(In reply to comment #2)
> BuildRequires тут не при чём.

А в чём же дело (Requires)? У меня и собрать и установить со старой версией
получилось. Но этого же вроде не должно было быть. Мне просто интересно (как
потенциальному майнтаинеру) как это надо правильно исправить.

P.S.: дважды жамкнул мышой - два бага и получилось. Сорри.
------- Comment #4 From 2006-08-31 13:51:15 -------
Просто не надо собирать grep с библиотекой, которая живёт не в /lib а в
/usr/lib.
grep работать будет, но только с того момента как будет смонтирован /usr.
------- Comment #5 From 2006-08-31 18:46:20 -------
(In reply to comment #4)
> Просто не надо собирать grep с библиотекой, которая живёт не в /lib а в /usr/lib.
> grep работать будет, но только с того момента как будет смонтирован /usr.

Я и забыл про этот баг. Переполз с того времени на Компакт 3. Гляжу:

~$ R -q grep
grep-2.5.1a-alt1
~$ ldd /bin/*grep*  G /usr/                                                    
                                        
        libpcre.so.3 => /usr/lib/libpcre.so.3 (0xb7f12000)
        libpcre.so.3 => /usr/lib/libpcre.so.3 (0xb7f70000)
        libpcre.so.3 => /usr/lib/libpcre.so.3 (0xb7ee4000)
        libpcre.so.3 => /usr/lib/libpcre.so.3 (0xb7f9b000)

Умом то я понимаю, что grep не должен зависеть от доступности /usr, просто
буквоедствую, столкнувшись с проблемкой (и не имея особенного желания обновлять
пакеты "по цепочке" без особой надобности). Хочу, так сказать, чтобы небо в
принципе не могло упасть на голову.

Но почему в Компакте точно также как и в Мастере? Это ж вроде неправильно?
------- Comment #6 From 2006-09-02 19:20:27 -------
В сборке 2.5.1a-alt2 я на всякий случай добавил зависимость на libpcre3 >=
0:6.4-alt2