Bug 9683 - switchto profile doesn't shutdown DISABLED iface
: switchto profile doesn't shutdown DISABLED iface
Status: CLOSED DUPLICATE of bug 11556
: Sisyphus
(All bugs in Sisyphus/etcnet)
: unstable
: all Linux
: P2 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2006-06-08 13:50 by
Modified: 2008-12-31 19:38 (History)


Attachments
switchto work command output (4.31 KB, text/plain)
2006-06-08 13:54, Marat Khayrullin
no flags Details
ip a l (after switchto) (962 bytes, text/plain)
2006-06-08 13:55, Marat Khayrullin
no flags Details


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2006-06-08 13:50:50
имеется 2 профайла:
1) home с ethernet: ext, int
2) work с ethernet: ext(DISABLED=yes), int

если стартовать с профайлом home и выполнить switchto work, то ext не перейдет в
down.
------- Comment #1 From 2006-06-08 13:54:17 -------
Created an attachment (id=1514) [details]
switchto work command output
------- Comment #2 From 2006-06-08 13:55:08 -------
Created an attachment (id=1515) [details]
ip a l (after switchto)
------- Comment #3 From 2006-06-08 13:56:17 -------
etcnet-0.8.3-alt0.2
------- Comment #4 From 2006-06-08 22:11:32 -------
> Stopping ext:  skipping hotplug iface 'ext' SKIPPED
Вот и причина.

>Loading rules for chain OUTPUT in table filter
>.
>....install: omitting directory `/etc/openldap/ssl/demo'
>.OK
А это что?
------- Comment #5 From 2006-06-12 00:50:53 -------
(In reply to comment #4)
> > Stopping ext:  skipping hotplug iface 'ext' SKIPPED
> Вот и причина.
Так и я о том же :)
А надо бы заглушить ext...

> >Loading rules for chain OUTPUT in table filter
> >.
> >....install: omitting directory `/etc/openldap/ssl/demo'
> >.OK
> А это что?
А кто его знает ? :)
------- Comment #6 From 2006-06-12 10:25:44 -------
Ситауция неоднозначная, нужно подумать.
------- Comment #7 From 2007-04-18 21:20:25 -------

*** This bug has been marked as a duplicate of 11556 ***
------- Comment #8 From 2008-12-31 19:38:18 -------
Похожим образом не всегда опускается интерфейс и при "service network stop",
хотя это и ожидается здравым смыслом:
https://bugzilla.altlinux.org/show_bug.cgi?id=18413 .