Bug 9732 - needs dependency on glibc-core with TLS support
: needs dependency on glibc-core with TLS support
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/libstdc++4.1)
: unstable
: all Linux
: P2 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2006-06-26 14:48 by
Modified: 2006-08-29 21:55 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2006-06-26 14:48:53
Установка libstdc++4.1-4.1.1-alt3 в систему с glibc-core-2.3.6-alt2 не
запрещается зависимостями пакетов, однако приводит к неработоспособности всех
программ, использующих libstdc++.so.6 (в том числе apt): при попытке запуска
возникает ошибка "libstdc++.so.6: cannot handle TLS data".  Вероятно, нужно
добавить в пакет зависимость на достаточно свежую сборку glibc-core,
поддерживающую TLS (причём, возможно, даже PreReq, чтобы не было проблем при
запуске скриптов других пакетов в процессе dist-upgrade, когда в одной
транзакции обновляется glibc-core и libstdc++4.1).
------- Comment #1 From 2006-06-29 22:26:07 -------
Fixed in -4.1.1-alt4
------- Comment #2 From 2006-07-03 19:13:02 -------
*** Bug 9756 has been marked as a duplicate of this bug. ***