Bug 13909 - initscript использует locale, хотя не зависит от пакета, его содержащего
: initscript использует locale, хотя не зависит от пакета, его содержащего
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/MySQL-server)
: unstable
: all Linux
: P2 minor
Assigned To:
:
:
:
: 12390
:
  Show dependency tree
 
Reported: 2008-01-06 20:23 by
Modified: 2008-03-22 00:57 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2008-01-06 20:23:13
Adjusting environment for mysqld:                                              
                                                                [ DONE ]
/etc/init.d/mysqld: line 41: locale: command not found
Unable to find proper charset from system locale, setting 'latin1'.
Please edit mysqld init script and set proper charset.
Starting mysqld service:                                                       
                                                                [ DONE ]

Впрочем, установка glibc-locales всё равно приводит к тому, что всё работает в
latin1:

Adjusting environment for mysqld:                                              
                                                                [ DONE ]
Unable to find proper charset from system locale, setting 'latin1'.
Please edit mysqld init script and set proper charset.
Starting mysqld service:                                                       
                                                                [ DONE ]
------- Comment #1 From 2008-01-07 14:06:06 -------
Во втором случае дело, конечно, было в /etc/sysconfig/mysqld. Но зависимость на
locale всё же лучше приделать.
------- Comment #2 From 2008-03-16 15:00:45 -------
Fixed in MySQL-5.0.51-alt2.a
------- Comment #3 From 2008-03-16 15:01:14 -------
*** Bug 14731 has been marked as a duplicate of this bug. ***