Bug 15496 - crashes on this site (because of xorg-x11-drv-intel)
: crashes on this site (because of xorg-x11-drv-intel)
Status: CLOSED WORKSFORME
: Sisyphus
(All bugs in Sisyphus/epiphany)
: unstable
: all Linux
: P2 critical
Assigned To:
:
: http://aeroflot.ru
:
:
:
  Show dependency tree
 
Reported: 2008-04-29 20:20 by
Modified: 2008-05-01 16:44 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2008-04-29 20:20:07
$ rpm -qa 'epiphany*'
epiphany-2.22.1.1-alt1
epiphany-extensions-2.22.1-alt1
epiphany-extension-gwget-0.99-alt1
$ 

Steps to Reproduce:
1. Open http://aeroflot.ru
2. Select on the page: "Выберите Страну" > "Россия"
3.
Actual Results:  
it crashes immediately:

$ epiphany
<...>
The program 'epiphany' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadAlloc (insufficient resources for operation)'.
  (Details: serial 16917 error_code 11 request_code 53 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)
$ 

Expected Results:  
it works
------- Comment #1 From 2008-04-29 20:26:12 -------
The same for firefox: https://bugzilla.altlinux.org/show_bug.cgi?id=15497 .
The same for seamonkey: https://bugzilla.altlinux.org/show_bug.cgi?id=15498 .
------- Comment #2 From 2008-04-29 20:29:00 -------
$ rpm -qa 'mozilla*'
mozilla-addon-bannerblind-1.0rc1-alt1
mozilla-plugin-svg-2.16.1-alt2
mozilla-plugin-djvu-3.5.17-alt2
mozilla-plugin-j2se1.6-sun-1.6.0.01-alt2
mozilla-plugin-vlc-0.8.6d-alt5
mozilla-addon-adblock-0.5-alt1
mozilla-plugin-adobe-flash-9.0.124.0-alt2
mozilla-plugin-mozplugger-1.7.3-alt1.2
mozilla-addon-linky-2.7.1-alt1
$ 
------- Comment #3 From 2008-04-29 20:37:01 -------
Works here for firefox and seamonkey.

mozilla-plugin-djvu-3.5.17-alt2
mozilla-addon-livehttpheaders-0.12-alt1
mozilla-plugin-j2se1.6-sun-1.6.0.05-alt1
mozilla-plugin-adobe-flash-9.0.124.0-alt2
mozilla-addon-adblock-0.5-alt1

firefox-quicknote-0.6.0.3-alt8
firefox-exif-1.13-alt2
firefox-webdeveloper-1.1.5-alt1
firefox-switchproxy-1.4.1-alt1.1
firefox-user-agent-switcher-0.6.11-alt1
firefox-scrapbook-1.3.3.2-alt1
firefox-copyallurls-0.7.1-alt8
firefox-copy_link_name-1.2.4-alt7
firefox-ru-2.0.0.4-alt1
firefox-2.0.0.13-alt1
firefox-gmail_manager-0.5.4-alt2
firefox-adblock_plus-0.7.5.3-alt1
firefox-gm-notifier-0.6.3.2-alt1
firefox-outliner-0.7-alt7
firefox-calculator-1.1.10-alt1
firefox-fireftp-0.97.1-alt1
firefox-flashblock-1.5.5-alt1
firefox-print_preview-0.6.1.1-alt1
firefox-imglikeopera-0.6.15-alt1
firefox-simple_calc-0.8-alt15
firefox-spoofstick-1.06-alt4
firefox-tab_url_copier-1.1.8-alt8
firefox-fireget-0.6-alt4
firefox-switch-locales-2.0-alt3
firefox-livehttpheaders-0.13.1-alt2

seamonkey-dom-inspector-1.1.9-alt2
seamonkey-irc-1.1.9-alt2
seamonkey-devel-1.1.9-alt2
seamonkey-ru-1.1-alt1
seamonkey-webdeveloper-1.1.4-alt1
seamonkey-1.1.9-alt2
seamonkey-multizilla-1.8.3.0-alt2
seamonkey-psm-1.1.9-alt2
seamonkey-plugins-common-1.1.9-alt2
------- Comment #4 From 2008-04-29 23:24:51 -------
epiphany у меня работает. Завтра попробую ещё на нескольких машинках.

У автора отчёта хотелось бы попросить прислать версии xorg-*, которые у него
установлены.
------- Comment #5 From 2008-04-30 03:15:17 -------
Т.е. ни у кого не воспроизводится? Хм...

$ rpm -qa 'xorg-*'
xorg-x11-drv-hyperpen-1.1.0-alt1
xorg-x11-drv-neomagic-1.0.0.5-alt1
xorg-x11-drv-v4l-0.1.1-alt2
xorg-x11-drv-ark-0.5.0.5-alt1
xorg-x11-drv-rendition-4.0.1.3-alt1
xorg-x11-drv-elographics-1.0.0.5-alt1
xorg-x11-drv-fpit-1.0.0.5-alt1
xorg-x11-drv-mutouch-1.1.0-alt1
xorg-cf-files-1.0.2-alt1
xorg-x11-drv-vga-4.1.0-alt4
xorg-x11-drv-ur98-1.0.0.5-alt1
xorg-x11-drv-multimedia-1.4.0.90-alt17
xorg-x11-utils-7.3.0-alt1
xorg-x11-drv-jamstudio-1.1.0-alt1
xorg-docs-1.4-alt2
xorg-x11-xfs-1.0.6-alt1
xorg-x11-drv-keyboard-1.2.2-alt3
xorg-x11-xephyr-1.4.0.90-alt17
xorg-x11-drv-nsc-2.7.6.5-alt1
xorg-x11-drv-voodoo-1.1.1-alt1
xorg-x11-drv-spaceorb-1.0.0.5-alt1
xorg-x11-font-utils-1.0.1-alt5
xorg-x11-drv-evdev-1.2.0-alt3
xorg-x11-drv-intel-2.2.1-alt4
xorg-x11-drv-digitaledge-1.0.1.3-alt1
xorg-x11-drv-palmax-1.0.0.5-alt1
xorg-x11-drv-vesa-1.3.0-alt3
xorg-x11-drv-newport-0.1.4.1-alt1
xorg-x11-drv-apm-1.1.1-alt2
xorg-x11-font-encodings-1.0.2-alt1
xorg-x11-rgb-1.0.1-alt1
xorg-x11-apps-7.3.0-alt1
xorg-x11-xnest-1.4.0.90-alt17
xorg-x11-drv-microtouch-1.0.0.5-alt1
xorg-x11-drv-elo2300-1.0.0.5-alt1
xorg-x11-drv-joystick-1.2.0-alt1
xorg-x11-extensions-glx-1.4.0.90-alt17
xorg-server-control-1.3-alt1
xorg-x11-drv-calcomp-1.0.0.5-alt1
xorg-x11-drv-chips-1.0.1.3-alt1
xorg-x11-drv-imstt-1.0.0.5-alt1
xorg-x11-mesagl-7.3.0-alt1
xorg-x11-proto-devel-7.3.0-alt10
xorg-x11-drv-summa-1.0.0.5-alt1
xorg-x11-drv-vmware-10.15.0-alt1
xorg-x11-server-common-1.4.0.90-alt17
xorg-x11-drv-magellan-1.0.0.5-alt1
xorg-x11-drv-glint-1.1.1-alt2
xorg-x11-drv-dynapro-1.0.0.5-alt1
xorg-x11-dri-intel-7.0.3-alt3
xorg-x11-drv-dmc-1.0.0.5-alt1
xorg-x11-libs-7.3.0-alt1
xorg-x11-drv-void-1.1.0-alt1
xorg-x11-drv-siliconmotion-1.3.1.5-alt1
xorg-x11-drv-tseng-1.0.0.5-alt1
xorg-x11-drv-tek4957-1.0.0.5-alt1
xorg-x11-drv-penmount-1.1.0-alt1
xorg-x11-xvfb-1.4.0.90-alt17
xorg-x11-bitmaps-1.0.1-alt2.1
xorg-x11-drv-mouse-1.2.3-alt2
xorg-x11-drv-fbdev-0.3.0-alt1
xorg-x11-server-1.4.0.90-alt17
$ 
------- Comment #6 From 2008-04-30 03:19:35 -------
0000:00:00.0 Host bridge: Intel Corporation Mobile 915GM/PM/GMS/910GML Express
Processor to DRAM Controller (rev 03)
        Subsystem: Dell Dell Latidude C610
        Flags: bus master, fast devsel, latency 0
        Capabilities: [e0] #09 [2109]

0000:00:02.0 VGA compatible controller: Intel Corporation Mobile
915GM/GMS/910GML Express Graphics Controller (rev 03) (prog-if 00 [VGA])
        Subsystem: Dell: Unknown device 0182
        Flags: bus master, fast devsel, latency 0, IRQ 16
        Memory at dff00000 (32-bit, non-prefetchable)
        I/O ports at ec38 [size=8]
        Memory at c0000000 (32-bit, prefetchable) [size=256M]
        Memory at dfec0000 (32-bit, non-prefetchable) [size=256K]
        Capabilities: [d0] Power Management version 2

0000:00:02.1 Display controller: Intel Corporation Mobile 915GM/GMS/910GML
Express Graphics Controller (rev 03)
        Subsystem: Dell: Unknown device 0182
        Flags: bus master, fast devsel, latency 0
        Memory at dff80000 (32-bit, non-prefetchable)
        Capabilities: [d0] Power Management version 2

0000:00:1c.0 PCI bridge: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family)
PCI Express Port 1 (rev 03) (prog-if 00 [Normal decode])
        Flags: bus master, fast devsel, latency 0
        Bus: primary=00, secondary=02, subordinate=02, sec-latency=0
        Memory behind bridge: dfd00000-dfdfffff
        Capabilities: [40] #10 [0141]
        Capabilities: [80] Message Signalled Interrupts: 64bit- Queue=0/0 Enable-
        Capabilities: [90] #0d [0000]
        Capabilities: [a0] Power Management version 2

------- Comment #7 From 2008-04-30 03:22:34 -------
# rpm -qa '*gdk*'
gst-plugins-gdkpixbuf-0.10.6-alt1
gdk-pixbuf-0.22.0-alt9.2
gdk-pixbuf-loaders-0.22.0-alt9.2
gdk-pixbuf-xlib-0.22.0-alt9.2
]# rpm -qa 'libgtk*'
libgtk-engine-redmond-2.12.2-alt2
libgtkhtml3-3.8-3.12.3-alt3
libgtk-sharp2-gapi-2.10.2-alt2
libgtk-engine-rezlooks-0.6-alt1
libgtk+2-devel-2.12.8-alt2
libgtk-engine-candido-0.9.1-alt1
libgtkmm2-2.8.3-alt0.1
libgtk-sharp-1.0.10-alt3
libgtk-engine-anachron-0.1-alt1
libgtk-engine-ubuntulooks-0.9.11-alt1
libgtk-engine-galaxy-1.0.4-alt2
libgtk-engine-smooth-2.12.2-alt2
libgtk-engine-svg-2.16.1-alt2
libgtk+2-common-devel-2.12.8-alt2
libgtkspell-2.0.4-alt6
libgtk-engines-default-2.12.2-alt2
libgtkglext-1.0.6-alt1.1.1
libgtk-engine-glide-2.12.2-alt2
libgtk-engines-default-common-2.12.2-alt2
libgtk+extra2-2.1.1-alt0.1
libgtk-sharp2-2.10.2-alt2
libgtk-engine-murrine-0.31-alt1
libgtk+2-2.12.8-alt2
libgtkhtml3-3.18.0-alt1.1
libgtk+mdk-0.1.6-alt5
libgtk-engine-dyndyn-0.1-alt1
libgtk-engine-hc-2.12.2-alt2
libgtkimageview-1.6.1-alt1
libgtk+2-common-2.12.8-alt2
libgtkhtml2-2.11.0-alt3
libgtksourceview2-2.0.2-alt3.1
libgtkmathview-0.8.0-alt1
libgtk-sharp2-devel-2.10.2-alt2
libgtk-engine-lua-2.10.2-alt1
libgtk-engines-xfce4-2.4.0-alt0.2
# 
------- Comment #8 From 2008-04-30 03:35:27 -------
After upgrading xorg-x11-drv-intel 3:2.2.1-alt4 to 3:2.3.0-alt1 it doesn't crash
anymore. Thanks for comments!
------- Comment #9 From 2008-04-30 03:36:05 -------
*** Bug 15497 has been marked as a duplicate of this bug. ***
------- Comment #10 From 2008-04-30 03:36:14 -------
*** Bug 15498 has been marked as a duplicate of this bug. ***