Bug 21340 - Не запускается графическая среда на VIA [S3 UniChrome]
: Не запускается графическая среда на VIA [S3 UniChrome]
Status: CLOSED DUPLICATE of bug 20574
: Школьный
(All bugs in Школьный/livecd)
: 5.0
: all Linux
: P5 normal
Assigned To:
:
:
:
: 21352
: 19564
  Show dependency tree
 
Reported: 2009-09-01 16:05 by
Modified: 2011-07-18 14:29 (History)


Attachments
лог выпадания в командную строку при загрузке с лайвСД с видео nVidia (10.12 KB, application/octet-stream)
2009-09-01 19:19, Anton Muryskin
no flags Details
вывод glxinfo для nvidia (23.20 KB, application/octet-stream)
2009-09-02 19:33, Anton Muryskin
no flags Details


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2009-09-01 16:05:25
при запуске с liveCD Мастер загрузка заканчивается командной строкой с вопросом
login/password. после входа и команды startx:
1. на видеокарточке nVidia GeForce 9300M GS запускает KDE, но на последнем шаге
вываливается в консоль. при повторном startx KDE успешно запускается.
2. на видеокарточке VIA Technologies, Inc. VT8378 [S3 UniChrome]              
Integrated Video - черный экран без каких-либо изменений.
------- Comment #1 From 2009-09-01 16:41:12 -------
*** Bug 21341 has been marked as a duplicate of this bug. ***
------- Comment #2 From 2009-09-01 17:23:40 -------
На GeForce 9300M GS после этого работает 3D ?

На установленной системе пробовали?
------- Comment #3 From 2009-09-01 17:38:41 -------
сорри, за повтор ошибок, просто раз одно про установку, а другое про лайвСД, то
подумал что разное.

(В ответ на комментарий №2)
> На GeForce 9300M GS после этого работает 3D ?

честно говоря не пробовал. щас проверю.
а систему ставить на этот бук как-то не хочется, ибо там и так все нормально и
прочее.
больше всего волнует конечно эта карточка: VIA Technologies, Inc. VT8378 [S3
UniChrome] Integrated Video
------- Comment #4 From 2009-09-01 18:30:47 -------
(В ответ на комментарий №3)
> сорри, за повтор ошибок, просто раз одно про установку, а другое про лайвСД, то
> подумал что разное.
> 
> (В ответ на комментарий №2)
> > На GeForce 9300M GS после этого работает 3D ?
> 
> честно говоря не пробовал. щас проверю.
> а систему ставить на этот бук как-то не хочется, ибо там и так все нормально и
> прочее.
> больше всего волнует конечно эта карточка: VIA Technologies, Inc. VT8378 [S3
> UniChrome] Integrated Video

А какой драйвер X подхватился?
------- Comment #5 From 2009-09-01 19:19:17 -------
Created an attachment (id=3815) [details]
лог выпадания в командную строку при загрузке с лайвСД с видео nVidia
------- Comment #6 From 2009-09-01 19:20:40 -------
(В ответ на комментарий №2)
> На GeForce 9300M GS после этого работает 3D ?
не нашел где лайвСД 3Д проверить. (искал компиз, ибо других способов и не знаю)

(В ответ на комментарий №0)
> при запуске с liveCD Мастер загрузка заканчивается командной строкой с вопросом
> login/password.
при запуске видна строка загрузки, дошедшая до конца. клик мыши вываливает к
логину/паролю.

> после входа и команды startx:
> на видеокарточке nVidia GeForce 9300M GS запускает KDE, но на последнем шаге
> вываливается в консоль.
пишет:
Fatal server error:
Caught signal 11. Server aborting
xinit: connection to X server lost.
xauth: (argv):1: bad display name "localhost.localdomain:0" in "remove" command

логи ошибки выложил.

(В ответ на комментарий №4)
> А какой драйвер X подхватился?
на ноуте с nvidia: nVidia driver version 185.18.36
на карточке VIA пока нет возможности посмотреть, какой драйвер берется.
------- Comment #7 From 2009-09-02 00:34:48 -------
Похоже, зависит от 21352, -- неверно указан дрйвер via, теперь он называется
openchrome. Проверьте, пожалуйста.
------- Comment #8 From 2009-09-02 15:37:50 -------
(В ответ на комментарий №7)
> Похоже, зависит от 21352, -- неверно указан дрйвер via, теперь он называется
> openchrome. Проверьте, пожалуйста.
из консоли не удалось запустить nano (типо его нет), чтобы посмотреть
xorg.conf, а других консольных редакторов не знаю.
а при повторной установке, на каком-то из последних шагов автоматически
предлагают драйвер видео:
openchrome - VIA UniChrome - рекомендовано
при нажатии на кнопку "проверить" - черный экран, как и раньше.
------- Comment #9 From 2009-09-02 16:04:19 -------
(В ответ на комментарий №8)
> из консоли не удалось запустить nano (типо его нет), чтобы посмотреть
> xorg.conf, а других консольных редакторов не знаю.
grep Driver /etc/X11/xorg.conf

Изучайте традиционные команды UNIX:
less
vi
cat
------- Comment #10 From 2009-09-02 16:18:32 -------
(В ответ на комментарий №9)
> cat
тогда уж more
------- Comment #11 From 2009-09-02 16:27:22 -------
Интересно следующее:

какие драйвера предлагает video_scan:
# video_scan

стоит ли пакет xorg-drv-openchrome:
# rpm -q xorg-drv-openchrome

что прописалось в xorg.conf:
# grep Driver /etc/X11/xorg.conf

каков modalias карты:
# cat "/sys/bus/pci/devices/0000:$(lspci | grep VGA | cut -d' ' -f1)/modalias"
------- Comment #12 From 2009-09-02 18:02:50 -------
(В ответ на комментарий №6)
> не нашел где лайвСД 3Д проверить.
покажите вывод glxinfo
------- Comment #13 From 2009-09-02 18:05:01 -------
(В ответ на комментарий №0)
> 1. на видеокарточке nVidia GeForce 9300M GS запускает KDE,
> но на последнем шаге вываливается в консоль. при повторном startx KDE успешно прикрепите сюда файл ~/.xsession-errors:0 , скопировав его до следующей попытки входа в систему
------- Comment #14 From 2009-09-02 18:11:45 -------
(В ответ на комментарий №13)
Некрасиво написал.

прикрепите сюда файл ~/.xsession-errors:0 , скопировав его до следующей попытки
входа в систему
------- Comment #15 From 2009-09-02 19:27:56 -------
(В ответ на комментарий №14)
> (В ответ на комментарий №13)
> прикрепите сюда файл ~/.xsession-errors:0 , скопировав его до следующей попытки
> входа в систему
до команды startx пишет что нет такого файла или каталога.
а вот после startx в этот раз KDE запустилось сразу! О_О мистика
------- Comment #16 From 2009-09-02 19:33:40 -------
Created an attachment (id=3825) [details]
вывод glxinfo для nvidia
------- Comment #17 From 2009-09-02 20:08:25 -------
(В ответ на комментарий №15)
> > прикрепите сюда файл ~/.xsession-errors:0 , скопировав его до следующей попытки
> > входа в систему
> до команды startx пишет что нет такого файла или каталога.
Я имел ввиду, его брать между неудачным запуском KDE и следующим.
Если не всегда воспроизводиться, может быть проблема с файловой системой.
------- Comment #18 From 2009-09-02 20:09:53 -------
(В ответ на комментарий №16)
> вывод glxinfo для nvidia
Здесь номально. В ~/.xsession-errors:0 скорее всего написано, почему
отваливается
------- Comment #19 From 2009-09-02 20:30:33 -------
(В ответ на комментарий №17)
> Я имел ввиду, его брать между неудачным запуском KDE и следующим.
это я понял, но решил на всякий случай написать))
> Если не всегда воспроизводиться, может быть проблема с файловой системой.
с фс, на винте ноутбука? а какая там может быть проблема? я просто не в курсе,
но разве с лайвСД он обращается к винчестеру?
и кстати, на лайве разделы жесткого диска и флешки не монтируются. такого бага
не нашел, поэтому запостил:
https://bugzilla.altlinux.org/show_bug.cgi?id=21367
------- Comment #20 From 2009-09-02 20:33:23 -------
(В ответ на комментарий №19)
> (В ответ на комментарий №17)

Пожалуйста, ответьте на комментарий #11
------- Comment #21 From 2009-09-02 20:34:17 -------
(В ответ на комментарий №19)
> (В ответ на комментарий №17)
> > Я имел ввиду, его брать между неудачным запуском KDE и следующим.
> это я понял, но решил на всякий случай написать))
> > Если не всегда воспроизводиться, может быть проблема с файловой системой.
> с фс, на винте ноутбука? а какая там может быть проблема? я просто не в курсе,
> но разве с лайвСД он обращается к винчестеру?
> и кстати, на лайве разделы жесткого диска и флешки не монтируются. такого бага
> не нашел, поэтому запостил:
> https://bugzilla.altlinux.org/show_bug.cgi?id=21367

Проверьте MD5SUM на LiveCD, пожалуйста.
------- Comment #22 From 2009-09-02 20:37:51 -------
(В ответ на комментарий №20)
> Пожалуйста, ответьте на комментарий #11
завтра утром обязательно отвечу. тот компьютер в школе.

(В ответ на комментарий №21)
> Проверьте MD5SUM на LiveCD, пожалуйста.
при скачивании образов проверял - все совпадало. разве что от частого
использования диск испортился.
------- Comment #23 From 2009-09-03 14:31:00 -------
(В ответ на комментарий №19)
> с фс, на винте ноутбука?
Нет, на LiveCD. При большой нагрузке (а KDE хорошо это делает при запуске),
могут вылезать проблемы.
Я это для silicium написал.
------- Comment #24 From 2009-09-04 13:39:46 -------
(В ответ на комментарий №11)
> какие драйвера предлагает video_scan:
> # video_scan
name: KM400/KN400/P4M800 [S3 UniChrome]
drivers: openchrome vesa

> стоит ли пакет xorg-drv-openchrome:
> # rpm -q xorg-drv-openchrome
xorg-drv-openchrome-0.2.903-alt16

> что прописалось в xorg.conf:
> # grep Driver /etc/X11/xorg.conf
Driver "openchrome"

> каков modalias карты:
> # cat "/sys/bus/pci/devices/0000:$(lspci | grep VGA | cut -d' ' -f1)/modalias"
pci:v00001106d00007205sv00001106sd00007205bc03sc00i00
------- Comment #25 From 2009-09-04 14:02:18 -------
(В ответ на комментарий №24)
> (В ответ на комментарий №11)
> > какие драйвера предлагает video_scan:
> > # video_scan
> name: KM400/KN400/P4M800 [S3 UniChrome]
> drivers: openchrome vesa
> 
> > стоит ли пакет xorg-drv-openchrome:
> > # rpm -q xorg-drv-openchrome
> xorg-drv-openchrome-0.2.903-alt16
> 
> > что прописалось в xorg.conf:
> > # grep Driver /etc/X11/xorg.conf
> Driver "openchrome"

А каким образом в приведенный Вами на форуме xorg.conf попала строчка 
Driver "via"?
------- Comment #26 From 2009-09-04 15:02:58 -------
(В ответ на комментарий №25)
> А каким образом в приведенный Вами на форуме xorg.conf попала строчка 
> Driver "via"?
тот xorg.conf из установленного на аналогичной машине Мастера из ПСПО.
------- Comment #27 From 2009-09-07 17:02:03 -------
(В ответ на комментарий №25)
> А каким образом в приведенный Вами на форуме xorg.conf попала строчка 
> Driver "via"?
ради интереса поменял сегодня драйвер с openchrome на via. пишет нет такого
драйвера.
------- Comment #28 From 2009-09-07 17:04:56 -------
(В ответ на комментарий №27)
> (В ответ на комментарий №25)
> > А каким образом в приведенный Вами на форуме xorg.conf попала строчка 
> > Driver "via"?
> ради интереса поменял сегодня драйвер с openchrome на via. пишет нет такого
> драйвера.

Это правильно. Должен работать драйвер openchrome.
------- Comment #29 From 2009-09-07 17:16:28 -------
(В ответ на комментарий №28)
> Это правильно. Должен работать драйвер openchrome.
сейчас на домашнем компьютере установил мастер на виртуальную машину. он
говорит что много обновлений, в т.ч. драйвер для via видео.
есть ли смысл на проблемном компьютере из командной строки обновить драйвер?
или там какие-то другие исправления.
------- Comment #30 From 2009-09-07 17:53:12 -------
(В ответ на комментарий №29)
> (В ответ на комментарий №28)
> > Это правильно. Должен работать драйвер openchrome.
> сейчас на домашнем компьютере установил мастер на виртуальную машину. он
> говорит что много обновлений, в т.ч. драйвер для via видео.
> есть ли смысл на проблемном компьютере из командной строки обновить драйвер?
> или там какие-то другие исправления.

Да, стоит обновиться.
------- Comment #31 From 2009-09-08 14:28:15 -------
изменил в /etc/X11/xorg.conf драйвер на vesa - startx и после минутной паузы
KDE запустился и работает. правда еще полминуты после запуска не реагирует ни
на какие нажатия мышью или клавиатурой.
проблема вот в чем: запускаю синаптик - просит пароль рута. ввожу - говорит
ошибка! Permission denied
запускаю в консоли:
[root@inf01beta ~]# synaptic
(consolehelper:15532): Gdk-CRITICAL **: gdk_x11_atom_to_xatom_for_display:
assertion `atom != GDK_NONE' failed
(consolehelper:15532): Gdk-CRITICAL **: gdk_x11_atom_to_xatom_for_display:
assertion `atom != GDK_NONE' failed
------- Comment #32 From 2009-09-08 15:08:24 -------
Вместо synaptic можно войти в систему в консольном режиме (Ctrl+F1)
пользователем root и выполнить
apt-get update
apt-get dist-upgrade
если много обновлений, по окончанию можно Ctrl+Alt+Del
------- Comment #33 From 2009-09-08 16:41:49 -------
собственно обновил я драйвера. apt-get install _нужный_пакет_ - помогло.
с драйвером openchrome все равно не запускает иксы. а если прописать в
xorg.conf драйвер vesa, то получается вот что: загрузка ядра с параметром 3,
чтобы из командной строки, затем startx - KDE запускается, хоть и
подтормаживает в начале и т.н. графические "артефакты" присутствуют. а если
загрузка ядра безо всяких параметров, то он как и раньше зависает на черном
экране.
------- Comment #34 From 2009-09-18 12:25:54 -------
(В ответ на комментарий №33)
> собственно обновил я драйвера. apt-get install _нужный_пакет_ - помогло.
> с драйвером openchrome все равно не запускает иксы. а если прописать в
> xorg.conf драйвер vesa, то получается вот что: загрузка ядра с параметром 3,
> чтобы из командной строки, затем startx - KDE запускается, хоть и
> подтормаживает в начале и т.н. графические "артефакты" присутствуют. а если
> загрузка ядра безо всяких параметров, то он как и раньше зависает на черном
> экране.
экспериментирую дальше.
из командной строки пишу KDM - черный экран. но просто startx - все
запускается. так вот: где изменить чтобы автоматом он не запускал кдм, а сразу
иксы запускал? (надеюсь не слишком туманно объяснил)
------- Comment #35 From 2009-09-18 14:38:00 -------
(В ответ на комментарий №34)
> запускается. так вот: где изменить чтобы автоматом он не запускал кдм, а сразу
> иксы запускал? (надеюсь не слишком туманно объяснил)
Можно попробовать использовать xdm/gdm и настроить автоматический вход в DM.
------- Comment #36 From 2009-09-18 14:59:38 -------
(В ответ на комментарий №35)
> Можно попробовать использовать xdm/gdm и настроить автоматический вход в DM.
спасибо! тоже уже подумал про xdm.
а такой глупый вопрос: можно ли вообще обойтись без каких-либо (gkx)dm, и
гденить в другом месте прописать автоматический вход для пользователя? или
только (gkx)dm служат для таких целей?
------- Comment #37 From 2009-09-18 15:41:27 -------
(В ответ на комментарий №36)
> гденить в другом месте прописать автоматический вход для пользователя?
autologin
------- Comment #38 From 2009-09-21 22:15:30 -------
Описанная ошибка не воспроизводится на имеющихся картах VIA. Прошу проверить
новый драйвер.
------- Comment #39 From 2009-10-03 17:59:24 -------
обновил до самых последний драйверов, но ни с openchrome, ни с vesa по-прежнему
не запускается автоматом. из командной строки через startx только с vesa.

попробовал хитрость: установил autologin. прописал туда пользователя, в
/etc/inittab прописал
id:3:initdefault
а вместо x:5:respawn:/usr/bin/kdm -nodaemon
написал x:5:respawn:autologin -nodaemon
в итоге проходит загрузка, входит под пользователем, запускает иксы и...
монитор показывает, что отсутствует сигнал...
вопросы:
1. как теперь мне попасть хотябы в консоль?
2. сейчас пришло в голову, а может проблема в мониторе?
------- Comment #40 From 2009-10-11 13:53:04 -------
По воводу openchrome и kde4 посмотрите bug#20682
------- Comment #41 From 2011-07-18 14:29:43 -------
Дубликат

*** This bug has been marked as a duplicate of bug 20574 ***