Bug 21832 - crashes when opening an .xpi link
: crashes when opening an .xpi link
Status: CLOSED DUPLICATE of bug 21750
: Sisyphus
(All bugs in Sisyphus/seamonkey)
: unstable
: all Linux
: P3 normal
Assigned To:
:
: http://forum.addonsmirror.net/ext/ext...
:
:
:
  Show dependency tree
 
Reported: 2009-10-05 05:29 by
Modified: 2009-12-14 14:44 (History)


Attachments
the auto-generated bug report (30.78 KB, application/x-bzip)
2009-10-05 05:29, Ivan Zakharyaschev
no flags Details


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2009-10-05 05:29:28
Created an attachment (id=3958) [details]
the auto-generated bug report

seamonkey-1.1.18-alt1
$ rpm -qa '*seamonkey*'
seamonkey-ru-1.1-alt1
seamonkey-psm-1.1.18-alt1
seamonkey-webdeveloper-1.1.4-alt1
seamonkey-1.1.18-alt1
seamonkey-plugins-common-1.1.18-alt1
seamonkey-spellchecker-1.1.18-alt1
$ 

How to reproduce:

try to open the "download" link found at
http://forum.addonsmirror.net/index.php?showtopic=1906 -- it's a Thunderbird
plugin:

$ seamonkey
http://forum.addonsmirror.net/ext/extensions/T/TB_Header_Tools/TB_Header_Tools_0.6.6.xpi
LoadPlugin: failed to initialize shared library
/usr/lib/browser-plugins-npapi/nsdejavu.so
[/usr/lib/browser-plugins-npapi/nsdejavu.so: undefined symbol: XtShellStrings]
LoadPlugin: failed to initialize shared library
/usr/lib/browser-plugins-npapi/nsdejavu.so
[/usr/lib/browser-plugins-npapi/nsdejavu.so: undefined symbol: XtShellStrings]
LoadPlugin: failed to initialize shared library
/usr/lib/browser-plugins-npapi/nsdejavu.so
[/usr/lib/browser-plugins-npapi/nsdejavu.so: undefined symbol: XtShellStrings]
LoadPlugin: failed to initialize shared library
/usr/lib/browser-plugins-npapi/nsdejavu.so
[/usr/lib/browser-plugins-npapi/nsdejavu.so: undefined symbol: XtShellStrings]
30b44148-a20d-a0a5-064e4e1a-4495a3e2 is dumped
$
------- Comment #1 From 2009-11-28 08:00:08 -------
seamonkey-1.1.18-alt2, i586, пересобранный gcc4.1, этого не показал.
------- Comment #2 From 2009-12-14 14:44:25 -------
see also bug #22522

PS: did you try to rpm -e `rpm -qf /usr/lib/browser-plugins-npapi/nsdejavu.so`?

*** This bug has been marked as a duplicate of bug 21750 ***