Bug 26136 - firefox: rpminstall can't register apt:// protocol
: firefox: rpminstall can't register apt:// protocol
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/firefox-5.0)
: unstable
: all Linux
: P3 normal
Assigned To:
:
:
:
:
: 11503
  Show dependency tree
 
Reported: 2011-08-22 12:31 by
Modified: 2011-08-30 00:25 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2011-08-22 12:31:35
сейчас firefox не слинкован с gio, следовательно, заведомо не использует
системные настройки обработчиков mime-типов.

Правильнее собрать с --enable-gio, чтобы потом не разбираться, как в
https://bugzilla.altlinux.org/show_bug.cgi?id=11503
------- Comment #1 From 2011-08-22 12:48:25 -------
тест:
установить rpminstall
и набрать url вида
apt:mplayer.
при работе через gio должен запуситься rpminstall.
------- Comment #2 From 2011-08-22 14:27:37 -------
Как вы установили, что firefox не слинкован с libgio ?
------- Comment #3 From 2011-08-22 14:48:09 -------
(В ответ на комментарий №2)
> Как вы установили, что firefox не слинкован с libgio ?

$ rpmquery --requires -p firefox-5.0-5.0.1-alt1.x86_64.rpm | grep gio
------- Comment #4 From 2011-08-22 14:51:13 -------
$ rpmquery -R firefox-5.0 |grep xulrunner
xulrunner = 5.0.1

$ rpmquery -R xulrunner-5.0 |grep gio
libgio-2.0.so.0 >=
set:ojVHhvKCwaMwpVLAHtxjZjF03nsobcXicN6GKa4mtvykuYVWZ59Js2Qor1
------- Comment #5 From 2011-08-22 14:58:35 -------
(В ответ на комментарий №4)
гм. действительно.
Тогда непонятно, почему не работает регистрация протокола apt: в firefox.
в rpminstall есть /usr/lib64/firefox/defaults/preferences/apturl.js
pref("network.protocol-handler.app.apt","/usr/bin/rpminstall");
pref("network.protocol-handler.warn-external.apt",false);
pref("network.protocol-handler.external.apt",true);
есть и MimeType=x-scheme-handler/apt; в rpminstall.desktop.
Ни на одно из этих заклинаний firefox не реагирует, а должен
хотя бы реагировать на x-scheme-handler/apt, если работает через gio.
------- Comment #6 From 2011-08-22 15:06:26 -------
(В ответ на комментарий №5)
> в rpminstall есть /usr/lib64/firefox/defaults/preferences/apturl.js
> pref("network.protocol-handler.app.apt","/usr/bin/rpminstall");
> pref("network.protocol-handler.warn-external.apt",false);
> pref("network.protocol-handler.external.apt",true);

Эти опции больше не работают.

> есть и MimeType=x-scheme-handler/apt; в rpminstall.desktop.
> Ни на одно из этих заклинаний firefox не реагирует, а должен
> хотя бы реагировать на x-scheme-handler/apt, если работает через gio.

Вот об этом мне нужно подумать. Я оооочень плохо знаком с gio и добавив
--enable-gio я не знал как его проверить... чуда не случилось.
------- Comment #7 From 2011-08-22 15:07:27 -------
меняю название на firefox: rpminstall can't register apt:// protocol 
так как старое название содержало неверный диагноз
------- Comment #8 From 2011-08-22 15:11:55 -------
возможно, надо приложить патч
Patch 3 - Use GIO for protocol handler settings (v3) 
https://bugzilla.mozilla.org/attachment.cgi?id=518476
и другие патчи из
https://bugzilla.mozilla.org/show_bug.cgi?id=611953
------- Comment #9 From 2011-08-22 15:55:28 -------
(В ответ на комментарий №8)
> Patch 3 - Use GIO for protocol handler settings (v3) 

По крайней мере в 6.0 этот патч уже есть. Но я кажется нашёл ещё одно почему
может не работать. Так теперь вы показали usecase, то у меня есть на чём
проверять.
------- Comment #10 From 2011-08-24 10:46:50 -------
Проблему удалось решить task#52920.
------- Comment #11 From 2011-08-24 13:37:27 -------
(В ответ на комментарий №10)
> Проблему удалось решить task#52920.

Алексей,
а поменялись ли интерфейсы в ff-6.0? если нет, то не стоит ли до его смены
сделать, чтобы ff провайдил ff-5.0?
------- Comment #12 From 2011-08-24 13:59:04 -------
(В ответ на комментарий №11)
> а поменялись ли интерфейсы в ff-6.0? если нет, то не стоит ли до его смены
> сделать, чтобы ff провайдил ff-5.0?

Предлагаете провайдить с версией ?

Изменений только по xulrunner:

7838 files changed, 254148 insertions(+), 410536 deletions(-)
------- Comment #13 From 2011-08-30 00:25:48 -------
xulrunner-6.0-alt1 -> sisyphus:

* Sun Aug 21 2011 Alexey Gladkov <legion@altlinux> 6.0-alt1
- New release (6.0).
- Add nsGIOProtocolHandler extension (ALT#26136)
- Fixed:
  + MFSA 2011-29 Security issues addressed in Firefox6.

* Tue Aug 09 2011 Alexey Gladkov <legion@altlinux> 5.0.1-alt2
- Fix requires (ALT#26014).

* Thu Jul 14 2011 Alexey Gladkov <legion@altlinux> 5.0.1-alt1
- New major release (5.0.1).
- Remove gnome-support subpackage.
- Fixed:
  + MFSA 2011-28 Non-whitelisted site can trigger xpinstall
  + MFSA 2011-27 XSS encoding hazard with inline SVG
  + MFSA 2011-26 Multiple WebGL crashes
  + MFSA 2011-25 Stealing of cross-domain images using WebGL textures
  + MFSA 2011-22 Integer overflow and arbitrary code execution in
Array.reduceRight()
  + MFSA 2011-21 Memory corruption due to multipart/x-mixed-replace images
  + MFSA 2011-20 Use-after-free vulnerability when viewing XUL document with
script disabled
  + MFSA 2011-19 Miscellaneous memory safety hazards (rv:3.0/1.9.2.18)
  + MFSA 2011-18 XSLT generate-id() function heap address leak
  + MFSA 2011-17 WebGLES vulnerabilities
  + MFSA 2011-12 Miscellaneous memory safety hazards (rv:2.0.1/ 1.9.2.17/
1.9.1.19)