Bug 33223 - недостаточно Provides
Summary: недостаточно Provides
Status: CLOSED FIXED
Alias: None
Product: Sisyphus
Classification: Development
Component: liblua5.1-devel (show other bugs)
Version: unstable
Hardware: all Linux
: P3 normal
Assignee: Vladimir D. Seleznev
QA Contact: qa-sisyphus
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-03-09 17:52 MSK by Anton Farygin
Modified: 2017-03-10 09:44 MSK (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Anton Farygin 2017-03-09 17:52:58 MSK
Пакет почему-то не предоставляет то, что в p8 предоставляется liblua5-devel, в частности нету:
liblua5-devel = 5.1.5-alt11
из-за этого не получается поставить универсальную сборочную зависимость у пакета на liblua5-devel < 5.3

Просьба добавить в Sisyphus недостающие Provides.
Comment 1 viy 2017-03-09 17:59:41 MSK
lua5.3-devel/lua5.1-devel?
Comment 2 viy 2017-03-09 18:01:44 MSK
не могу, породит конфликты при сборке некоторых других пакетов
Comment 3 Vladimir D. Seleznev 2017-03-09 19:34:28 MSK
(В ответ на комментарий №2)
> не могу, породит конфликты при сборке некоторых других пакетов

Лучше пойти в другую сторону: сделать провайдс в liblua5-devel liblua5.1-devel в p8.
Comment 4 Anton Farygin 2017-03-09 20:38:09 MSK
Какие конфликты, не могли бы вы рассказать подробнее ?
Comment 5 viy 2017-03-09 20:45:58 MSK
BR: liblua5-devel
Comment 6 viy 2017-03-09 20:46:44 MSK
BuildReq: ----------------------------
ntop-4.1.0-alt1.1.src|liblua5-devel
desmume-0.9.8-alt1.src|liblua5-devel
highlight-3.13-alt1.src|liblua5-devel
conky-1.9.0-alt1.src|liblua5-devel
lua-module-luaexpat-1.3.0-alt1_lr1.src|liblua5-devel
lua-module-luafilesystem-1.6.2-alt1_lr2.src|liblua5-devel
luarocks-2.2.0-alt1.rc1.src|liblua5-devel
lua-module-copas-1.2.1-alt1_lr1.src|liblua5-devel
lua-module-coxpcall-1.15.0-alt1_lr1.src|liblua5-devel
lua-module-luasocket-3.0rc1-alt1_lr1.src|liblua5-devel
lua-module-mobdebug-0.55-alt1_lr1.src|liblua5-devel
lua-module-lua-parser-loose-0.1-alt3_lr1.git.g67f9007.src|liblua5-devel
libisdn-0.0.1-alt1.qa1.src|liblua5-devel
megaglest-3.9.2-alt1.7bf6fe75.src|liblua5-devel
xscript-5.63-alt24.8.1.src|liblua5-devel
asterisk13-13-alt0.417586.3.src|liblua5-devel
asterisk1.8-1.8.32.3-alt1.src|liblua5-devel
libkeybinder-0.3.0-alt4.git20120617.src|liblua5-devel
swift-3.0-alt1.beta2.src|liblua5-devel
mysql-workbench-community-6.3.4-alt2.src|liblua5-devel
bjs-0.1.3-alt3.2.src|liblua5-devel
asterisk11-11.21.0-alt1.src|liblua5-devel
mk-configure-0.29.1-alt1.src|liblua5-devel
ember-0.7.2-alt2_14.src.rpm.src|liblua5-devel
wesnoth1.10-1.10.7-alt3.qa1.src|liblua5-devel
nmap-5.51-alt1.1.qa1.src|liblua5-devel
verlihub-plugins-0.1-alt2.qa2.1.src|liblua5-devel
kdelibs-3.5.13.2-alt4.3.src|liblua5-devel
vlc-2.2.4-alt1.src|liblua5-devel
fceux-2.2.3-alt1.src|liblua5-devel
asterisk11cert-11.6.cert13-alt1.src|liblua5-devel
kde5-cantor-16.08.1-alt1.src|liblua5-devel
wesnoth-1.12.6-alt1.src|liblua5-devel
lua-module-luasec-0.6-alt1_lr1.src|liblua5-devel
prosody-0.9.10-alt2.src|liblua5-devel
rpm-4.13.0-alt7.src|liblua5-devel
apt-0.5.15lorg2-alt56.src|liblua5-devel
celestia-1.6.1-alt4.qa1.src|liblua5-devel
libgegl-0.2.0-alt4.src|liblua5-devel
asc-2.6.1.0-alt1.src|liblua5-devel
lgi-0.9.1-alt2.src|liblua5-devel
mpv-0.22.0-alt2.src|liblua5-devel
swig-3.0.12-alt1.src|liblua5-devel
libprelude-3.1.0-alt2_29.1.src|liblua5-devel
vim-8.0.170-alt1.1.src|liblua5-devel
...
Comment 7 Anton Farygin 2017-03-09 20:47:39 MSK
А в чём конфликт ? если два devel пакета с разными версиями будут провайдить одно и то-же, то никаких конфликтов быть не должно.

apt на apt-get install liblua5-devel должен установить последнюю версию (5.3).
Comment 8 Anton Farygin 2017-03-09 20:50:54 MSK
т.е. - provides то будет разный:
liblua5-devel = 5.1.5  это не одно и тоже что liblua5-devel = 5.3.0
Comment 9 Anton Farygin 2017-03-09 20:52:44 MSK
Вдобавок у вас ещё и конфликт прописан между liblua5.3-devel и liblua5.1-devel.
Comment 10 Anton Farygin 2017-03-09 20:55:03 MSK
Вот вам вдогонку пример правильных Provides:
$ rpm -q --provides gcc4.5 
gcc = 4.5.4-alt4
/usr/bin/gcc
/usr/bin/x86_64-alt-linux-gcc = 454
/usr/bin/x86_64-alt-linux-gcov = 454
/usr/share/man/man1/gcc.1.xz = 454
/usr/share/man/man1/gcov.1.xz = 454
gcc4.5 = 4.5.4-alt4

$ rpm -q --provides gcc5
gcc = 5.3.1
/usr/bin/gcc
/usr/bin/x86_64-alt-linux-gcc = 511
/usr/bin/x86_64-alt-linux-gcc-ar = 511
/usr/bin/x86_64-alt-linux-gcc-nm = 511
/usr/bin/x86_64-alt-linux-gcc-ranlib = 511
/usr/bin/x86_64-alt-linux-gcov = 511
/usr/bin/x86_64-alt-linux-gcov-tool = 511
/usr/share/man/man1/gcc.1.xz = 511
/usr/share/man/man1/gcov.1.xz = 511
gcc5 = 5.3.1-alt4


И никаких проблем нет. Пакеты вообще одновременно в системе стоят.
Comment 11 viy 2017-03-09 20:56:21 MSK
(In reply to comment #7)
> А в чём конфликт ? если два devel пакета с разными версиями будут провайдить
> одно и то-же, то никаких конфликтов быть не должно.
> 
> apt на apt-get install liblua5-devel должен установить последнюю версию (5.3).

там сейчас файловый конфликт.
Comment 12 Anton Farygin 2017-03-09 20:57:02 MSK
Не вижу никаких проблем.
Одновременно в систему два этих пакета никто тянуть не будет.
Comment 13 viy 2017-03-09 20:58:20 MSK
> И никаких проблем нет. Пакеты вообще одновременно в системе стоят.

там нет файловых конфликтов - альтернативы.

а здесь есть.
до меня так сложилось :(
Comment 14 viy 2017-03-09 20:59:09 MSK
(In reply to comment #12)
> Не вижу никаких проблем.
> Одновременно в систему два этих пакета никто тянуть не будет.

BR: liblua5-devel как раз это и сделает, если я бы provides добавил.
Comment 15 Anton Farygin 2017-03-09 21:00:12 MSK
Ну и что ? ну файловые конфликты. Я же не предлагаю Conflicts убрать.

Володя, Игорь говорит что ты так придумал.
Comment 16 Anton Farygin 2017-03-09 21:01:33 MSK
(In reply to comment #14)
> (In reply to comment #12)
> > Не вижу никаких проблем.
> > Одновременно в систему два этих пакета никто тянуть не будет.
> 
> BR: liblua5-devel как раз это и сделает, если я бы provides добавил.

Я не понял этой фразы. Что это он сделает ? потянет одновременно два пакета в систему по apt-get install liblua5-devel ?
apt выберет по умолчанию старшего из этих двух пакетов.
Comment 17 viy 2017-03-09 21:11:23 MSK
(In reply to comment #16)
> > BR: liblua5-devel как раз это и сделает, если я бы provides добавил.
> 
> Я не понял этой фразы. Что это он сделает ? потянет одновременно два пакета в
> систему по apt-get install liblua5-devel ?
> apt выберет по умолчанию старшего из этих двух пакетов.

Да, я чего-то такого и опасаюсь. Кроме того, хочу в перспективе вообще избавиться от liblua5-devel.
Comment 18 Anton Farygin 2017-03-09 21:13:07 MSK
Ну так что бы не опасаться - нужно понимать как apt работает. Ваши опасения беспочвенны.

А зачем избавляться от libluad5-devel ? что бы всё пересобирать ?
Давайте не будем ломать то, что работает.
Comment 19 viy 2017-03-09 21:21:30 MSK
(In reply to comment #18)
> Ну так что бы не опасаться - нужно понимать как apt работает. Ваши опасения
> беспочвенны.

Может быть, а может и не совсем. rpm -> rpm 4.13 apt -> yum?

> А зачем избавляться от liblua5-devel ? что бы всё пересобирать ?
> Давайте не будем ломать то, что работает.

Это спор о вкусах.
Можно в Provides писать, 
а можно в BR: lua5.1-devel написать.
Напишите, пожалуйста, BR: lua5.1-devel
Comment 20 Anton Farygin 2017-03-09 21:23:29 MSK
У вас в других бранчах нету такого Provides у liblua-devel, и такая разница заметно мне добавляет работы при выкладывании security update для wireshark.

Я сейчас соберу lua5.1 с нужным мне Provides и посмотрю на поведение apt'а в разных ситуациях.
Comment 21 viy 2017-03-09 21:28:18 MSK
(In reply to comment #20)
> У вас в других бранчах нету такого Provides у liblua-devel, и такая разница
> заметно мне добавляет работы при выкладывании security update для wireshark.
> 
> Я сейчас соберу lua5.1 с нужным мне Provides и посмотрю на поведение apt'а в
> разных ситуациях.

я в таких случаях (hplip, к примеру) пользуюсь
%ifwith backport
%else
%endif
Comment 22 Anton Farygin 2017-03-09 21:33:26 MSK
на мой взгляд идея обвязывать условиями спеки в тех случаях, когда этого можно было бы не делать не очень удачна.

Давайте лучше приведём в порядок lua или apt, если он не может выбрать по каким-то причинам нужные пакеты.
Comment 23 Anton Farygin 2017-03-09 21:38:09 MSK
Добавлю, что backport'а в вашем его понимании я не делаю, я собираю один и тот же тэг в разные бранчи.

Но наверное какие-то условия придумать можно.
Comment 24 Anton Farygin 2017-03-09 21:48:56 MSK
А про зависимость на asterisk-build-hacks что-то расскажете ?
Comment 25 viy 2017-03-09 22:02:23 MSK
(In reply to comment #23)
> Добавлю, что backport'а в вашем его понимании я не делаю, я собираю один и тот
> же тэг в разные бранчи.
> 
> Но наверное какие-то условия придумать можно.

%ubt ? ладно. Попробую.
Comment 26 viy 2017-03-09 22:04:22 MSK
(In reply to comment #24)
> А про зависимость на asterisk-build-hacks что-то расскажете ?

О. то был ужос-ужос.
он внутри таскал /usr/include/lua5.1.
Comment 27 viy 2017-03-09 22:04:53 MSK
(In reply to comment #25)
> (In reply to comment #23)
> > Добавлю, что backport'а в вашем его понимании я не делаю, я собираю один и тот
> > же тэг в разные бранчи.
> > 
> > Но наверное какие-то условия придумать можно.
> 
> %ubt ? ладно. Попробую.
task #179361: added #100: build tag "5.1.5-alt12" from /people/viy/packages/lua5.1.git
task #179361: try #1 is AWAITING, result will be emailed to viy@altlinux.org
Comment 28 Repository Robot 2017-03-09 22:11:43 MSK
lua5.1-5.1.5-alt12 -> sisyphus:

* Thu Mar 09 2017 Igor Vlasenko <viy@altlinux> 5.1.5-alt12
- added liblua5-devel provides (closes: #33223)
Comment 29 Anton Farygin 2017-03-09 22:14:11 MSK
не надо спешить, там есть проблемы.
Comment 30 Anton Farygin 2017-03-09 22:18:00 MSK
А у liblua5.1-compat-devel конфликт на liblua5-devel ещё надо убрать
Comment 31 viy 2017-03-09 22:23:23 MSK
(In reply to comment #30)
> А у liblua5.1-compat-devel конфликт на liblua5-devel ещё надо убрать

но там действительно файловый конфликт.
И с liblua5-devel <= 5.1.5-alt9
и с liblua5-devel >= 5.3.
Comment 32 Anton Farygin 2017-03-09 22:24:36 MSK
Убрал конфликт (локально) и всё поехало.

Иначе получается это:
Starting
Starting 2
Selected version liblua5.1-devel#5.1.5-alt12 for liblua5.1-devel<5.3.0
Investigating liblua5.1-compat-devel
Package liblua5.1-compat-devel has broken dep on liblua5-devel
  Considering liblua5.3-devel 0 as a solution to liblua5.1-compat-devel 0
  Holding Back liblua5.1-compat-devel rather than change liblua5-devel
Investigating liblua5.1-devel
Package liblua5.1-devel has broken dep on liblua5.1-compat-devel
  Considering liblua5.1-compat-devel 0 as a solution to liblua5.1-devel 10000
  Re-Instated liblua5.1-compat-devel
Investigating liblua5.1-compat-devel
Package liblua5.1-compat-devel has broken dep on liblua5-devel
  Considering liblua5.3-devel 0 as a solution to liblua5.1-compat-devel 0
  Holding Back liblua5.1-compat-devel rather than change liblua5-devel
Investigating liblua5.1-devel
Package liblua5.1-devel has broken dep on liblua5.1-compat-devel
  Considering liblua5.1-compat-devel 0 as a solution to liblua5.1-devel 10000
Done
Некоторые пакеты установить невозможно. Это может означать, что Вы
потребовали невозможного, либо пользуетесь нестабильным репозиторием.
Часть необходимых пакетов либо ещё не создана, либо была удалена
из каталога 'Входящие'.
Comment 33 Anton Farygin 2017-03-09 22:25:53 MSK
Для разрешения конфликтов достаточно вот этого:
Conflicts: liblua5.1-devel < 5.1.5-alt10
Conflicts: liblua4-devel
Conflicts: liblua5.3-devel
Comment 34 Anton Farygin 2017-03-09 22:26:57 MSK
если очень хочется то можно поставить Conflict на liblua5-devel > 5.3 но это масло масляное с Conflict на liblua5.3-devel
Comment 35 Repository Robot 2017-03-09 22:51:33 MSK
lua5.1-5.1.5-alt13 -> sisyphus:

* Thu Mar 09 2017 Igor Vlasenko <viy@altlinux> 5.1.5-alt13
- adjusted liblua5-devel conflicts (closes: #33223)
Comment 36 Anton Farygin 2017-03-10 09:44:17 MSK
всё работает, спасибо