Bug 3363 - licq crashes when starting with qt plugin
: licq crashes when starting with qt plugin
Status: CLOSED DUPLICATE of bug 3357
: Sisyphus
(All bugs in Sisyphus/licq)
: unstable
: all Linux
: P2 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2003-12-11 10:56 by
Modified: 2005-09-01 12:25 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2003-12-11 10:56:43
After dist-upgrade from Sisyphus 10.12.2003 when starting licq with qt plugin it
craches with this messages:
[srr@sabitov srr]$ licq
10:38:02: [WRN] Licq: Ignoring stale lockfile (pid 20670)
Licq Segmentation Violation Detected.
Backtrace:
licq(licq_handle_sigsegv+0xca) [0x80c5b2a]
/lib/libpthread.so.0 [0x25116b]
/lib/libc.so.6 [0x379288]
/lib/libc.so.6(__libc_free+0xb8) [0x3bd9a8]
/usr/X11R6/lib/X11/locale/lib/common/ximcp.so.2(_XimCheckIfLocalProcessing+0xa7)
[0x155b157]
/usr/X11R6/lib/X11/locale/lib/common/ximcp.so.2(_XimOpenIM+0x136) [0x155aa06]
/usr/X11R6/lib/libX11.so.6 [0xca6cf8]
/usr/X11R6/lib/X11/locale/lib/common/ximcp.so.2(_XimRegisterIMInstantiateCallback+0xdf)
[0x155a20f]
/usr/X11R6/lib/libX11.so.6 [0xca6e26]
/usr/X11R6/lib/libX11.so.6(XRegisterIMInstantiateCallback+0x5a) [0xc76e4a]
/usr/lib/qt3/lib/libqt-mt.so.3(_Z16qt_init_internalPiPPcP9_XDisplaymm+0x275)
[0x7394c5]
/usr/lib/qt3/lib/libqt-mt.so.3(_Z7qt_initPiPPcN12QApplication4TypeE+0x3e) [0x73b9ce]
/usr/lib/qt3/lib/libqt-mt.so.3(_ZN12QApplication9constructERiPPcNS_4TypeE+0x60)
[0x7997c0]
/usr/lib/qt3/lib/libqt-mt.so.3(_ZN12QApplicationC2ERiPPc+0x6c) [0x79940c]
/usr/lib/licq/licq_qt-gui.so(_ZN8CLicqGuiC1EiPPc+0x33) [0x4e0df3]
/usr/lib/licq/licq_qt-gui.so(LP_Main+0x4a) [0x4e02aa]
/usr/lib/licq/licq_qt-gui.so(LP_Main_tep+0x1f) [0x4dffef]
/lib/libpthread.so.0 [0x24e1f0]
/lib/libc.so.6(__clone+0x3a) [0x41a84a]
Attempting to generate core file.

[srr@sabitov srr]$ licq --help
licq version 1.2.7.
Usage:  Licq [-h] [-d #] [-b configdir] [-I] [-p plugin] [-o file] [ -- <plugin
#1 parameters>] [-- <plugin #2 parameters>...]

 -h : this help screen (and any plugin help screens as well)
 -d : set what information is logged to standard output:
        1  status information
        2  unknown packets
        4  errors
        8  warnings
       16  all packets
      add values together for multiple options
 -c : disable color at standard output
 -b : set the base directory for the config and data files (~/.licq by default)
 -I : force initialization of the given base directory
 -p : load the given plugin library
 -o : redirect stderr to <file>, which can be a device (ie /dev/ttyp4)
licq: invalid option -- e
licq: invalid option -- l
licq: option requires an argument -- p

[srr@sabitov srr]$ rpm -qa | grep licq
licq-1.2.7-alt4
licq-kde-1.2.7-alt4
licq-console-1.2.7-alt4
licq-maxi-1.2.7-alt4
licq-email-1.2.7-alt4
licq-common-1.2.7-alt4
alicq-0.8.6-alt4
licq-autoreply-1.2.7-alt4
licq-osd-1.2.7-alt4
licq-rms-1.2.7-alt4
licq-qt-1.2.7-alt4



Steps to Reproduce:
1. run licq -p qt
2.
3.
Actual Results:  
core file

Expected Results:  
licq qt interface
------- Comment #1 From 2003-12-11 11:22:01 -------

*** This bug has been marked as a duplicate of 3357 ***