Bug 5241 - wget could not retreive files larger than 2 Gb.
: wget could not retreive files larger than 2 Gb.
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/wget)
: unstable
: all Linux
: P2 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2004-09-23 12:54 by
Modified: 2005-08-30 02:04 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2004-09-23 12:54:06
--12:24:42-- 
ftp://satellit.immo/pub/distributions/w4r3z/Master2.4/20040916/dvdbin.iso
           => `satellit.immo/pub/distributions/w4r3z/Master2.4/20040916/dvdbin.iso'
==> CWD not required.
==> PASV ... done.    ==> RETR dvdbin.iso ... done.
Length: 291,713,024

100%[=========================================================================>]
2,145,827,104    7.28M/s    ETA 00:00File size limit exceeded

видимо, следует собрать с -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 ?

Steps to Reproduce:
1. взять iso от dvd версии alm24
2. попытаться скачать wget'om
Actual Results:  
File size limit exceeded.

Expected Results:  
должно скачаться без ошибок :)
------- Comment #1 From 2004-09-23 13:00:55 -------
> Actual Results:  
> File size limit exceeded.
> 
> Expected Results:  
> должно скачаться без ошибок :)

либо vsftpd не умеет отдавать файлы, размером > 2Gb. либо оба (wget и vsftpd) не
умеют работать с большими файлами.
------- Comment #2 From 2005-06-27 13:14:05 -------
2 algor: забирайте?
------- Comment #3 From 2005-06-27 13:14:35 -------
*** Bug 5686 has been marked as a duplicate of this bug. ***
------- Comment #4 From 2005-06-29 22:31:22 -------

*** This bug has been marked as a duplicate of 5043 ***
------- Comment #5 From 2005-06-29 23:05:38 -------
запутался
------- Comment #6 From 2005-06-29 23:07:38 -------
fixed in 1.10-alt1
------- Comment #7 From 2005-06-29 23:16:04 -------
дуп #5151, кстати.

PS: зря я жмакнул по UNCONFIRMED/NEW/ASSIGNED, надо было как обычно -- все
запросить.  ну и фиксить дупы по двум веткам параллельно не стоит. :]