Bug 5752 - Python crashes in import gtksourceview
: Python crashes in import gtksourceview
Status: CLOSED DUPLICATE of bug 6442
: Sisyphus
(All bugs in Sisyphus/python-module-pygnome-gtksourceview)
: unstable
: all Linux
: P2 blocker
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2004-12-21 03:09 by
Modified: 2005-06-01 00:47 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2004-12-21 03:09:08
[ktirf@twilight ~/src]$ python
Python 2.3.4 (#1, Nov 17 2004, 18:12:13)
[GCC 3.3.3 20040412 (ALT Linux, build 3.3.3-alt5)] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> import gtksourceview
Fatal Python error: can't initialise module gtksourceview
zsh: 28369 abort (core dumped)  python
[ktirf@twilight ~/src]$ gdb `which python` core
<...skipped...>
(gdb) where
#0  0xb7cc52c1 in kill () from /lib/i686/libc.so.6
#1  0xb7eb0181 in pthread_kill () from /lib/i686/libpthread.so.0
#2  0xb7eb04fb in raise () from /lib/i686/libpthread.so.0
#3  0xb7cc4f54 in raise () from /lib/i686/libc.so.6
#4  0xb7cc668d in abort () from /lib/i686/libc.so.6
#5  0xb7f8de9a in Py_FatalError () from /usr/lib/libpython2.3.so.1.0
#6  0xb7bbb830 in initgtksourceview ()
   from /usr/lib/python2.3/site-packages/gtk-2.0/gtksourceviewmodule.so
#7  0xb7f87330 in _PyImport_LoadDynamicModule ()
   from /usr/lib/libpython2.3.so.1.0
#8  0xb7f84fd3 in PyImport_ExecCodeModuleEx ()
   from /usr/lib/libpython2.3.so.1.0
#9  0xb7f85fc7 in PyImport_ImportModuleEx () from /usr/lib/libpython2.3.so.1.0
#10 0xb7f85a16 in PyImport_ImportModuleEx () from /usr/lib/libpython2.3.so.1.0
#11 0xb7f855b3 in PyImport_ImportModule () from /usr/lib/libpython2.3.so.1.0
#12 0xb7f8573c in PyImport_ImportModuleEx () from /usr/lib/libpython2.3.so.1.0
#13 0xb7f649b0 in _PyUnicodeUCS2_IsAlpha () from /usr/lib/libpython2.3.so.1.0
#14 0xb7f3d46d in PyCFunction_Call () from /usr/lib/libpython2.3.so.1.0
#15 0xb7f1b157 in PyObject_Call () from /usr/lib/libpython2.3.so.1.0
#16 0xb7f7026a in PyEval_CallObjectWithKeywords ()
   from /usr/lib/libpython2.3.so.1.0
#17 0xb7f6e16e in PyEval_EvalCode () from /usr/lib/libpython2.3.so.1.0
#18 0xb7f6ef5e in PyEval_EvalCodeEx () from /usr/lib/libpython2.3.so.1.0
---Type <return> to continue, or q <return> to quit---q
Quit
(gdb)

Версии: 
python-2.3.4-alt3
python-module-pygtk-2.5.0-alt3
python-module-pygnome-gtksourceview-2.9.1-alt2
libgtksourceview-1.1.1-alt1
------- Comment #1 From 2004-12-29 03:39:59 -------
Взял .src.rpm, пересобрал, установил. Не падает. Что в таких случаях полагается
делать?
------- Comment #2 From 2005-04-17 13:28:00 -------
исправлено 

*** This bug has been marked as a duplicate of 6442 ***
------- Comment #3 From 2005-06-01 00:47:56 -------
закрываю