Bug 6360 - реструктуризация
: реструктуризация
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/net-tools)
: unstable
: all Linux
: P2 enhancement
Assigned To:
:
:
:
: 6611 6871
: 7222 7223 7224 7225 7226 7227
  Show dependency tree
 
Reported: 2005-03-31 14:48 by
Modified: 2008-01-08 07:27 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2005-03-31 14:48:34
Есть предложение следующие файлы выделить в пакет net-tools-obsolete:
/sbin/arp
/sbin/ifconfig
/sbin/ipmaddr
/sbin/iptunnel
/sbin/nameif
/sbin/route
/usr/share/man/de_DE/man5/ethers.5.gz
/usr/share/man/de_DE/man8/arp.8.gz
/usr/share/man/de_DE/man8/ifconfig.8.gz
/usr/share/man/de_DE/man8/route.8.gz
/usr/share/man/fr_FR/man5/ethers.5.gz
/usr/share/man/fr_FR/man8/arp.8.gz
/usr/share/man/fr_FR/man8/ifconfig.8.gz
/usr/share/man/fr_FR/man8/route.8.gz
/usr/share/man/man5/ethers.5.gz
/usr/share/man/man8/arp.8.gz
/usr/share/man/man8/ifconfig.8.gz
/usr/share/man/man8/nameif.8.gz
/usr/share/man/man8/route.8.gz
/usr/share/man/pt_BR/man8/arp.8.gz
/usr/share/man/pt_BR/man8/ifconfig.8.gz
/usr/share/man/pt_BR/man8/route.8.gz
Далее можно будет продолжать: проконтролировать, чтобы этот пакет никто кроме
net-scripts не требовал и по умолчанию его не ставить.
------- Comment #1 From 2005-03-31 16:18:30 -------
Обсуждением решено наделить net-tools ролью obsolete и переместить:
в coreutils:
/bin/dnsdomainname
/bin/domainname
/bin/hostname
/bin/nisdomainname
/bin/ypdomainname

в iproute2:
/bin/netstat

в ethtool:
/sbin/mii-tool
/usr/sbin/ether-wake
------- Comment #2 From 2005-04-19 04:08:52 -------
netstat: лучше (пока?) оставить
{host,*domain}name: переехали в coreutils >= 0:5.3.1-alt0.2
resolve: переехало в hostinfo >= 0:2.2-alt2
ether-wake: не запаковать ли отдельно (как в Debian и Gentoo, см. напр.
http://packages.debian.org/testing/net/etherwake)?
------- Comment #3 From 2005-04-19 10:14:58 -------
Можно и отдельно, но mii-tool всё равно же в ethtool уходит, почему не слить
ether-wake туда же?
------- Comment #4 From 2005-04-19 18:05:38 -------
2 pilot: так переберёшь ethtool или мне?
------- Comment #5 From 2005-04-20 18:09:03 -------
Забираю ethtool.
------- Comment #6 From 2005-05-13 19:11:38 -------
mii-tool и ether-wake готовы
------- Comment #7 From 2005-05-16 14:12:50 -------
Насколько я понял, то что я получил при обновлении, не совсем сходится с 
результатом обсуждения: 
file /usr/sbin/ether-wake from install of ethtool-3-alt1 conflicts with file 
from package net-tools-1.60-alt10 
------- Comment #8 From 2005-05-16 14:43:21 -------
ethtool-3-alt1 предполагает обновлённый net-tools без лишних файлов. Нужно
скоординироваться и проставить Requires/Conflicts.
------- Comment #9 From 2005-05-16 17:46:24 -------
ethtool-3-alt2
Conflicts:      net-tools <= 1.60-alt10
------- Comment #10 From 2005-05-16 18:28:31 -------
Всё окончательно переехало в net-tools-1.60-alt11.
------- Comment #11 From 2005-05-17 11:05:59 -------
Пока что конфликт... Делаю ethtool-3-alt3
Conflicts:      net-tools <= 1.60-alt11
------- Comment #12 From 2005-05-17 19:28:31 -------
Ну теперь совсем окончательно переехало. :)
------- Comment #13 From 2005-05-18 14:26:46 -------
#6871 решился.
/bin/netstat
/usr/share/man/man8/netstat.8.gz
остались в net-tools-1.60-alt12, хотя просятся в iproute2.
------- Comment #14 From 2005-05-26 15:01:43 -------
А может всё-таки оставить старый netstat в старом пакете?
------- Comment #15 From 2005-06-23 03:57:18 -------
Ну, кажется, с этим всё.

Вот список исходных пакетов, из которых по-прежнему собирается нечто, зависящее
от net-tools:

amedyn-20040713-alt1.src.rpm
apache-1.3.33rusPL30.20-alt2.src.rpm
chkrootkit-0.45-alt1.src.rpm
cups-1.1.20-alt14.src.rpm
dhcp-3.0.2-alt1.src.rpm
dnsmasq-2.22-alt1.src.rpm
gnome-netinfo-0.99.0-alt0.6.src.rpm
gnome-nettool-1.2.0-alt1.src.rpm
kernel-modules-rtai-rt-up-3.2-alt1.1.src.rpm
kernel-source-dvb-20031013-alt2.1.src.rpm
mldonkey-2.6-alt0.3.src.rpm
net-scripts-0.5.4-alt2.src.rpm
openswan-1.0.9-alt1.src.rpm
pcmcia-cs-3.2.8-alt5.src.rpm
pptp-client-1.6.0-alt1.src.rpm
rgmanager-0.0.cvs20050330-alt1.src.rpm
rp-pppoe-3.5-alt16.src.rpm
snort-2.3.3-alt2.src.rpm
util-vserver-0.30-alt1.1.src.rpm
xemacs-net-utils-1.46-alt1.src.rpm
------- Comment #16 From 2005-06-23 17:04:53 -------
В смысле "надо проверить, что они дёргали из net-tools, переезжающего в
-obsolete"?
------- Comment #17 From 2005-06-23 17:22:39 -------
Именно в этом смысле.
------- Comment #18 From 2005-06-23 17:31:56 -------
2 at: а можно на эти багеты развесить "см. #6360"? :)