Bug 14380 - doesn't render Indic text correctly
: doesn't render Indic text correctly
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/firefox)
: unstable
: all Linux
: P2 major
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2008-02-10 13:06 by
Modified: 2008-12-20 23:12 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2008-02-10 13:06:05
firefox-2.0.0.11-alt1

Related topics:

http://en.wikipedia.org/wiki/Help:Multilingual_support_%28Indic%29#GNOME
http://en.wikipedia.org/wiki/Complex_Text_Layout

I don't know whether the required feature (ctl) is present in current stable
releases, if not, then it's a todo for future releases.

Steps to Reproduce:
1.Open http://hi.wikipedia.org/. (The pkg fonts-ttf-devanagari contains the font
used for Hindi.)
2.
3.
Actual Results:  
The vowel signs (the short "i") are not correctly placed (compare how
"vikipiiDiyaa" -- विकिपीडिया -- is written in the logo image and in the text).
There are no ligatures of consonants.

Expected Results:  
Correct rendering. For comparison, kdebase-konqueror-3.5.8-alt11 gives the
correct rendering.
------- Comment #1 From 2008-07-19 09:34:32 -------
Если я правильно понял проблему, то её больше нет.
------- Comment #2 From 2008-09-10 21:43:49 -------
*** Bug 14381 has been marked as a duplicate of this bug. ***
------- Comment #3 From 2008-09-11 18:08:40 -------
*** Bug 14381 has been marked as a duplicate of this bug. ***
------- Comment #4 From 2008-12-20 23:12:20 -------
Yes, thanks! Tested on firefox-3.0.4-alt0.M41.2.